summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2016-03-31 01:18:08 +0200
committerMarc Schiffbauer <mschiff@gentoo.org>2016-03-31 01:25:46 +0200
commit7fc710bc65bf3cc070bf3c0b7a8696ae83360afc (patch)
tree8b53a3c0c0af387b3b67ef3cc60afef61cfd72b8 /sci-geosciences
parentsci-geosciences/opencpn-plugin-ocpndebugger: bump version, add live version (diff)
downloadgentoo-7fc710bc65bf3cc070bf3c0b7a8696ae83360afc.tar.gz
gentoo-7fc710bc65bf3cc070bf3c0b7a8696ae83360afc.tar.bz2
gentoo-7fc710bc65bf3cc070bf3c0b7a8696ae83360afc.zip
sci-geosciences/opencpn-plugin-climatology: add live version
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/opencpn-plugin-climatology/opencpn-plugin-climatology-9999.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-climatology/opencpn-plugin-climatology-9999.ebuild b/sci-geosciences/opencpn-plugin-climatology/opencpn-plugin-climatology-9999.ebuild
new file mode 100644
index 000000000000..a318a294cdad
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-climatology/opencpn-plugin-climatology-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="climatology_pi"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/seandepagnier/${MY_PN}.git"
+ inherit git-r3 cmake-utils wxwidgets
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/seandepagnier/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ mirror://sourceforge/opencpnplugins/climatology_pi/CL-DATA-1.0.tar.xz -> ${P}-CL-DATA.tar.xz
+ "
+ inherit cmake-utils wxwidgets
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Climatology Plugin for OpenCPN (includes CL-DATA)"
+HOMEPAGE="https://github.com/seandepagnier/climatology_pi"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}
+src_install() {
+ cmake-utils_src_install
+ insinto "/usr/share/opencpn/plugins/${MY_PN}/data/"
+ doins "${S}"/{,../}data/*
+}