summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-29 10:49:55 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-29 10:50:36 +0200
commitbde1f53104418c74c9d78fabd1c1df70982dd411 (patch)
treedfc6a54ec51fcd2335b0252e47d26c630e1e1d9f /sci-geosciences
parentmedia-plugins/gimp-lensfun: Drop 0.2.4 (r0) (diff)
downloadgentoo-bde1f53104418c74c9d78fabd1c1df70982dd411.tar.gz
gentoo-bde1f53104418c74c9d78fabd1c1df70982dd411.tar.bz2
gentoo-bde1f53104418c74c9d78fabd1c1df70982dd411.zip
sci-geosciences/gpscorrelate: EAPI-7 bump, fix build w/ exiv2-0.27.1
Don't install cruft. Bug: https://bugs.gentoo.org/685926 Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gpscorrelate/files/gpscorrelate-1.6.1-exiv2-0.27.1.patch27
-rw-r--r--sci-geosciences/gpscorrelate/gpscorrelate-1.6.1-r1.ebuild55
2 files changed, 82 insertions, 0 deletions
diff --git a/sci-geosciences/gpscorrelate/files/gpscorrelate-1.6.1-exiv2-0.27.1.patch b/sci-geosciences/gpscorrelate/files/gpscorrelate-1.6.1-exiv2-0.27.1.patch
new file mode 100644
index 000000000000..16921b72a1f6
--- /dev/null
+++ b/sci-geosciences/gpscorrelate/files/gpscorrelate-1.6.1-exiv2-0.27.1.patch
@@ -0,0 +1,27 @@
+From c82aa1e76e3faeaec605df618c87223513efb3b9 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sat, 29 Jun 2019 10:27:24 +0200
+Subject: [PATCH] Fix build with exiv2-0.27.1
+
+Use catchall header as recommended by exiv2 upstream.
+---
+ exif-gps.cpp | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/exif-gps.cpp b/exif-gps.cpp
+index fb9f2cb..61b4736 100644
+--- a/exif-gps.cpp
++++ b/exif-gps.cpp
+@@ -41,8 +41,7 @@
+ #include <unistd.h>
+
+
+-#include "exiv2/image.hpp"
+-#include "exiv2/exif.hpp"
++#include "exiv2/exiv2.hpp"
+
+ #include "gpsstructure.h"
+ #include "exif-gps.h"
+--
+2.22.0
+
diff --git a/sci-geosciences/gpscorrelate/gpscorrelate-1.6.1-r1.ebuild b/sci-geosciences/gpscorrelate/gpscorrelate-1.6.1-r1.ebuild
new file mode 100644
index 000000000000..859bf5a9d68f
--- /dev/null
+++ b/sci-geosciences/gpscorrelate/gpscorrelate-1.6.1-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop toolchain-funcs
+
+DESCRIPTION="Tool for adjusting EXIF tags of your photos with a recorded GPS trace"
+HOMEPAGE="https://github.com/freefoote/gpscorrelate"
+SRC_URI="http://freefoote.dview.net/linux/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="doc gtk"
+
+BDEPEND="
+ app-text/docbook-xml-dtd:4.2
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/libxml2:2
+ media-gfx/exiv2:=
+ gtk? ( x11-libs/gtk+:2 )
+"
+DEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-makefile.patch"
+ "${FILESDIR}/${P}-exiv2-0.27.1.patch"
+)
+
+src_compile() {
+ tc-export CC CXX
+ local opts="gpscorrelate gpscorrelate.1"
+ use gtk && opts+=" gpscorrelate-gui BUILD_GUI=1"
+ emake ${opts}
+}
+
+src_install() {
+ dobin ${PN}
+ if use gtk; then
+ dobin ${PN}-gui
+ doicon ${PN}-gui.svg
+ domenu ${PN}.desktop
+ fi
+ if use doc; then
+ rm doc/gpscorrelate-manpage.xml* || die
+ local DOCS=()
+ local HTML_DOCS=( doc/. )
+ einstalldocs
+ fi
+ doman ${PN}.1
+}