summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-02-28 20:42:23 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-03-02 12:20:43 -0500
commit03f7fea8f7acaa6f32007d375e955e29aebb94b3 (patch)
tree18cf21661771207d993d7af09e3c1034a354b52f /sci-libs/amd
parentsci-libs/suitesparseconfig: new version 5.4.0. (diff)
downloadgentoo-03f7fea8f7acaa6f32007d375e955e29aebb94b3.tar.gz
gentoo-03f7fea8f7acaa6f32007d375e955e29aebb94b3.tar.bz2
gentoo-03f7fea8f7acaa6f32007d375e955e29aebb94b3.zip
sci-libs/amd: new version 2.4.6.
Update to EAPI=7 and fix the HOMEPAGE, SRC_URI, and LICENSE. This is part of a larger SuiteSparse v5.4.0 upgrade thanks to François Bissey whose sage-on-gentoo ebuilds I'm using. There's a newer release (v5.7.1) of SuiteSparse, but v5.4.0 has seen more testing. Closes: https://bugs.gentoo.org/680550 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/amd')
-rw-r--r--sci-libs/amd/Manifest1
-rw-r--r--sci-libs/amd/amd-2.4.6.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/sci-libs/amd/Manifest b/sci-libs/amd/Manifest
index 60d2d288f61c..90c50c2fda23 100644
--- a/sci-libs/amd/Manifest
+++ b/sci-libs/amd/Manifest
@@ -1 +1,2 @@
DIST amd-2.3.1.tar.bz2 339970 BLAKE2B b84b7b690deb6a1fcfdbbec403a3e5267cd4e1cf851312a56bbd48ac92a732f789365e2191f6b74f49173bc6c008ebd5f6b528a99a9abdc6a2777f3a6a7305b8 SHA512 19b8c010e0f7a5a96e60fe52904b2b548fb89dfaf9d6f99184df955a732ec3edef04acff01a82a909e030c3bf78c9eccfe0c329731edb29f4b936507e39d885e
+DIST amd-2.4.6.tar.bz2 343925 BLAKE2B 296579d888b61e84ec798206fbb6f89fd923f0d762e84e7a1e2e2a5fb502f4822f89a2a4b631dc42fa829e845bf3980886185650e8de28774400e0c351805061 SHA512 6960a557e6c2f82ca2e68e48ddcb502e1527235a3ca34df2f5f7f63f0f12afacedb15fefe4a39768fe7a2c70308793544b5b24b6f2be2c6b934b0c0e0e796d57
diff --git a/sci-libs/amd/amd-2.4.6.ebuild b/sci-libs/amd/amd-2.4.6.ebuild
new file mode 100644
index 000000000000..14e702a4e129
--- /dev/null
+++ b/sci-libs/amd/amd-2.4.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit fortran-2
+
+DESCRIPTION="Library to order a sparse matrix prior to Cholesky factorization"
+HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html"
+SRC_URI="http://202.36.178.9/sage/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc fortran static-libs"
+
+BDEPEND="virtual/pkgconfig
+ doc? ( virtual/latex-base )"
+DEPEND=">=sci-libs/suitesparseconfig-5.4.0"
+REPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable fortran) \
+ $(use_with doc) \
+ $(use_enable static-libs static)
+}