summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-12-26 11:32:45 +0100
committerSam James <sam@gentoo.org>2020-12-27 03:11:10 +0000
commitb41573ad26db26cb1ed156a4ea80bf3681784e49 (patch)
treebaf5c23c65a858e3dbc508e67dc6242dcd575479 /sci-libs/arpack
parentdev-util/hip: C++ Heterogeneous-Compute Interface for Portability. (diff)
downloadgentoo-b41573ad26db26cb1ed156a4ea80bf3681784e49.tar.gz
gentoo-b41573ad26db26cb1ed156a4ea80bf3681784e49.tar.bz2
gentoo-b41573ad26db26cb1ed156a4ea80bf3681784e49.zip
sci-libs/arpack: Bump to 3.8.0
Closes: https://bugs.gentoo.org/761292 Closes: https://bugs.gentoo.org/740222 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/arpack')
-rw-r--r--sci-libs/arpack/Manifest1
-rw-r--r--sci-libs/arpack/arpack-3.8.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/sci-libs/arpack/Manifest b/sci-libs/arpack/Manifest
index 78188d3b5d33..b578f3ff68d3 100644
--- a/sci-libs/arpack/Manifest
+++ b/sci-libs/arpack/Manifest
@@ -1,3 +1,4 @@
DIST arpack-3.7.0.tar.gz 989570 BLAKE2B bdab72f080d223ebbe5a279102d54fc196aac3ad1b8360be0e3814cb5e14e8f26a1f37b4b27b66db4b88b0c651c039666aa94a98fcdb34977feea7fc7d10808c SHA512 cc07cdd1fba4881907b507ff6b6c9bce9e3dadd8ef744194f08ee718a6210c039ac0c51c12edd720503f8e59bcd11c178fc323e1a59696be8c3b8262cf47a452
+DIST arpack-3.8.0.tar.gz 1014494 BLAKE2B 6daf8a237fdfce527935d777292df150b2f78892d9975f8696a37024fcb78174b29afd300e7abca2684c1907eeda658eb4478f09f580835896c0e10d106cdbbd SHA512 8969c74c4c0459ea2d29ea49d5260f668fd33f73886df0da78a42a94aea93c9f5fb70f5df035266db68807ab09a92c13487a7a4e6ca64922145aade8a148a2de
DIST tutorial.ps.gz 105599 BLAKE2B 99570e6a0cc1c020b9c271e8ce1cc224f69ff5333cc818c10b063dc8ffbaf66a9f5c6ede99541b4212286d422146b1c4e332eba7e1635c99efa0e4c2620f0630 SHA512 a7b8fefd1a572ed477ae208d49094c1c65c9368990d12de9b3528e33fed546c947659f74e54a810d04154b4a1b0f9a94bcba4db0cf59d379e20786a261066aa4
DIST ug.ps.gz 248543 BLAKE2B ac010aef470060636fa00360636ba093f0d24d219fa927c79fb1726b798160eda74fa8b4be6c7dff94f5759efcf30afa99ad310e7959115e028738beb8aa125d SHA512 3349117fb10b07207ffbab2ffa31b406d026855ea4c16e8649b14c7d70bc94e11b5730672e34acd654817799136d4bd76569ac50ec78d787df5582d18ed61328
diff --git a/sci-libs/arpack/arpack-3.8.0.ebuild b/sci-libs/arpack/arpack-3.8.0.ebuild
new file mode 100644
index 000000000000..e5986de25b70
--- /dev/null
+++ b/sci-libs/arpack/arpack-3.8.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools fortran-2 toolchain-funcs
+
+DESCRIPTION="Arnoldi package library to solve large scale eigenvalue problems"
+HOMEPAGE="http://www.caam.rice.edu/software/ARPACK/ https://github.com/opencollab/arpack-ng"
+SRC_URI="
+ https://github.com/opencollab/${PN}-ng/archive/${PV}.tar.gz -> ${P}.tar.gz
+ doc? (
+ http://www.caam.rice.edu/software/ARPACK/SRC/ug.ps.gz
+ http://www.caam.rice.edu/software/ARPACK/DOCS/tutorial.ps.gz )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc examples mpi"
+
+RDEPEND="
+ virtual/blas
+ virtual/lapack
+ mpi? ( virtual/mpi[fortran] )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}-ng-${PV}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)" \
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)" \
+ $(use_enable mpi)
+}
+
+src_install() {
+ default
+
+ dodoc DOCUMENTS/*.doc
+ newdoc DOCUMENTS/README README.doc
+ use doc && dodoc "${WORKDIR}"/*.ps
+ if use examples; then
+ dodoc -r EXAMPLES
+ if use mpi; then
+ docinto EXAMPLES/PARPACK
+ dodoc -r PARPACK/EXAMPLES/MPI
+ fi
+ fi
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}