summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/arprec
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/arprec')
-rw-r--r--sci-libs/arprec/Manifest2
-rw-r--r--sci-libs/arprec/arprec-2.2.16.ebuild55
-rw-r--r--sci-libs/arprec/arprec-2.2.17.ebuild56
-rw-r--r--sci-libs/arprec/metadata.xml15
4 files changed, 128 insertions, 0 deletions
diff --git a/sci-libs/arprec/Manifest b/sci-libs/arprec/Manifest
new file mode 100644
index 000000000000..87356081d5b7
--- /dev/null
+++ b/sci-libs/arprec/Manifest
@@ -0,0 +1,2 @@
+DIST arprec-2.2.16.tar.gz 830227 SHA256 cf71f2a7f3530b57900e67d1282c4a114830d2c00a0fba90819aa8313f11653f SHA512 278bf96402179566d4f2b9a6d69e42d726c81c814f96cd31c19df2c3b61941f3a1858e4a56577548d0fcf526b7db7caca2b7ea7ec57e834e7768d21788e7e672 WHIRLPOOL c55a875af752dfe6700cd714e2d6d34d3100676b8c41d4271065ddb0e754b3c5333cffd7432b45f2dfa0efed8f93dfd3448ac87038b18941a27f6bed1468131c
+DIST arprec-2.2.17.tar.gz 900043 SHA256 87977981c1145465da51f252d04f11d16ee009d9dc7e8d0da71e4ef56b9fc5eb SHA512 d10f7d3e3d61274a36d253d2b50004bbf15447be3ffbd37bb0334ba62bd624e27fb9e26364fa1b89c1d4dfbb4136ab93d865f990ce123ecf94d9614e3ac567d1 WHIRLPOOL 6daeff384cfc9dfbb5771a177166212370ba724850d27ae99de63d1e2f2bc5f76b2be5c28e1fa0bb1d407a29d46212b0896c5e7f6ba66f9c2830e3a53e3e8b31
diff --git a/sci-libs/arprec/arprec-2.2.16.ebuild b/sci-libs/arprec/arprec-2.2.16.ebuild
new file mode 100644
index 000000000000..e467be41e889
--- /dev/null
+++ b/sci-libs/arprec/arprec-2.2.16.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+FORTRAN_NEEDED=fortran
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit eutils fortran-2 autotools-utils
+
+DESCRIPTION="Arbitrary precision float arithmetics and functions"
+HOMEPAGE="http://crd.lbl.gov/~dhbailey/mpdist/"
+SRC_URI="http://crd.lbl.gov/~dhbailey/mpdist/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc cpu_flags_x86_fma3 cpu_flags_x86_fma4 fortran qd static-libs"
+
+DEPEND="qd? ( sci-libs/qd[fortran=] )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ $(use_enable "cpu_flags_x86_fma$(usex cpu_flags_x86_fma3 3 4)" fma)
+ $(use_enable fortran)
+ $(use_enable qd)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use fortran && autotools-utils_src_compile toolkit
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use fortran; then
+ cd toolkit
+ ./mathinit || die "mathinit failed"
+ exeinto /usr/libexec/${PN}
+ doexe .libs/mathtool
+ insinto /usr/libexec/${PN}
+ doins *.dat
+ echo > mathtool.exe "#!${EROOT}/bin/sh"
+ echo >> mathtool.exe "cd ${EROOT}/usr/libexec/arprec && exec ./mathtool"
+ newbin mathtool.exe mathtool
+ newdoc README README.mathtool
+ fi
+ use doc || rm "${ED}"/usr/share/doc/${PF}/*.pdf
+}
diff --git a/sci-libs/arprec/arprec-2.2.17.ebuild b/sci-libs/arprec/arprec-2.2.17.ebuild
new file mode 100644
index 000000000000..b5e9fe326944
--- /dev/null
+++ b/sci-libs/arprec/arprec-2.2.17.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+FORTRAN_NEEDED=fortran
+FORTRAN_STANDARD="90"
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit eutils fortran-2 autotools-utils
+
+DESCRIPTION="Arbitrary precision float arithmetics and functions"
+HOMEPAGE="http://crd.lbl.gov/~dhbailey/mpdist/"
+SRC_URI="http://crd.lbl.gov/~dhbailey/mpdist/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc cpu_flags_x86_fma3 cpu_flags_x86_fma4 fortran qd static-libs"
+
+DEPEND="qd? ( sci-libs/qd:0=[fortran=] )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ $(use_enable "cpu_flags_x86_fma$(usex cpu_flags_x86_fma3 3 4)" fma)
+ $(use_enable fortran)
+ $(use_enable qd)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use fortran && autotools-utils_src_compile toolkit
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use fortran; then
+ cd toolkit
+ ./mathinit || die "mathinit failed"
+ exeinto /usr/libexec/${PN}
+ doexe .libs/mathtool
+ insinto /usr/libexec/${PN}
+ doins *.dat
+ echo > mathtool.exe "#!${EROOT%/}/bin/sh"
+ echo >> mathtool.exe "cd ${EROOT%/}/usr/libexec/arprec && exec ./mathtool"
+ newbin mathtool.exe mathtool
+ newdoc README README.mathtool
+ fi
+ use doc || rm "${ED}"/usr/share/doc/${PF}/*.pdf
+}
diff --git a/sci-libs/arprec/metadata.xml b/sci-libs/arprec/metadata.xml
new file mode 100644
index 000000000000..f5a8029c8896
--- /dev/null
+++ b/sci-libs/arprec/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+<maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+</maintainer>
+<longdescription>
+ Arbitrary precision library for float arithmetics and mathematical functions.
+</longdescription>
+<use>
+ <flag name="qd">Use <pkg>sci-libs/qd</pkg> for quad-double datatype</flag>
+</use>
+</pkgmetadata>