summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2016-09-25 12:37:57 -0500
committerMatthias Maier <tamiko@gentoo.org>2016-09-25 12:39:05 -0500
commitd40c661a09fcd2a4a0a38186fb89659a30487233 (patch)
tree627be00bcfb46fc5d8f1c783451f98d0c3d28ef4 /sci-libs/blas-reference/blas-reference-20151113-r1.ebuild
parentmail-mta/postfix: version bump to 3.2_pre20160924 (diff)
downloadgentoo-d40c661a09fcd2a4a0a38186fb89659a30487233.tar.gz
gentoo-d40c661a09fcd2a4a0a38186fb89659a30487233.tar.bz2
gentoo-d40c661a09fcd2a4a0a38186fb89659a30487233.zip
sci-libs/blas-reference: fix eselect blas alternative, bug #595102
Also set the libblas.so.3 symlink. Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-libs/blas-reference/blas-reference-20151113-r1.ebuild')
-rw-r--r--sci-libs/blas-reference/blas-reference-20151113-r1.ebuild93
1 files changed, 93 insertions, 0 deletions
diff --git a/sci-libs/blas-reference/blas-reference-20151113-r1.ebuild b/sci-libs/blas-reference/blas-reference-20151113-r1.ebuild
new file mode 100644
index 000000000000..d5c4ac3829a5
--- /dev/null
+++ b/sci-libs/blas-reference/blas-reference-20151113-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils fortran-2 cmake-utils multilib flag-o-matic toolchain-funcs
+
+LPN=lapack
+LPV=3.6.0
+
+DESCRIPTION="Basic Linear Algebra Subprograms F77 reference implementations"
+HOMEPAGE="http://www.netlib.org/blas/"
+SRC_URI="http://www.netlib.org/${LPN}/${LPN}-${LPV}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="doc"
+
+DEPEND="app-eselect/eselect-blas"
+RDEPEND="${DEPEND}
+ doc? ( app-doc/blas-docs )
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${LPN}-${LPV}"
+PATCHES=( "${FILESDIR}/lapack-fix-build-system.patch" )
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+
+ eapply_user
+
+ ESELECT_PROF=reference
+
+ cp "${FILESDIR}"/eselect.blas.reference-r1 "${T}"/eselect.blas.reference || die
+ sed -i -e "s:/usr:${EPREFIX}/usr:" "${T}"/eselect.blas.reference || die
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ sed -i -e 's/\.so\([\.0-9]\+\)\?/\1.dylib/g' \
+ "${T}"/eselect.blas.reference || die
+ fi
+}
+
+src_configure() {
+ local FCFLAGS="${FCFLAGS}"
+ append-fflags $($(tc-getPKG_CONFIG) --cflags ${blas_profname})
+ append-fflags $(get_abi_CFLAGS)
+ append-fflags $(numeric-int64_get_fortran_int64_abi_fflags)
+
+ local mycmakeargs=(
+ -Wno-dev
+ -DUSE_OPTIMIZED_BLAS=OFF
+ -DCMAKE_Fortran_FLAGS="${FCFLAGS}"
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_STATIC_LIBS=ON
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ local each target_dirs=( BLAS )
+ for each in ${target_dirs[@]}; do
+ cmake-utils_src_compile -C ${each}
+ done
+}
+
+src_install() {
+ cmake-utils_src_install -C BLAS
+
+ mkdir -p "${ED}/usr/$(get_libdir)/blas/reference" || die
+ mv "${ED}/usr/$(get_libdir)"/lib* "${ED}/usr/$(get_libdir)/pkgconfig"/* \
+ "${ED}/usr/$(get_libdir)/blas/reference" || die
+ rmdir "${ED}/usr/$(get_libdir)/pkgconfig" || die
+
+ eselect blas add $(get_libdir) "${T}"/eselect.blas.reference ${ESELECT_PROF}
+}
+
+pkg_postinst() {
+ local p=blas
+ local current_lib=$(eselect ${p} show | cut -d' ' -f2)
+ if [[ ${current_lib} == ${ESELECT_PROF} || -z ${current_lib} ]]; then
+ # work around eselect bug #189942
+ local configfile="${EROOT}"/etc/env.d/${p}/$(get_libdir)/config
+ [[ -e ${configfile} ]] && rm -f ${configfile}
+ eselect ${p} set ${ESELECT_PROF}
+ elog "${p} has been eselected to ${ESELECT_PROF}"
+ else
+ elog "Current eselected ${p} is ${current_lib}"
+ elog "To use ${p} ${ESELECT_PROF} implementation, you have to issue (as root):"
+ elog "\t eselect ${p} set ${ESELECT_PROF}"
+ fi
+}