summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMo Zhou <cdluminate@gmail.com>2019-06-26 02:41:35 +0000
committerBenda Xu <heroxbd@gentoo.org>2019-06-26 14:06:10 +0800
commit914aebf44db94fad75de5781a770ffdc97cd38a3 (patch)
tree8f07567d8477072e985305f3ede3fb4ad7937bb8 /sci-libs/blis
parentsci-libs/lapack: add eselect-ldso USE flag. (diff)
downloadgentoo-914aebf44db94fad75de5781a770ffdc97cd38a3.tar.gz
gentoo-914aebf44db94fad75de5781a770ffdc97cd38a3.tar.bz2
gentoo-914aebf44db94fad75de5781a770ffdc97cd38a3.zip
sci-libs/blis: new BLIS package as an BLAS/CBLAS alternative.
Closes: https://github.com/gentoo/gentoo/pull/12322 Signed-off-by: Mo Zhou <cdluminate@gmail.com> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sci-libs/blis')
-rw-r--r--sci-libs/blis/Manifest1
-rw-r--r--sci-libs/blis/blis-0.5.2.ebuild107
-rw-r--r--sci-libs/blis/files/blas.lds15
-rw-r--r--sci-libs/blis/files/blis-0.5.2-blas-provider.patch13
-rw-r--r--sci-libs/blis/files/blis-0.5.2-gh313.patch187
-rw-r--r--sci-libs/blis/files/blis-0.5.2-rpath.patch13
-rw-r--r--sci-libs/blis/files/cblas.lds15
-rw-r--r--sci-libs/blis/metadata.xml30
8 files changed, 381 insertions, 0 deletions
diff --git a/sci-libs/blis/Manifest b/sci-libs/blis/Manifest
new file mode 100644
index 000000000000..7d42eadf47b8
--- /dev/null
+++ b/sci-libs/blis/Manifest
@@ -0,0 +1 @@
+DIST blis-0.5.2.tar.gz 3502383 BLAKE2B b09fda20711086c8bde0d4efc3f3c9b0f6072e1ddb8bd2846465877f0353cced27548abe1239b6a042fe655e85e4b7b3c960322e39b2c733866b8e17777718bd SHA512 4f91a7834ef0ed39544dd21856814467416a222240050cca323917b0fc61b9201ae4dbd109aa687cdecb27ddee5d6bf4510ef023e1c1dc73599faef0482d3d04
diff --git a/sci-libs/blis/blis-0.5.2.ebuild b/sci-libs/blis/blis-0.5.2.ebuild
new file mode 100644
index 000000000000..939d0b608d65
--- /dev/null
+++ b/sci-libs/blis/blis-0.5.2.ebuild
@@ -0,0 +1,107 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils
+
+DESCRIPTION="BLAS-like Library Instantiation Software Framework"
+HOMEPAGE="https://github.com/flame/blis"
+SRC_URI="https://github.com/flame/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="openmp pthread serial static-libs eselect-ldso doc 64bit-index"
+REQUIRED_USE="?? ( openmp pthread serial ) ?? ( eselect-ldso 64bit-index )"
+
+RDEPEND="eselect-ldso? ( !app-eselect/eselect-cblas
+ >=app-eselect/eselect-blas-0.2 )"
+
+DEPEND="${RDEPEND}
+ dev-lang/python
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-rpath.patch"
+ "${FILESDIR}/${P}-blas-provider.patch"
+ "${FILESDIR}/${P}-gh313.patch"
+)
+
+src_configure () {
+ local BLIS_FLAGS=()
+ local confname
+ # determine flags
+ if use openmp; then
+ BLIS_FLAGS+=( -t openmp )
+ elif use pthread; then
+ BLIS_FLAGS+=( -t pthreads )
+ else
+ BLIS_FLAGS+=( -t no )
+ fi
+ use 64bit-index && BLIS_FLAGS+=( -b 64 -i 64 )
+ # determine config name
+ case "${ARCH}" in
+ "x86" | "amd64")
+ confname=auto ;;
+ "ppc64")
+ confname=generic ;;
+ *)
+ confname=generic ;;
+ esac
+ # This is not an autotools configure file. We don't use econf here.
+ ./configure \
+ --enable-verbose-make \
+ --prefix="${BROOT}"/usr \
+ --libdir="${BROOT}"/usr/$(get_libdir) \
+ $(use_enable static-libs static) \
+ --enable-blas \
+ --enable-cblas \
+ ${BLIS_FLAGS[@]} \
+ --enable-shared \
+ $confname || die
+}
+
+src_compile() {
+ DEB_LIBBLAS=libblas.so.3 DEB_LIBCBLAS=libcblas.so.3 \
+ LDS_BLAS="${FILESDIR}"/blas.lds LDS_CBLAS="${FILESDIR}"/cblas.lds \
+ default
+}
+
+src_test () {
+ emake check
+}
+
+src_install () {
+ default
+ use doc && dodoc README.md docs/*.md
+
+ if use eselect-ldso; then
+ dodir /usr/$(get_libdir)/blas/blis
+ insinto /usr/$(get_libdir)/blas/blis
+ doins lib/*/lib{c,}blas.so.3
+ dosym libblas.so.3 usr/$(get_libdir)/blas/blis/libblas.so
+ dosym libcblas.so.3 usr/$(get_libdir)/blas/blis/libcblas.so
+ fi
+}
+
+pkg_postinst() {
+ use eselect-ldso || return
+
+ local libdir=$(get_libdir) me="blis"
+
+ # check blas
+ eselect blas add ${libdir} "${EROOT}"/usr/${libdir}/blas/${me} ${me}
+ local current_blas=$(eselect blas show ${libdir})
+ if [[ ${current_blas} == blis || -z ${current_blas} ]]; then
+ eselect blas set ${libdir} ${me}
+ elog "Current eselect: BLAS/CBLAS ($libdir) -> [${current_blas}]."
+ else
+ elog "Current eselect: BLAS/CBLAS ($libdir) -> [${current_blas}]."
+ elog "To use blas [${me}] implementation, you have to issue (as root):"
+ elog "\t eselect blas set ${libdir} ${me}"
+ fi
+}
+
+pkg_postrm() {
+ use eselect-ldso && eselect blas validate
+}
diff --git a/sci-libs/blis/files/blas.lds b/sci-libs/blis/files/blas.lds
new file mode 100644
index 000000000000..db79d3bc9054
--- /dev/null
+++ b/sci-libs/blis/files/blas.lds
@@ -0,0 +1,15 @@
+{
+ # Export BLAS symbols
+ global:
+ *_;
+ RowMajorStrg;
+
+ # Hide everything else.
+ local:
+ cblas_*;
+ CBLAS_*;
+ bli_thread_set_num_threads_;
+ bli_thread_set_ways_;
+ bli_*;
+ *;
+};
diff --git a/sci-libs/blis/files/blis-0.5.2-blas-provider.patch b/sci-libs/blis/files/blis-0.5.2-blas-provider.patch
new file mode 100644
index 000000000000..5999f847929c
--- /dev/null
+++ b/sci-libs/blis/files/blis-0.5.2-blas-provider.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 2d31fee..7008682 100644
+--- a/Makefile
++++ b/Makefile
+@@ -659,6 +659,8 @@ else
+ @$(LINKER) $(SOFLAGS) -o $(LIBBLIS_SO_OUTPUT_NAME) $? $(LDFLAGS)
+ endif
+ endif
++ $(LINKER) $(SOFLAGS) -o $(BASE_LIB_PATH)/$(DEB_LIBBLAS) $? $(LDFLAGS) -Wl,--soname,$(DEB_LIBBLAS) -Wl,--version-script=$(LDS_BLAS)
++ $(LINKER) $(SOFLAGS) -o $(BASE_LIB_PATH)/$(DEB_LIBCBLAS) $? $(LDFLAGS) -Wl,--soname,$(DEB_LIBCBLAS) -Wl,--version-script=$(LDS_CBLAS)
+
+ # Local symlink for shared library.
+ # NOTE: We use a '.loc' suffix to avoid filename collisions in case this
diff --git a/sci-libs/blis/files/blis-0.5.2-gh313.patch b/sci-libs/blis/files/blis-0.5.2-gh313.patch
new file mode 100644
index 000000000000..fab3a8a09ee3
--- /dev/null
+++ b/sci-libs/blis/files/blis-0.5.2-gh313.patch
@@ -0,0 +1,187 @@
+diff --git a/common.mk b/common.mk
+index 5513098a5..999df774b 100644
+--- a/common.mk
++++ b/common.mk
+@@ -118,7 +118,8 @@ get-noopt-cxxflags-for = $(strip $(CFLAGS_PRESET) \
+ get-refinit-cflags-for = $(strip $(call load-var-for,COPTFLAGS,$(1)) \
+ $(call get-noopt-cflags-for,$(1)) \
+ -DBLIS_CNAME=$(1) \
+- $(BUILD_FLAGS) \
++ $(BUILD_CPPFLAGS) \
++ $(BUILD_SYMFLAGS) \
+ )
+
+ get-refkern-cflags-for = $(strip $(call load-var-for,CROPTFLAGS,$(1)) \
+@@ -126,23 +127,27 @@ get-refkern-cflags-for = $(strip $(call load-var-for,CROPTFLAGS,$(1)) \
+ $(call get-noopt-cflags-for,$(1)) \
+ $(COMPSIMDFLAGS) \
+ -DBLIS_CNAME=$(1) \
+- $(BUILD_FLAGS) \
++ $(BUILD_CPPFLAGS) \
++ $(BUILD_SYMFLAGS) \
+ )
+
+ get-config-cflags-for = $(strip $(call load-var-for,COPTFLAGS,$(1)) \
+ $(call get-noopt-cflags-for,$(1)) \
+- $(BUILD_FLAGS) \
++ $(BUILD_CPPFLAGS) \
++ $(BUILD_SYMFLAGS) \
+ )
+
+ get-frame-cflags-for = $(strip $(call load-var-for,COPTFLAGS,$(1)) \
+ $(call get-noopt-cflags-for,$(1)) \
+- $(BUILD_FLAGS) \
++ $(BUILD_CPPFLAGS) \
++ $(BUILD_SYMFLAGS) \
+ )
+
+ get-kernel-cflags-for = $(strip $(call load-var-for,CKOPTFLAGS,$(1)) \
+ $(call load-var-for,CKVECFLAGS,$(1)) \
+ $(call get-noopt-cflags-for,$(1)) \
+- $(BUILD_FLAGS) \
++ $(BUILD_CPPFLAGS) \
++ $(BUILD_SYMFLAGS) \
+ )
+
+ # When compiling sandboxes, we use flags similar to those of general framework
+@@ -153,19 +158,24 @@ get-kernel-cflags-for = $(strip $(call load-var-for,CKOPTFLAGS,$(1)) \
+ get-sandbox-c99flags-for = $(strip $(call load-var-for,COPTFLAGS,$(1)) \
+ $(call get-noopt-cflags-for,$(1)) \
+ $(CSBOXINCFLAGS) \
+- $(BUILD_FLAGS) \
++ $(BUILD_CPPFLAGS) \
++ $(BUILD_SYMFLAGS) \
+ )
+ get-sandbox-cxxflags-for = $(strip $(call load-var-for,COPTFLAGS,$(1)) \
+ $(call get-noopt-cxxflags-for,$(1)) \
+ $(CSBOXINCFLAGS) \
+- $(BUILD_FLAGS) \
++ $(BUILD_CPPFLAGS) \
++ $(BUILD_SYMFLAGS) \
+ )
+
+ # Define a separate function that will return appropriate flags for use by
+ # applications that want to use the same basic flags as those used when BLIS
+-# was compiled. (This is the same as get-frame-cflags-for(), except that it
+-# omits the BUILD_FLAGS, which are exclusively for use when BLIS is being
+-# compiled.)
++# was compiled. (NOTE: This is the same as the $(get-frame-cflags-for ...)
++# function, except that it omits two variables that contain flags exclusively
++# for use when BLIS is being compiled/built: BUILD_CPPFLAGS, which contains a
++# cpp macro that confirms that BLIS is being built; and BUILD_SYMFLAGS, which
++# contains symbol export flags that are only needed when a shared library is
++# being compiled/linked.)
+ get-user-cflags-for = $(strip $(call load-var-for,COPTFLAGS,$(1)) \
+ $(call get-noopt-cflags-for,$(1)) \
+ )
+@@ -627,22 +637,26 @@ $(foreach c, $(CONFIG_LIST_FAM), $(eval $(call append-var-for,CPICFLAGS,$(c))))
+
+ # --- Symbol exporting flags (shared libraries only) ---
+
++# NOTE: These flags are only applied when building BLIS and not used by
++# applications that import BLIS compilation flags via the
++# $(get-user-cflags-for ...) function.
++
+ # Determine default export behavior / visibility of symbols for gcc.
+ ifeq ($(CC_VENDOR),gcc)
+ ifeq ($(IS_WIN),yes)
+ ifeq ($(EXPORT_SHARED),all)
+-CMISCFLAGS := -Wl,--export-all-symbols, -Wl,--enable-auto-import
++BUILD_SYMFLAGS := -Wl,--export-all-symbols, -Wl,--enable-auto-import
+ else # ifeq ($(EXPORT_SHARED),public)
+-CMISCFLAGS := -Wl,--exclude-all-symbols
++BUILD_SYMFLAGS := -Wl,--exclude-all-symbols
+ endif
+ else # ifeq ($(IS_WIN),no)
+ ifeq ($(EXPORT_SHARED),all)
+ # Export all symbols by default.
+-CMISCFLAGS := -fvisibility=default
++BUILD_SYMFLAGS := -fvisibility=default
+ else # ifeq ($(EXPORT_SHARED),public)
+ # Hide all symbols by default and export only those that have been annotated
+ # as needing to be exported.
+-CMISCFLAGS := -fvisibility=hidden
++BUILD_SYMFLAGS := -fvisibility=hidden
+ endif
+ endif
+ endif
+@@ -653,11 +667,11 @@ endif
+ ifeq ($(CC_VENDOR),icc)
+ ifeq ($(EXPORT_SHARED),all)
+ # Export all symbols by default.
+-CMISCFLAGS := -fvisibility=default
++BUILD_SYMFLAGS := -fvisibility=default
+ else # ifeq ($(EXPORT_SHARED),public)
+ # Hide all symbols by default and export only those that have been annotated
+ # as needing to be exported.
+-CMISCFLAGS := -fvisibility=hidden
++BUILD_SYMFLAGS := -fvisibility=hidden
+ endif
+ endif
+
+@@ -667,27 +681,25 @@ ifeq ($(IS_WIN),yes)
+ ifeq ($(EXPORT_SHARED),all)
+ # NOTE: clang on Windows does not appear to support exporting all symbols
+ # by default, and therefore we ignore the value of EXPORT_SHARED.
+-CMISCFLAGS :=
++BUILD_SYMFLAGS :=
+ else # ifeq ($(EXPORT_SHARED),public)
+ # NOTE: The default behavior of clang on Windows is to hide all symbols
+ # and only export functions and other declarations that have beenannotated
+ # as needing to be exported.
+-CMISCFLAGS :=
++BUILD_SYMFLAGS :=
+ endif
+ else # ifeq ($(IS_WIN),no)
+ ifeq ($(EXPORT_SHARED),all)
+ # Export all symbols by default.
+-CMISCFLAGS := -fvisibility=default
++BUILD_SYMFLAGS := -fvisibility=default
+ else # ifeq ($(EXPORT_SHARED),public)
+ # Hide all symbols by default and export only those that have been annotated
+ # as needing to be exported.
+-CMISCFLAGS := -fvisibility=hidden
++BUILD_SYMFLAGS := -fvisibility=hidden
+ endif
+ endif
+ endif
+
+-$(foreach c, $(CONFIG_LIST_FAM), $(eval $(call append-var-for,CMISCFLAGS,$(c))))
+-
+ # --- Language flags ---
+
+ # Enable C99.
+@@ -1026,7 +1038,7 @@ VERS_DEF := -DBLIS_VERSION_STRING=\"$(VERSION)\"
+ # Define a C preprocessor flag that is *only* defined when BLIS is being
+ # compiled. (In other words, an application that #includes blis.h will not
+ # get this cpp macro.)
+-BUILD_FLAGS := -DBLIS_IS_BUILDING_LIBRARY
++BUILD_CPPFLAGS := -DBLIS_IS_BUILDING_LIBRARY
+
+
+
+diff --git a/configure b/configure
+index 5b5695cd5..bb21671f0 100755
+--- a/configure
++++ b/configure
+@@ -152,13 +152,13 @@ print_usage()
+ echo " functions and variables that belong to public APIs are"
+ echo " exported in shared libraries. However, the user may"
+ echo " instead export all symbols in BLIS, even those that were"
+- echo " intended for internal use only. Note Note that the public"
+- echo " APIs encompass all functions that almost any user would"
+- echo " ever want to call, including the BLAS/CBLAS compatibility"
+- echo " APIs as well as the basic and expert interfaces to the"
+- echo " typed and object APIs that are unique to BLIS. Also note"
+- echo " that changing this option to 'all' will have no effect in"
+- echo " some environments, such as when compiling with clang on"
++ echo " intended for internal use only. Note that the public APIs"
++ echo " encompass all functions that almost any user would ever"
++ echo " want to call, including the BLAS/CBLAS compatibility APIs"
++ echo " as well as the basic and expert interfaces to the typed"
++ echo " and object APIs that are unique to BLIS. Also note that"
++ echo " changing this option to 'all' will have no effect in some"
++ echo " environments, such as when compiling with clang on"
+ echo " Windows."
+ echo " "
+ echo " -t MODEL, --enable-threading[=MODEL], --disable-threading"
diff --git a/sci-libs/blis/files/blis-0.5.2-rpath.patch b/sci-libs/blis/files/blis-0.5.2-rpath.patch
new file mode 100644
index 000000000000..a8b5a46870d1
--- /dev/null
+++ b/sci-libs/blis/files/blis-0.5.2-rpath.patch
@@ -0,0 +1,13 @@
+diff --git a/common.mk b/common.mk
+index ef0acfb..e1ce31d 100644
+--- a/common.mk
++++ b/common.mk
+@@ -527,7 +527,7 @@ LIBBLIS_L := $(LIBBLIS_SO)
+ LIBBLIS_LINK := $(LIBBLIS_SO_PATH)
+ ifeq ($(IS_WIN),no)
+ # For Linux and OS X: set rpath property of shared object.
+-LDFLAGS += -Wl,-rpath,$(BASE_LIB_PATH)
++#LDFLAGS += -Wl,-rpath,$(BASE_LIB_PATH)
+ endif
+ endif
+ endif
diff --git a/sci-libs/blis/files/cblas.lds b/sci-libs/blis/files/cblas.lds
new file mode 100644
index 000000000000..18ec172028ca
--- /dev/null
+++ b/sci-libs/blis/files/cblas.lds
@@ -0,0 +1,15 @@
+{
+ # Export CBLAS symbols
+ global:
+ cblas_*;
+ CBLAS_*;
+ RowMajorStrg;
+
+ # Hide everything else.
+ local:
+ bli_thread_set_num_threads_;
+ bli_thread_set_ways_;
+ bli_*;
+ *_;
+ *;
+};
diff --git a/sci-libs/blis/metadata.xml b/sci-libs/blis/metadata.xml
new file mode 100644
index 000000000000..a27c6853409d
--- /dev/null
+++ b/sci-libs/blis/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <bugs-to>https://github.com/flame/blis/issues/</bugs-to>
+ <doc>https://github.com/flame/blis</doc>
+ </upstream>
+ <maintainer type="project">
+ <name>Mo Zhou</name>
+ <email>lumin@debian.org</email>
+ </maintainer>
+ <longdescription>
+ BLIS is a portable software framework for instantiating high-performance
+ BLAS-like dense linear algebra libraries. The framework was designed to
+ isolate essential kernels of computation that, when optimized, immediately
+ enable optimized implementations of most of its commonly used and
+ computationally intensive operations. BLIS is written in ISO C99 and
+ available under a new/modified/3-clause BSD license. While BLIS exports a
+ new BLAS-like API, it also includes a BLAS compatibility layer which gives
+ application developers access to BLIS implementations via traditional BLAS
+ routine calls. An object-based API unique to BLIS is also available.
+ </longdescription>
+ <use>
+ <flag name="openmp">Use openmp threadding model</flag>
+ <flag name="pthread">Use pthread threadding model</flag>
+ <flag name="serial">Use no threadding model</flag>
+ <flag name="eselect-ldso">Enable runtime library switching by eselect and ld.so.</flag>
+ <flag name="64bit-index">Enable 64bit array indexing, incompatible with runtime switching</flag>
+ </use>
+</pkgmetadata>