summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/buddy/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/buddy/files')
-rw-r--r--sci-libs/buddy/files/buddy-2.4-gcc43.patch22
-rw-r--r--sci-libs/buddy/files/buddy-2.4-gold.patch16
2 files changed, 38 insertions, 0 deletions
diff --git a/sci-libs/buddy/files/buddy-2.4-gcc43.patch b/sci-libs/buddy/files/buddy-2.4-gcc43.patch
new file mode 100644
index 000000000000..c7b9f85688eb
--- /dev/null
+++ b/sci-libs/buddy/files/buddy-2.4-gcc43.patch
@@ -0,0 +1,22 @@
+diff -Naurp buddy-2.4-orig/src/bddtest.cxx buddy-2.4/src/bddtest.cxx
+--- buddy-2.4-orig/src/bddtest.cxx 2004-06-25 07:22:26.000000000 -0600
++++ buddy-2.4/src/bddtest.cxx 2009-02-09 22:14:19.000000000 -0600
+@@ -28,6 +28,7 @@
+ ========================================================================*/
+
+ #include <string>
++#include <cstdlib>
+ #include "bdd.h"
+ #include "bvec.h"
+
+diff -Naurp buddy-2.4-orig/examples/bddcalc/parser_.h buddy-2.4/examples/bddcalc/parser_.h
+--- buddy-2.4-orig/examples/bddcalc/parser_.h 2004-06-25 07:21:43.000000000 -0600
++++ buddy-2.4/examples/bddcalc/parser_.h 2009-02-09 22:21:09.000000000 -0600
+@@ -9,6 +9,7 @@
+ #define _PARSER_H
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "bdd.h"
+
+ #define MAXIDLEN 32 /* Max. number of allowed characters in an identifier */
diff --git a/sci-libs/buddy/files/buddy-2.4-gold.patch b/sci-libs/buddy/files/buddy-2.4-gold.patch
new file mode 100644
index 000000000000..dc30a642141d
--- /dev/null
+++ b/sci-libs/buddy/files/buddy-2.4-gold.patch
@@ -0,0 +1,16 @@
+ examples/cmilner/Makefile.in | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/examples/cmilner/Makefile.in b/examples/cmilner/Makefile.in
+index 9b49e9d..f7a9b8a 100644
+--- a/examples/cmilner/Makefile.in
++++ b/examples/cmilner/Makefile.in
+@@ -217,7 +217,7 @@ clean-checkPROGRAMS:
+ done
+ cmilner$(EXEEXT): $(cmilner_OBJECTS) $(cmilner_DEPENDENCIES)
+ @rm -f cmilner$(EXEEXT)
+- $(LINK) $(cmilner_LDFLAGS) $(cmilner_OBJECTS) $(cmilner_LDADD) $(LIBS)
++ $(LINK) $(cmilner_LDFLAGS) $(cmilner_OBJECTS) $(cmilner_LDADD) $(LIBS) -lm
+
+ mostlyclean-compile:
+ -rm -f *.$(OBJEXT)