summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 20:04:15 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:35:28 +0100
commitb4937ee4a074b4b6849c7fb31cd635b327995b41 (patch)
tree35417fd05571580735a6095d56935817eb54298a /sci-libs/cantera
parentsci-geosciences/qgis: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-b4937ee4a074b4b6849c7fb31cd635b327995b41.tar.gz
gentoo-b4937ee4a074b4b6849c7fb31cd635b327995b41.tar.bz2
gentoo-b4937ee4a074b4b6849c7fb31cd635b327995b41.zip
sci-libs/cantera: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-libs/cantera')
-rw-r--r--sci-libs/cantera/cantera-2.4.0-r1.ebuild8
-rw-r--r--sci-libs/cantera/cantera-2.4.0-r3.ebuild (renamed from sci-libs/cantera/cantera-2.4.0-r2.ebuild)8
2 files changed, 12 insertions, 4 deletions
diff --git a/sci-libs/cantera/cantera-2.4.0-r1.ebuild b/sci-libs/cantera/cantera-2.4.0-r1.ebuild
index edaded328a20..cd27ff27f637 100644
--- a/sci-libs/cantera/cantera-2.4.0-r1.ebuild
+++ b/sci-libs/cantera/cantera-2.4.0-r1.ebuild
@@ -28,7 +28,9 @@ REQUIRED_USE="
RDEPEND="
${PYTHON_DEPS}
python? (
- dev-python/numpy[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ ')
)
<sci-libs/sundials-4.0.0:0=
"
@@ -39,7 +41,9 @@ DEPEND="
dev-libs/boost
dev-libs/libfmt
python? (
- dev-python/cython[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_MULTI_USEDEP}]
+ ')
)
test? (
>=dev-cpp/gtest-1.8.0
diff --git a/sci-libs/cantera/cantera-2.4.0-r2.ebuild b/sci-libs/cantera/cantera-2.4.0-r3.ebuild
index f82bfa086396..29345e36058c 100644
--- a/sci-libs/cantera/cantera-2.4.0-r2.ebuild
+++ b/sci-libs/cantera/cantera-2.4.0-r3.ebuild
@@ -28,7 +28,9 @@ REQUIRED_USE="
RDEPEND="
${PYTHON_DEPS}
python? (
- dev-python/numpy[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ ')
)
<sci-libs/sundials-5.1.0:0=
"
@@ -39,7 +41,9 @@ DEPEND="
dev-libs/boost
dev-libs/libfmt
python? (
- dev-python/cython[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_MULTI_USEDEP}]
+ ')
)
test? (
>=dev-cpp/gtest-1.8.0