summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2016-10-09 10:22:44 -0500
committerMatthias Maier <tamiko@gentoo.org>2016-10-09 10:23:48 -0500
commitec07bd6704edd93082d57c41c7edf461e46cbe58 (patch)
tree80f24a49add78c34322fd8f42fdabac16e8be746 /sci-libs/cblas-reference/cblas-reference-20151113-r2.ebuild
parentkde-frameworks/oxygen-icons: add missing test dependency (diff)
downloadgentoo-ec07bd6704edd93082d57c41c7edf461e46cbe58.tar.gz
gentoo-ec07bd6704edd93082d57c41c7edf461e46cbe58.tar.bz2
gentoo-ec07bd6704edd93082d57c41c7edf461e46cbe58.zip
sci-libs/cblas-reference: fix eselect symlnk to pc file
Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-libs/cblas-reference/cblas-reference-20151113-r2.ebuild')
-rw-r--r--sci-libs/cblas-reference/cblas-reference-20151113-r2.ebuild96
1 files changed, 96 insertions, 0 deletions
diff --git a/sci-libs/cblas-reference/cblas-reference-20151113-r2.ebuild b/sci-libs/cblas-reference/cblas-reference-20151113-r2.ebuild
new file mode 100644
index 000000000000..9a1017c7c4be
--- /dev/null
+++ b/sci-libs/cblas-reference/cblas-reference-20151113-r2.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils fortran-2 cmake-utils multilib flag-o-matic toolchain-funcs
+
+LPN=lapack
+LPV=3.6.0
+
+DESCRIPTION="C wrapper interface to the F77 reference BLAS implementation"
+HOMEPAGE="http://www.netlib.org/cblas/"
+SRC_URI="http://www.netlib.org/${LPN}/${LPN}-${LPV}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
+IUSE=""
+
+DEPEND="app-eselect/eselect-cblas
+ >=virtual/blas-3.6
+ virtual/pkgconfig"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${LPN}-${LPV}"
+PATCHES=( "${FILESDIR}/lapack-fix-build-system.patch" )
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+
+ eapply_user
+
+ ESELECT_PROF=reference
+
+ cp "${FILESDIR}"/eselect.cblas.reference-r2 "${T}"/eselect.cblas.reference || die
+ sed -i -e "s:/usr:${EPREFIX}/usr:" "${T}"/eselect.cblas.reference || die
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ sed -i -e 's/\.so\([\.0-9]\+\)\?/\1.dylib/g' \
+ "${T}"/eselect.cblas.reference || die
+ fi
+
+ sed -i \
+ -e 's:/CMAKE/:/cmake/:g' \
+ CBLAS/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -Wno-dev
+ -DCBLAS=ON
+ -DUSE_OPTIMIZED_BLAS=ON
+ -DBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs blas)"
+ -DCMAKE_C_FLAGS="$($(tc-getPKG_CONFIG) --cflags blas) ${CFLAGS}"
+ -DCMAKE_Fortran_FLAGS="$($(tc-getPKG_CONFIG) --cflags blas) $(get_abi_CFLAGS) ${FCFLAGS}"
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_STATIC_LIBS=ON
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile -C CBLAS
+}
+
+src_install() {
+ cmake-utils_src_install -C CBLAS
+
+ mkdir -p "${ED}/usr/$(get_libdir)/blas/reference" || die
+ mv "${ED}/usr/$(get_libdir)"/lib* "${ED}/usr/include"/cblas* \
+ "${ED}/usr/$(get_libdir)/pkgconfig"/* \
+ "${ED}/usr/$(get_libdir)/blas/reference" || die
+
+ rmdir "${ED}/usr/$(get_libdir)/pkgconfig" || die
+ rmdir "${ED}/usr/include" || die
+ rm -rf "${ED}"/usr/lib/ || die
+
+ eselect cblas add $(get_libdir) "${T}"/eselect.cblas.reference ${ESELECT_PROF}
+}
+
+pkg_postinst() {
+ local p=cblas
+ local current_lib=$(eselect ${p} show | cut -d' ' -f2)
+ if [[ ${current_lib} == ${ESELECT_PROF} || -z ${current_lib} ]]; then
+ # work around eselect bug #189942
+ local configfile="${EROOT}"/etc/env.d/${p}/$(get_libdir)/config
+ [[ -e ${configfile} ]] && rm -f ${configfile}
+ eselect ${p} set ${ESELECT_PROF}
+ elog "${p} has been eselected to ${ESELECT_PROF}"
+ else
+ elog "Current eselected ${p} is ${current_lib}"
+ elog "To use ${p} ${ESELECT_PROF} implementation, you have to issue (as root):"
+ elog "\t eselect ${p} set ${ESELECT_PROF}"
+ fi
+}