summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/cddlib/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/cddlib/files')
-rw-r--r--sci-libs/cddlib/files/cdd_both_reps.c255
-rw-r--r--sci-libs/cddlib/files/cddlib-094f-add-cdd_both_reps-binary.patch41
-rw-r--r--sci-libs/cddlib/files/cddlib-094f-use-libtool.patch54
-rw-r--r--sci-libs/cddlib/files/cddlib-094g-add-cdd_both_reps-binary.patch41
4 files changed, 391 insertions, 0 deletions
diff --git a/sci-libs/cddlib/files/cdd_both_reps.c b/sci-libs/cddlib/files/cdd_both_reps.c
new file mode 100644
index 000000000000..3de4247e3016
--- /dev/null
+++ b/sci-libs/cddlib/files/cdd_both_reps.c
@@ -0,0 +1,255 @@
+/* cdd_both_reps.c: compute reduced H and V representation of polytope
+ by Volker Braun <vbraun@stp.dias.ie>
+
+ The input is taken from stdin and can be either a
+ H or V representation, not necessarily reduced.
+
+ based on testcdd1.c, redcheck.c, and of course the cdd library
+ written by Komei Fukuda, fukuda@ifor.math.ethz.ch
+ Standard ftp site: ftp.ifor.math.ethz.ch, Directory: pub/fukuda/cdd
+*/
+
+/* This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+*/
+
+#include "setoper.h"
+#include "cdd.h"
+#include <stdio.h>
+#include <stdlib.h>
+#include <time.h>
+#include <math.h>
+#include <string.h>
+
+
+
+
+
+void compute_adjacency(dd_MatrixPtr Rep, dd_ErrorType* err_ptr)
+{
+ dd_SetFamilyPtr AdjacencyGraph;
+ if (*err_ptr != dd_NoError) return;
+
+ switch (Rep->representation) {
+ case dd_Inequality:
+ printf("Facet graph\n");
+ break;
+ case dd_Generator:
+ printf("Vertex graph\n");
+ break;
+ case dd_Unspecified:
+ printf("unknown representation type!\n");
+ default:
+ printf("This should be unreachable!\n");
+ exit(2);
+ }
+
+ /* Output adjacency of vertices/rays/lines */
+ if (Rep->rowsize > 0) { /* workaround for bug with empty polyhedron */
+ /* compute adjacent vertices/rays/lines */
+ AdjacencyGraph = dd_Matrix2Adjacency(Rep, err_ptr);
+ if (*err_ptr == dd_NoError) {
+ dd_WriteSetFamily(stdout,AdjacencyGraph);
+ dd_FreeSetFamily(AdjacencyGraph);
+ }
+ } else {
+ printf("begin\n");
+ printf(" 0 0\n");
+ printf("end\n");
+ }
+
+ printf("\n");
+}
+
+
+void minimal_Vrep_Hrep(dd_MatrixPtr M,
+ dd_MatrixPtr* Vrep_ptr, dd_MatrixPtr* Hrep_ptr,
+ dd_ErrorType* err_ptr)
+{
+ dd_PolyhedraPtr poly;
+ dd_rowindex newpos;
+ dd_rowset impl_linset,redset;
+ dd_MatrixPtr Vrep, Hrep;
+
+ if (*err_ptr != dd_NoError) return;
+
+ /* compute the second representation */
+ poly = dd_DDMatrix2Poly(M, err_ptr);
+ if (*err_ptr != dd_NoError) return;
+
+ if (*err_ptr == dd_NoError) {
+ /* compute canonical H-representation */
+ Hrep = dd_CopyInequalities(poly);
+ if (Hrep->rowsize > 0) { /* workaround for bug with empty matrix */
+ dd_MatrixCanonicalize(&Hrep, &impl_linset, &redset, &newpos, err_ptr);
+ if (*err_ptr == dd_NoError) {
+ set_free(redset);
+ set_free(impl_linset);
+ free(newpos);
+ }
+ }
+ if (*err_ptr == dd_NoError) (*Hrep_ptr) = Hrep;
+ }
+
+ if (*err_ptr == dd_NoError) {
+ /* compute canonical V-representation */
+ Vrep = dd_CopyGenerators(poly);
+ if (Vrep->rowsize > 0) { /* workaround for bug with empty matrix */
+ dd_MatrixCanonicalize(&Vrep, &impl_linset, &redset, &newpos, err_ptr);
+ if (*err_ptr == dd_NoError) {
+ set_free(redset);
+ set_free(impl_linset);
+ free(newpos);
+ }
+ }
+ if (*err_ptr == dd_NoError) (*Vrep_ptr) = Vrep;
+ }
+
+ dd_FreePolyhedra(poly);
+}
+
+
+void print_both_reps(dd_MatrixPtr Vrep, dd_MatrixPtr Hrep)
+{
+ /* Output V-representation */
+ dd_WriteMatrix(stdout,Vrep);
+ printf("\n");
+
+ /* Output H-representation */
+ dd_WriteMatrix(stdout,Hrep);
+ printf("\n");
+}
+
+
+void compute_both_reps(dd_MatrixPtr M, dd_ErrorType* err_ptr)
+{
+ dd_MatrixPtr Vrep, Hrep;
+ minimal_Vrep_Hrep(M, &Vrep, &Hrep, err_ptr);
+ if (*err_ptr != dd_NoError) return;
+
+ print_both_reps(Vrep, Hrep);
+ dd_FreeMatrix(Hrep);
+ dd_FreeMatrix(Vrep);
+}
+
+
+void compute_all(dd_MatrixPtr M, dd_ErrorType* err_ptr)
+{
+ dd_MatrixPtr Vrep, Hrep;
+ minimal_Vrep_Hrep(M, &Vrep, &Hrep, err_ptr);
+ if (*err_ptr != dd_NoError) return;
+
+ print_both_reps(Vrep, Hrep);
+ compute_adjacency(Vrep, err_ptr);
+ compute_adjacency(Hrep, err_ptr);
+ dd_FreeMatrix(Hrep);
+ dd_FreeMatrix(Vrep);
+}
+
+
+
+void usage(char *name)
+{
+ printf("No known option specified, I don't know what to do!\n"
+ "Usage:\n"
+ "%s --option\n"
+ "where --option is precisely one of the following:\n\n"
+ " --all: Compute everything.\n"
+ " This will compute minimal H-,V-representation and vertex and facet graph.\n"
+ "\n"
+ " --reps: Compute both a minimal H- and minimal V-representation.\n"
+ "\n"
+ " --adjacency: Compute adjacency information only.\n"
+ " The input is assumed to be a minimal representation, as, for example, computed\n"
+ " by --reps. Warning, you will not get the correct answer if the input\n"
+ " representation is not minimal! The output is the vertex or facet graph,\n"
+ " depending on the input.\n"
+ "\n"
+ "The input data is a H- or V-representation in cdd's ine/ext format and\n"
+ "is in each case read from stdin.\n",
+ name);
+}
+
+
+enum command_line_arguments { ALL, REPS, ADJACENCY };
+
+
+int parse_arguments(char* arg, enum command_line_arguments* option)
+{
+ if (strcmp(arg,"--all")==0) {
+ *option = ALL;
+ return 0;
+ }
+ if (strcmp(arg,"--reps")==0) {
+ *option = REPS;
+ return 0;
+ }
+ if (strcmp(arg,"--adjacency")==0) {
+ *option = ADJACENCY;
+ return 0;
+ }
+ printf("Unknown option: %s\n", arg);
+ return 1;
+}
+
+
+int main(int argc, char *argv[])
+{
+ dd_ErrorType err=dd_NoError;
+ dd_MatrixPtr M;
+ enum command_line_arguments option;
+
+ if (argc!=2 || parse_arguments(argv[1],&option)) {
+ usage(argv[0]);
+ return 0;
+ }
+
+ dd_set_global_constants();
+
+ /* Read data from stdin */
+ M = dd_PolyFile2Matrix(stdin, &err);
+ if (err != dd_NoError) {
+ printf("I was unable to parse the input data!\n");
+ dd_WriteErrorMessages(stdout,err);
+ dd_free_global_constants();
+ return 1;
+ }
+
+ switch (option) {
+ case ALL:
+ compute_all(M,&err);
+ break;
+ case REPS:
+ compute_both_reps(M,&err);
+ break;
+ case ADJACENCY:
+ compute_adjacency(M,&err);
+ break;
+ default:
+ printf("unreachable option %d\n", option);
+ exit(3); /* unreachable */
+ }
+
+ /* cleanup */
+ dd_FreeMatrix(M);
+ if (err != dd_NoError) {
+ dd_WriteErrorMessages(stdout,err);
+ }
+
+ dd_free_global_constants();
+ return 0;
+}
+
+
+
diff --git a/sci-libs/cddlib/files/cddlib-094f-add-cdd_both_reps-binary.patch b/sci-libs/cddlib/files/cddlib-094f-add-cdd_both_reps-binary.patch
new file mode 100644
index 000000000000..3c7392db7244
--- /dev/null
+++ b/sci-libs/cddlib/files/cddlib-094f-add-cdd_both_reps-binary.patch
@@ -0,0 +1,41 @@
+--- src-gmp/Makefile.am 2009-01-26 09:30:16.000000000 +0000
++++ src-gmp/Makefile.am 2009-10-04 10:36:17.000000000 +0100
+@@ -11,7 +11,8 @@
+ testcdd2_gmp \
+ testlp1_gmp \
+ testlp2_gmp \
+-testlp3_gmp
++testlp3_gmp \
++cdd_both_reps_gmp
+ #cddmathlink
+
+ scdd_gmp_SOURCES = simplecdd.c
+@@ -27,6 +28,7 @@
+ testlp1_gmp_SOURCES = testlp1.c
+ testlp2_gmp_SOURCES = testlp2.c
+ testlp3_gmp_SOURCES = testlp3.c
++cdd_both_reps_gmp_SOURCES = cdd_both_reps.c
+ # cddmathlink_SOURCES = cddmathlink.c cddmlio.h cddmlio.c
+
+ LDADD = ../lib-src-gmp/libcddgmp.a
+--- src/Makefile.am 2009-01-26 09:30:03.000000000 +0000
++++ src/Makefile.am 2009-10-04 10:36:17.000000000 +0100
+@@ -11,7 +11,8 @@
+ testcdd2 \
+ testlp1 \
+ testlp2 \
+-testlp3
++testlp3 \
++cdd_both_reps
+ #cddmathlink
+
+ scdd_SOURCES = simplecdd.c
+@@ -27,6 +28,7 @@
+ testlp1_SOURCES = testlp1.c
+ testlp2_SOURCES = testlp2.c
+ testlp3_SOURCES = testlp3.c
++cdd_both_reps_SOURCES = cdd_both_reps.c
+ # cddmathlink_SOURCES = cddmathlink.c cddmlio.h cddmlio.c
+
+ LDADD = ../lib-src/libcdd.a
+
diff --git a/sci-libs/cddlib/files/cddlib-094f-use-libtool.patch b/sci-libs/cddlib/files/cddlib-094f-use-libtool.patch
new file mode 100644
index 000000000000..219f6d9eb371
--- /dev/null
+++ b/sci-libs/cddlib/files/cddlib-094f-use-libtool.patch
@@ -0,0 +1,54 @@
+--- configure.in.orig 2008-02-07 09:57:13.000000000 +1300
++++ configure.in 2008-05-26 08:59:21.000000000 +1200
+@@ -7,7 +7,7 @@
+ dnl Checks for programs.
+ AC_PROG_CC
+ AC_PROG_INSTALL
+-AC_PROG_RANLIB
++AC_PROG_LIBTOOL
+
+ dnl Checks for libraries.
+ dnl Replace `main' with a function in -lg:
+--- lib-src-gmp/Makefile.am.orig 2008-02-07 09:57:13.000000000 +1300
++++ lib-src-gmp/Makefile.am 2008-05-26 08:55:35.000000000 +1200
+@@ -1,6 +1,6 @@
+-lib_LIBRARIES = libcddgmp.a
++lib_LTLIBRARIES = libcddgmp.la
+
+-libcddgmp_a_SOURCES = \
++libcddgmp_la_SOURCES = \
+ cddcore.c \
+ cddlp.c \
+ cddmp.c \
+--- lib-src/Makefile.am.orig 2008-02-07 09:57:14.000000000 +1300
++++ lib-src/Makefile.am 2008-05-26 08:56:38.000000000 +1200
+@@ -1,6 +1,6 @@
+-lib_LIBRARIES = libcdd.a
++lib_LTLIBRARIES = libcdd.la
+
+-libcdd_a_SOURCES = \
++libcdd_la_SOURCES = \
+ cddcore.c \
+ cddlp.c \
+ cddmp.c \
+--- src/Makefile.am.orig 2008-02-07 09:57:15.000000000 +1300
++++ src/Makefile.am 2008-05-26 08:57:49.000000000 +1200
+@@ -29,6 +29,6 @@
+ testlp3_SOURCES = testlp3.c
+ # cddmathlink_SOURCES = cddmathlink.c cddmlio.h cddmlio.c
+
+-LDADD = ../lib-src/libcdd.a
++LDADD = ../lib-src/libcdd.la
+ INCLUDES = -I../lib-src
+ AM_CPPFLAGS = -UGMPRATIONAL
+--- src-gmp/Makefile.am.orig 2008-02-07 09:57:14.000000000 +1300
++++ src-gmp/Makefile.am 2008-05-26 08:58:35.000000000 +1200
+@@ -29,7 +29,7 @@
+ testlp3_gmp_SOURCES = testlp3.c
+ # cddmathlink_SOURCES = cddmathlink.c cddmlio.h cddmlio.c
+
+-LDADD = ../lib-src-gmp/libcddgmp.a
++LDADD = ../lib-src-gmp/libcddgmp.la
+ AM_LDFLAGS = -L$(gmplibdir)
+ INCLUDES = -I../lib-src-gmp
+ INCLUDES += -I$(gmpincludedir)
diff --git a/sci-libs/cddlib/files/cddlib-094g-add-cdd_both_reps-binary.patch b/sci-libs/cddlib/files/cddlib-094g-add-cdd_both_reps-binary.patch
new file mode 100644
index 000000000000..3aa5912b7460
--- /dev/null
+++ b/sci-libs/cddlib/files/cddlib-094g-add-cdd_both_reps-binary.patch
@@ -0,0 +1,41 @@
+--- src-gmp/Makefile.am 2009-01-26 09:30:16.000000000 +0000
++++ src-gmp/Makefile.am 2009-10-04 10:36:17.000000000 +0100
+@@ -11,7 +11,8 @@
+ testcdd2_gmp \
+ testlp1_gmp \
+ testlp2_gmp \
+-testlp3_gmp
++testlp3_gmp \
++cdd_both_reps_gmp
+ #cddmathlink
+
+ scdd_gmp_SOURCES = simplecdd.c
+@@ -27,6 +28,7 @@
+ testlp1_gmp_SOURCES = testlp1.c
+ testlp2_gmp_SOURCES = testlp2.c
+ testlp3_gmp_SOURCES = testlp3.c
++cdd_both_reps_gmp_SOURCES = cdd_both_reps.c
+ # cddmathlink_SOURCES = cddmathlink.c cddmlio.h cddmlio.c
+
+ LDADD = ../lib-src-gmp/libcddgmp.la
+--- src/Makefile.am 2009-01-26 09:30:03.000000000 +0000
++++ src/Makefile.am 2009-10-04 10:36:17.000000000 +0100
+@@ -11,7 +11,8 @@
+ testcdd2 \
+ testlp1 \
+ testlp2 \
+-testlp3
++testlp3 \
++cdd_both_reps
+ #cddmathlink
+
+ scdd_SOURCES = simplecdd.c
+@@ -27,6 +28,7 @@
+ testlp1_SOURCES = testlp1.c
+ testlp2_SOURCES = testlp2.c
+ testlp3_SOURCES = testlp3.c
++cdd_both_reps_SOURCES = cdd_both_reps.c
+ # cddmathlink_SOURCES = cddmathlink.c cddmlio.h cddmlio.c
+
+ LDADD = ../lib-src/libcdd.la
+