summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-01 20:04:50 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-01 22:31:34 +0200
commit79996b214863489ff4ea8d55968f34796b624278 (patch)
treedaf5410de340c603cdcea7cb3c62dbbf2f405861 /sci-libs/ceres-solver
parentkde-misc/kdiff3: Drop 1.8.2 (r0) (diff)
downloadgentoo-79996b214863489ff4ea8d55968f34796b624278.tar.gz
gentoo-79996b214863489ff4ea8d55968f34796b624278.tar.bz2
gentoo-79996b214863489ff4ea8d55968f34796b624278.zip
sci-libs/ceres-solver: Drop 1.12.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-libs/ceres-solver')
-rw-r--r--sci-libs/ceres-solver/Manifest1
-rw-r--r--sci-libs/ceres-solver/ceres-solver-1.12.0.ebuild97
-rw-r--r--sci-libs/ceres-solver/metadata.xml1
3 files changed, 0 insertions, 99 deletions
diff --git a/sci-libs/ceres-solver/Manifest b/sci-libs/ceres-solver/Manifest
index 0b1e2173e3d0..941bf4bbf4f1 100644
--- a/sci-libs/ceres-solver/Manifest
+++ b/sci-libs/ceres-solver/Manifest
@@ -1,2 +1 @@
-DIST ceres-solver-1.12.0.tar.gz 5008861 BLAKE2B 52b3954dde96386bd031543ab9d7370368f58f76f1dec9d24ef10803da787cc96f40a1c775626fde832b70ebd94cf4274c70a8fb4bd7e1bcf040e119cbec09f8 SHA512 485eece0471cf05d31b5dd7e133e23115a334a4ed557a3c1bd0b715a063f840738af8f507e935522a0dae90ce6851984c0002a25e9b445b90889792f68a05571
DIST ceres-solver-1.14.0.tar.gz 5450130 BLAKE2B cfcfe07cecb267528081dfc6deb5283bc5a04b79d4595e45365960895b84a6dca2a3024b046868f06709fc81e8514730cbc409ab01cb0cbee488b5bad5b9f7cc SHA512 a2af9918d2730709361ec971431a2b22e6ca3ca440081be87fa52729ec43702020b021837bfe5a42a58db1ab89ea6aada11f2d1888da66bef614ec1f27ab30c6
diff --git a/sci-libs/ceres-solver/ceres-solver-1.12.0.ebuild b/sci-libs/ceres-solver/ceres-solver-1.12.0.ebuild
deleted file mode 100644
index 05747c215b05..000000000000
--- a/sci-libs/ceres-solver/ceres-solver-1.12.0.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit cmake-multilib eutils python-any-r1 toolchain-funcs
-
-DESCRIPTION="Nonlinear least-squares minimizer"
-HOMEPAGE="http://ceres-solver.org/"
-SRC_URI="http://ceres-solver.org/${P}.tar.gz"
-
-LICENSE="sparse? ( BSD ) !sparse? ( LGPL-2.1 ) cxsparse? ( BSD )"
-SLOT="0/1"
-KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="cxsparse c++11 doc examples gflags lapack openmp +schur sparse test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="test? ( gflags ) sparse? ( lapack ) abi_x86_32? ( !sparse !lapack )"
-
-RDEPEND="
- dev-cpp/glog[gflags?,${MULTILIB_USEDEP}]
- cxsparse? ( sci-libs/cxsparse )
- lapack? ( virtual/lapack )
- sparse? (
- sci-libs/amd
- sci-libs/camd
- sci-libs/ccolamd
- sci-libs/cholmod[metis(+)]
- sci-libs/colamd
- sci-libs/spqr
- )"
-
-DEPEND="${RDEPEND}
- dev-cpp/eigen:3
- doc? ( dev-python/sphinx dev-python/sphinx_rtd_theme )
- lapack? ( virtual/pkgconfig )
- ${PYTHON_DEPS}"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
- if [[ $(tc-getCXX) == *g++* ]] && ! tc-has-openmp; then
- ewarn "OpenMP is not available in your current selected gcc"
- die "need openmp capable gcc"
- fi
- fi
-}
-
-pkg_setup() {
- use doc && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- # search paths work for prefix
- sed -e "s:/usr:${EPREFIX}/usr:g" \
- -i cmake/*.cmake || die
-
- # remove Werror
- sed -e 's/-Werror=(all|extra)//g' \
- -i CMakeLists.txt || die
-
- # respect gentoo doc install directory
- sed -e "s:share/doc/ceres:share/doc/${PF}:" \
- -i docs/source/CMakeLists.txt || die
- cmake-utils_src_prepare
-}
-
-src_configure() {
- # CUSTOM_BLAS=OFF EIGENSPARSE=OFF MINIGLOG=OFF CXX11=OFF
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
- -DBUILD_EXAMPLES=OFF
- -DENABLE_TESTING="$(usex test)"
- -DCXX11="$(usex c++11)"
- -DBUILD_DOCUMENTATION="$(usex doc)"
- -DGFLAGS="$(usex gflags)"
- -DLAPACK="$(usex lapack)"
- -DOPENMP="$(usex openmp)"
- -DSCHUR_SPECIALIZATIONS="$(usex schur)"
- -DCXSPARSE="$(usex cxsparse)"
- -DSUITESPARSE="$(usex sparse)"
- )
- use sparse || use cxsparse || mycmakeargs+=( -DEIGENSPARSE=ON )
- cmake-multilib_src_configure
-}
-
-src_install() {
- cmake-multilib_src_install
- dodoc README.md VERSION
-
- if use examples; then
- docinto /usr/share/doc/${PF}
- docompress -x /usr/share/doc/${PF}/examples
- doins -r examples data
- fi
-}
diff --git a/sci-libs/ceres-solver/metadata.xml b/sci-libs/ceres-solver/metadata.xml
index 42d1cafcb8bf..57c1a1394e07 100644
--- a/sci-libs/ceres-solver/metadata.xml
+++ b/sci-libs/ceres-solver/metadata.xml
@@ -29,6 +29,5 @@
<flag name="sparse">Enable support for sparse matrix algebra with various
packages from SuiteSparse</flag>
<flag name="gflags">Use <pkg>dev-cpp/gflags</pkg> for flag parsing</flag>
- <flag name="c++11">Build ceres-solver using the C++11 standard</flag>
</use>
</pkgmetadata>