summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-06 12:09:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-06 12:09:47 +0100
commitf8c284bd0c13b1666a6e8c29b07a05d4c3e077c7 (patch)
treee62be6e2ab2d82d703b1862794200663deeeb1c4 /sci-libs/clapack
parentsci-libs/cminpack: Drop 1.3.5 (diff)
downloadgentoo-f8c284bd0c13b1666a6e8c29b07a05d4c3e077c7.tar.gz
gentoo-f8c284bd0c13b1666a6e8c29b07a05d4c3e077c7.tar.bz2
gentoo-f8c284bd0c13b1666a6e8c29b07a05d4c3e077c7.zip
sci-libs/clapack: https, cmake.eclass, EAPI-7 bump
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-libs/clapack')
-rw-r--r--sci-libs/clapack/clapack-3.2.1-r8.ebuild26
1 files changed, 14 insertions, 12 deletions
diff --git a/sci-libs/clapack/clapack-3.2.1-r8.ebuild b/sci-libs/clapack/clapack-3.2.1-r8.ebuild
index ac9a2c73f97e..30384df4db47 100644
--- a/sci-libs/clapack/clapack-3.2.1-r8.ebuild
+++ b/sci-libs/clapack/clapack-3.2.1-r8.ebuild
@@ -1,25 +1,28 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit flag-o-matic cmake-utils
+inherit flag-o-matic cmake
DESCRIPTION="f2c'ed version of LAPACK"
-HOMEPAGE="http://www.netlib.org/clapack/"
-SRC_URI="http://www.netlib.org/${PN}/${P}-CMAKE.tgz"
+HOMEPAGE="https://www.netlib.org/clapack/"
+SRC_URI="https://www.netlib.org/${PN}/${P}-CMAKE.tgz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
IUSE="test"
+# bug 433806
+RESTRICT="test"
+
RDEPEND="
>=dev-libs/libf2c-20090407-r1
virtual/blas"
DEPEND="${RDEPEND}"
-S=${WORKDIR}/${P}-CMAKE
+S="${WORKDIR}"/${P}-CMAKE
PATCHES=(
"${FILESDIR}/${P}-fix_include_file.patch"
@@ -28,18 +31,17 @@ PATCHES=(
"${FILESDIR}/${P}-findblas-r7.patch"
)
-# bug 433806
-RESTRICT="test"
-
src_prepare() {
+ cmake_src_prepare
rm INCLUDE/f2c.h F2CLIBS/libf2c/f2c.h || die
- cmake-utils_src_prepare
}
src_configure() {
filter-flags -ftree-vectorize
# causes an internal compiler error with gcc-4.6.2
- local mycmakeargs=( -DENABLE_TESTS=$(usex test) )
- cmake-utils_src_configure
+ local mycmakeargs=(
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake_src_configure
}