summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-14 21:19:40 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-14 21:19:40 +0100
commit785c90cfa242ac84cff475d5ec5e7f0ed64c14c3 (patch)
treef77adf4b499470ba292260e19f0b9bf01f8c69f5 /sci-libs/cln
parentsci-chemistry/mopac7: disable static libs (diff)
downloadgentoo-785c90cfa242ac84cff475d5ec5e7f0ed64c14c3.tar.gz
gentoo-785c90cfa242ac84cff475d5ec5e7f0ed64c14c3.tar.bz2
gentoo-785c90cfa242ac84cff475d5ec5e7f0ed64c14c3.zip
sci-libs/cln: disable static libs
Closes: https://bugs.gentoo.org/725420 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/cln')
-rw-r--r--sci-libs/cln/cln-1.3.3.ebuild8
-rw-r--r--sci-libs/cln/cln-1.3.4.ebuild8
-rw-r--r--sci-libs/cln/cln-1.3.6.ebuild8
3 files changed, 21 insertions, 3 deletions
diff --git a/sci-libs/cln/cln-1.3.3.ebuild b/sci-libs/cln/cln-1.3.3.ebuild
index 8b641d2d4f4d..a8823500d1ed 100644
--- a/sci-libs/cln/cln-1.3.3.ebuild
+++ b/sci-libs/cln/cln-1.3.3.ebuild
@@ -12,7 +12,7 @@ SRC_URI="ftp://ftpthep.physik.uni-mainz.de/pub/gnu/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="1"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples static-libs"
+IUSE="doc examples"
RDEPEND="dev-libs/gmp:0="
DEPEND="${RDEPEND}
@@ -35,6 +35,10 @@ src_prepare() {
autotools-utils_src_prepare
}
+src_configure() {
+ econf --disable-static
+}
+
src_compile() {
autotools-utils_src_compile
if use doc; then
@@ -53,4 +57,6 @@ src_install() {
insinto /usr/share/doc/${PF}/examples
doins examples/*.cc
fi
+
+ find "${ED}" -name '*.la' -delete || die
}
diff --git a/sci-libs/cln/cln-1.3.4.ebuild b/sci-libs/cln/cln-1.3.4.ebuild
index e8173925c67e..da31581523ef 100644
--- a/sci-libs/cln/cln-1.3.4.ebuild
+++ b/sci-libs/cln/cln-1.3.4.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://www.ginac.de/CLN/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="1"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples static-libs"
+IUSE="doc examples"
RDEPEND="dev-libs/gmp:0="
DEPEND="${RDEPEND}
@@ -35,6 +35,10 @@ src_prepare() {
autotools-utils_src_prepare
}
+src_configure() {
+ econf --disable-static
+}
+
src_compile() {
autotools-utils_src_compile
if use doc; then
@@ -53,4 +57,6 @@ src_install() {
insinto /usr/share/doc/${PF}/examples
doins examples/*.cc
fi
+
+ find "${ED}" -name '*.la' -delete || die
}
diff --git a/sci-libs/cln/cln-1.3.6.ebuild b/sci-libs/cln/cln-1.3.6.ebuild
index 66502b2bb272..f0d995c3dc05 100644
--- a/sci-libs/cln/cln-1.3.6.ebuild
+++ b/sci-libs/cln/cln-1.3.6.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://www.ginac.de/CLN/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="1"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples static-libs"
+IUSE="doc examples"
RDEPEND="dev-libs/gmp:0="
DEPEND="${RDEPEND}
@@ -33,6 +33,10 @@ src_prepare() {
Makefile.in || die
}
+src_configure() {
+ econf --disable-static
+}
+
src_compile() {
default
if use doc; then
@@ -51,4 +55,6 @@ src_install() {
docinto examples
dodoc examples/*.cc
fi
+
+ find "${ED}" -name '*.la' -delete || die
}