summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/cminpack
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/cminpack')
-rw-r--r--sci-libs/cminpack/Manifest2
-rw-r--r--sci-libs/cminpack/cminpack-1.3.2.ebuild35
-rw-r--r--sci-libs/cminpack/cminpack-1.3.4.ebuild35
-rw-r--r--sci-libs/cminpack/files/cminpack-1.2.2-underlinking.patch15
-rw-r--r--sci-libs/cminpack/metadata.xml17
5 files changed, 104 insertions, 0 deletions
diff --git a/sci-libs/cminpack/Manifest b/sci-libs/cminpack/Manifest
new file mode 100644
index 000000000000..572530c271ec
--- /dev/null
+++ b/sci-libs/cminpack/Manifest
@@ -0,0 +1,2 @@
+DIST cminpack-1.3.2.tar.gz 299376 SHA256 a0a7f9b2e97c4f6dc8fe39675aed8423b27c7e839ba6c1745bcc2acc09c97825 SHA512 ec7cf2bdb58148b7664cca78cb2f5f2501c8d2df46a723285832a4e1fbe69457d1b5f67d2cdc7904900597a1af7bb22008e13f260e4672c32944cdadd856fd82 WHIRLPOOL 530d047bc56d536e2bec32d99845202ff9a664e70df1c2f6a1bd2023f6efd098338d2101a077365109c177a65b57be7c3d23aca7b2c5023e0fff63d660ca6848
+DIST cminpack-1.3.4.tar.gz 311147 SHA256 3b517bf7dca68cc9a882883db96dac0a0d37d72aba6dfb0c9c7e78e67af503ca SHA512 2221dd710285e4d043ec51b296979686645ee48dad2e4bcbfef3e78ff6e8e02c09575af17edc3e9879cb9b7d4b431f0effe24640a2bdc437e32d0d0710545d7a WHIRLPOOL 460b56dcdac171daf9fda1c43b05654b549f1349babe8dfe5190f2aea98c3c42953ceda12e6dfff49d93958c6aaa0dc8b124477d1a22346e4d0a557dcae692a4
diff --git a/sci-libs/cminpack/cminpack-1.3.2.ebuild b/sci-libs/cminpack/cminpack-1.3.2.ebuild
new file mode 100644
index 000000000000..236b20addd76
--- /dev/null
+++ b/sci-libs/cminpack/cminpack-1.3.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils multilib
+
+DESCRIPTION="C implementation of the MINPACK nonlinear optimization library"
+HOMEPAGE="http://devernay.free.fr/hacks/cminpack/"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+
+LICENSE="minpack"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.2.2-underlinking.patch )
+
+src_configure() {
+ sed -i \
+ -e "/CMINPACK_LIB_INSTALL_DIR/s:lib\(\|64\):$(get_libdir):g" \
+ cmake/cminpack_utils.cmake || die
+ local mycmakeargs+=(
+ -DSHARED_LIBS=ON
+ $(cmake-utils_use_build test examples)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc readme*
+ use doc && dohtml -A .txt doc/*
+}
diff --git a/sci-libs/cminpack/cminpack-1.3.4.ebuild b/sci-libs/cminpack/cminpack-1.3.4.ebuild
new file mode 100644
index 000000000000..d3a605fa2764
--- /dev/null
+++ b/sci-libs/cminpack/cminpack-1.3.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils multilib
+
+DESCRIPTION="C implementation of the MINPACK nonlinear optimization library"
+HOMEPAGE="http://devernay.free.fr/hacks/cminpack/"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+
+LICENSE="minpack"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.2.2-underlinking.patch )
+
+src_configure() {
+ sed -i \
+ -e "/CMINPACK_LIB_INSTALL_DIR/s:lib\(\|64\):$(get_libdir):g" \
+ cmake/cminpack_utils.cmake || die
+ local mycmakeargs+=(
+ -DSHARED_LIBS=ON
+ $(cmake-utils_use_build test examples)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc readme*
+ use doc && dohtml -A .txt doc/*
+}
diff --git a/sci-libs/cminpack/files/cminpack-1.2.2-underlinking.patch b/sci-libs/cminpack/files/cminpack-1.2.2-underlinking.patch
new file mode 100644
index 000000000000..a042d4c2f72b
--- /dev/null
+++ b/sci-libs/cminpack/files/cminpack-1.2.2-underlinking.patch
@@ -0,0 +1,15 @@
+ CMakeLists.txt | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 57394af..5a46a75 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -56,6 +56,7 @@ set (cminpack_hdrs
+ cminpack.h minpack.h)
+
+ add_library (cminpack ${LIB_TYPE} ${cminpack_srcs})
++target_link_libraries (cminpack m)
+
+ install (TARGETS cminpack
+ LIBRARY DESTINATION ${CMINPACK_LIB_INSTALL_DIR} COMPONENT library
diff --git a/sci-libs/cminpack/metadata.xml b/sci-libs/cminpack/metadata.xml
new file mode 100644
index 000000000000..7f432fd0dc55
--- /dev/null
+++ b/sci-libs/cminpack/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ Minpack includes software for solving nonlinear equations and
+ nonlinear least squares problems. Five algorithmic paths each
+ include a core subroutine and an easy-to-use driver. The algorithms
+ proceed either from an analytic specification of the Jacobian matrix
+ or directly from the problem functions. The paths include facilities
+ for systems of equations with a banded Jacobian matrix, for least
+ squares problems with a large amount of data, and for checking the
+ consistency of the Jacobian matrix with the functions.
+ This is the C re-write of the original fortran minpack
+ implementation.
+</longdescription>
+</pkgmetadata>