summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/coinor-cgl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/coinor-cgl')
-rw-r--r--sci-libs/coinor-cgl/Manifest1
-rw-r--r--sci-libs/coinor-cgl/coinor-cgl-0.58.6.ebuild68
-rw-r--r--sci-libs/coinor-cgl/metadata.xml12
3 files changed, 81 insertions, 0 deletions
diff --git a/sci-libs/coinor-cgl/Manifest b/sci-libs/coinor-cgl/Manifest
new file mode 100644
index 000000000000..3b0f81049c71
--- /dev/null
+++ b/sci-libs/coinor-cgl/Manifest
@@ -0,0 +1 @@
+DIST Cgl-0.58.6.tgz 5331274 SHA256 1a690475f3dcd5830949d67dae3669ade4b1b5f8415b30d0759b161c26b9a476 SHA512 28fe2e570cb2ebfa3109ca53e5ebb7dd3a38e2ddcfda4d7a9a1d78d4784abe1b6ab79734e6cbcee48e21791fe8353658df47d11253b04366ccb66c3e566db585 WHIRLPOOL 60627feebe64cedfe26c56aae7c432d409e2136d5a5090569577914343a1248b1e8b695d99808676931bb5b27e7cd4270de2aef0db198fb03b3494e23ff382f8
diff --git a/sci-libs/coinor-cgl/coinor-cgl-0.58.6.ebuild b/sci-libs/coinor-cgl/coinor-cgl-0.58.6.ebuild
new file mode 100644
index 000000000000..c7a11f057c05
--- /dev/null
+++ b/sci-libs/coinor-cgl/coinor-cgl-0.58.6.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils multilib
+
+MYPN=Cgl
+
+DESCRIPTION="COIN-OR cutting-plane generators library"
+HOMEPAGE="https://projects.coin-or.org/Cgl/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs test"
+
+RDEPEND="
+ sci-libs/coinor-clp:=
+ sci-libs/coinor-dylp:=
+ sci-libs/coinor-osi:=
+ sci-libs/coinor-utils:=
+ sci-libs/coinor-vol:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+ test? ( sci-libs/coinor-sample )"
+
+S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
+
+src_prepare() {
+ # needed for the --with-coin-instdir
+ dodir /usr
+ sed -i \
+ -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ configure || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-dependency-linking
+ --with-coin-instdir="${ED}"/usr
+ $(use_with doc dot)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile all $(usex doc doxydoc "")
+}
+
+src_test() {
+ autotools-utils_src_test test
+}
+
+src_install() {
+ use doc && HTML_DOC=("${BUILD_DIR}/doxydocs/html/")
+ autotools-utils_src_install
+ # already installed
+ rm "${ED}"/usr/share/coin/doc/${MYPN}/{README,AUTHORS,LICENSE} || die
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/sci-libs/coinor-cgl/metadata.xml b/sci-libs/coinor-cgl/metadata.xml
new file mode 100644
index 000000000000..20a7edd0c5af
--- /dev/null
+++ b/sci-libs/coinor-cgl/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ The COIN-OR Cut Generation Library (Cgl) is an open collection of
+ cutting plane implementations ("cut generators") for use in teaching,
+ research, and applications. Cgl can be used with other COIN-OR
+ packages that make use of cuts, such as the mixed-integer linear
+ programming.
+</longdescription>
+</pkgmetadata>