summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/coinor-mp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/coinor-mp')
-rw-r--r--sci-libs/coinor-mp/Manifest1
-rw-r--r--sci-libs/coinor-mp/coinor-mp-1.7.6.ebuild61
-rw-r--r--sci-libs/coinor-mp/metadata.xml11
3 files changed, 73 insertions, 0 deletions
diff --git a/sci-libs/coinor-mp/Manifest b/sci-libs/coinor-mp/Manifest
new file mode 100644
index 000000000000..e09275b2c1e2
--- /dev/null
+++ b/sci-libs/coinor-mp/Manifest
@@ -0,0 +1 @@
+DIST CoinMP-1.7.6.tgz 10343849 SHA256 86c798780b9e1f5921fe4efe651a93cb420623b45aa1fdff57af8c37f116113f SHA512 1612d43d52d0ee29b4e6ca328e1535c59722dfd5c7a7e0811a4180ad6033ef27111ced6497f9d5cea816c047a4e11c2aed6d1936feac8ded797eeec55d9539ce WHIRLPOOL 32f392e7bc2a0ca1e4a3a7f4ae30d1302cac3e65630cfb8d1483dc5cdf26fb46ba758049f7bd590bb93e7b73018affe05118ebb15fe1e41ffaade8f5a938ea5a
diff --git a/sci-libs/coinor-mp/coinor-mp-1.7.6.ebuild b/sci-libs/coinor-mp/coinor-mp-1.7.6.ebuild
new file mode 100644
index 000000000000..8b7e475624ab
--- /dev/null
+++ b/sci-libs/coinor-mp/coinor-mp-1.7.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils multilib
+
+MYPN=CoinMP
+
+DESCRIPTION="COIN-OR lightweight API for COIN-OR libraries CLP, CBC, and CGL"
+HOMEPAGE="https://projects.coin-or.org/CoinMP/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="EPL-1.0"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples static-libs"
+
+RDEPEND="sci-libs/coinor-cbc:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
+
+src_prepare() {
+ # needed for the --with-coin-instdir
+ dodir /usr
+ sed -i \
+ -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ configure || die
+ sed -i \
+ -e '/^addlibsdir/s/$(DESTDIR)//' \
+ -e 's/$(addlibsdir)/$(DESTDIR)\/$(addlibsdir)/g' \
+ -e 's/$(DESTDIR)$(DESTDIR)/$(DESTDIR)/g' \
+ Makefile.in || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-dependency-linking
+ --with-coin-instdir="${ED}"/usr
+ --datadir=/usr/share
+ )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ autotools-utils_src_test test
+}
+
+src_install() {
+ autotools-utils_src_install
+ # already installed
+ rm "${ED}"/usr/share/coin/doc/${MYPN}/{README,AUTHORS,LICENSE} || die
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/sci-libs/coinor-mp/metadata.xml b/sci-libs/coinor-mp/metadata.xml
new file mode 100644
index 000000000000..d740b64ecba3
--- /dev/null
+++ b/sci-libs/coinor-mp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ The COmputational INfrastructure for Operations Research (COIN-OR)
+ MP is a C-API interface library that supports most of the
+ functionality of the CLP (Coin LP), CBC (Coin Branch-and-Cut), and
+ CGL (Cut Generation Library) projects.
+</longdescription>
+</pkgmetadata>