summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/coinor-os
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/coinor-os')
-rw-r--r--sci-libs/coinor-os/Manifest1
-rw-r--r--sci-libs/coinor-os/coinor-os-2.8.3.ebuild62
-rw-r--r--sci-libs/coinor-os/metadata.xml11
3 files changed, 74 insertions, 0 deletions
diff --git a/sci-libs/coinor-os/Manifest b/sci-libs/coinor-os/Manifest
new file mode 100644
index 000000000000..d5a01cd3bc78
--- /dev/null
+++ b/sci-libs/coinor-os/Manifest
@@ -0,0 +1 @@
+DIST OS-2.8.3.tgz 36046350 SHA256 45dbedbaf0db850a62d50351e1b855c529edcb627ed4ddea0011afbfc72e4da3 SHA512 33812e4ae12862bb44d0cb7e2210d418ce8fe705988364ee0622fc5aef04491e6675447bcac379a16add15ec4d123d853a5940ce1244a5767f1587c09b435078 WHIRLPOOL 8e802db5d0faf17e11cc11e5768c581b5b686fdea0db9668c6631a3a90aa9d71eb9f684bcfbba8dbdcc66d88ebf9367b8ce86e6c139cd640faf6d90673ab8d6e
diff --git a/sci-libs/coinor-os/coinor-os-2.8.3.ebuild b/sci-libs/coinor-os/coinor-os-2.8.3.ebuild
new file mode 100644
index 000000000000..1195488445c6
--- /dev/null
+++ b/sci-libs/coinor-os/coinor-os-2.8.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils multilib flag-o-matic
+
+MYPN=OS
+
+DESCRIPTION="COIN-OR Optimization Services"
+HOMEPAGE="https://projects.coin-or.org/OS/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="EPL-1.0"
+SLOT="0/6"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs test"
+
+RDEPEND="
+ sci-libs/coinor-bcp:=
+ sci-libs/coinor-bonmin:=
+ sci-libs/coinor-couenne:=
+ sci-libs/coinor-clp:=
+ sci-libs/coinor-dylp:=
+ sci-libs/coinor-symphony:=
+ sci-libs/coinor-utils:=
+ sci-libs/coinor-vol:=
+ sci-libs/ipopt:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+ test? ( sci-libs/coinor-sample )"
+
+S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
+
+src_prepare() {
+ append-cppflags -DNDEBUG
+ # needed for the --with-coin-instdir
+ dodir /usr
+ sed -i \
+ -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ configure || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-dependency-linking
+ --with-coin-instdir="${ED}"/usr
+ )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ autotools-utils_src_test test
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dodoc doc/*.pdf
+}
diff --git a/sci-libs/coinor-os/metadata.xml b/sci-libs/coinor-os/metadata.xml
new file mode 100644
index 000000000000..fd3616a08225
--- /dev/null
+++ b/sci-libs/coinor-os/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ The objective of Optimization Services (OS) is to provide a set of
+ standards for representing optimization instances, results, solver
+ options, and communication between clients and solvers in a
+ distributed environment using Web Services.
+</longdescription>
+</pkgmetadata>