summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /sci-libs/dlib
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-libs/dlib')
-rw-r--r--sci-libs/dlib/dlib-19.16.ebuild1
-rw-r--r--sci-libs/dlib/dlib-19.7.ebuild3
-rw-r--r--sci-libs/dlib/dlib-19.9.ebuild1
3 files changed, 4 insertions, 1 deletions
diff --git a/sci-libs/dlib/dlib-19.16.ebuild b/sci-libs/dlib/dlib-19.16.ebuild
index 93b39e4eaa05..3eef02e2c0e8 100644
--- a/sci-libs/dlib/dlib-19.16.ebuild
+++ b/sci-libs/dlib/dlib-19.16.ebuild
@@ -15,6 +15,7 @@ LICENSE="Boost-1.0"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="cblas cuda debug examples gif jpeg lapack mkl png python sqlite static-libs test X cpu_flags_x86_avx cpu_flags_x86_sse2 cpu_flags_x86_sse4_1"
+RESTRICT="!test? ( test )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
# doc needs a bunch of deps not in portage
diff --git a/sci-libs/dlib/dlib-19.7.ebuild b/sci-libs/dlib/dlib-19.7.ebuild
index 34db96814907..470c52a217e6 100644
--- a/sci-libs/dlib/dlib-19.7.ebuild
+++ b/sci-libs/dlib/dlib-19.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,6 +13,7 @@ LICENSE="Boost-1.0"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="cblas debug cuda examples gif jpeg lapack mkl png sqlite static-libs test X"
+RESTRICT="!test? ( test )"
# doc needs a bunch of deps not in portage
diff --git a/sci-libs/dlib/dlib-19.9.ebuild b/sci-libs/dlib/dlib-19.9.ebuild
index 28049b0cd64a..d0a78e21fc64 100644
--- a/sci-libs/dlib/dlib-19.9.ebuild
+++ b/sci-libs/dlib/dlib-19.9.ebuild
@@ -13,6 +13,7 @@ LICENSE="Boost-1.0"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="cblas debug cuda examples gif jpeg lapack mkl png python sqlite static-libs test X"
+RESTRICT="!test? ( test )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
# doc needs a bunch of deps not in portage