summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-07-22 16:57:54 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-07-22 16:58:02 +0200
commitece64176d2256f3edbd70c33ff8ac63c150909d6 (patch)
treec2ab3af869ec71b0bd7479c6aa4bd28c95c33c36 /sci-libs/fcl/fcl-0.5.0.ebuild
parentdev-util/rosinstall_generator: bump to 0.1.12 (diff)
downloadgentoo-ece64176d2256f3edbd70c33ff8ac63c150909d6.tar.gz
gentoo-ece64176d2256f3edbd70c33ff8ac63c150909d6.tar.bz2
gentoo-ece64176d2256f3edbd70c33ff8ac63c150909d6.zip
sci-libs/fcl: bump to 0.5.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-libs/fcl/fcl-0.5.0.ebuild')
-rw-r--r--sci-libs/fcl/fcl-0.5.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-libs/fcl/fcl-0.5.0.ebuild b/sci-libs/fcl/fcl-0.5.0.ebuild
new file mode 100644
index 000000000000..65a92633b478
--- /dev/null
+++ b/sci-libs/fcl/fcl-0.5.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/flexible-collision-library/fcl"
+fi
+
+inherit ${SCM} cmake-utils
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm"
+ SRC_URI="https://github.com/flexible-collision-library/fcl/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="The Flexible Collision Library"
+HOMEPAGE="http://gamma.cs.unc.edu/FCL/"
+LICENSE="BSD"
+SLOT="0"
+IUSE="cpu_flags_x86_sse"
+
+RDEPEND="
+ sci-libs/octomap
+ sci-libs/flann
+ dev-libs/boost:=[threads]
+ sci-libs/libccd"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ "-DFCL_USE_SSE=$(usex cpu_flags_x86_sse TRUE FALSE)"
+ )
+ cmake-utils_src_configure
+}