summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-25 21:42:13 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-25 21:46:20 +0100
commitcafa6007bf77dd0cd210ed9aeecd9e47053a9223 (patch)
tree98301de1bcfe93dd62ea27cd683ce09dc35288ea /sci-libs/gdal
parentdev-python/coverage: keyworded 4.5.4 for ppc64, bug #700194 (diff)
downloadgentoo-cafa6007bf77dd0cd210ed9aeecd9e47053a9223.tar.gz
gentoo-cafa6007bf77dd0cd210ed9aeecd9e47053a9223.tar.bz2
gentoo-cafa6007bf77dd0cd210ed9aeecd9e47053a9223.zip
sci-libs/gdal: Fix build with app-text/poppler-0.83.0
Closes: https://bugs.gentoo.org/703790 Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-libs/gdal')
-rw-r--r--sci-libs/gdal/files/gdal-2.4.1-poppler-0.83-1.patch27
-rw-r--r--sci-libs/gdal/files/gdal-2.4.1-poppler-0.83-2.patch42
-rw-r--r--sci-libs/gdal/gdal-2.4.1-r2.ebuild1
3 files changed, 70 insertions, 0 deletions
diff --git a/sci-libs/gdal/files/gdal-2.4.1-poppler-0.83-1.patch b/sci-libs/gdal/files/gdal-2.4.1-poppler-0.83-1.patch
new file mode 100644
index 000000000000..f077f4632386
--- /dev/null
+++ b/sci-libs/gdal/files/gdal-2.4.1-poppler-0.83-1.patch
@@ -0,0 +1,27 @@
+From 1f8fa16f58cfe0364099ddad0e1d86522d8de41a Mon Sep 17 00:00:00 2001
+From: Even Rouault <even.rouault@spatialys.com>
+Date: Wed, 13 Nov 2019 14:07:22 +0100
+Subject: [PATCH] PDF: fix build against Poppler 0.83.0dev
+
+---
+ gdal/frmts/pdf/pdfdataset.cpp | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/frmts/pdf/pdfdataset.cpp b/frmts/pdf/pdfdataset.cpp
+index 8f944c40d30..88017953de5 100644
+--- a/frmts/pdf/pdfdataset.cpp
++++ b/frmts/pdf/pdfdataset.cpp
+@@ -4267,7 +4267,13 @@ PDFDataset *PDFDataset::Open( GDALOpenInfo * poOpenInfo )
+ CPLMutexHolderD(&hGlobalParamsMutex);
+ /* poppler global variable */
+ if (globalParams == nullptr)
++ {
++#if POPPLER_MAJOR_VERSION >= 1 || POPPLER_MINOR_VERSION >= 83
++ globalParams.reset(new GlobalParams());
++#else
+ globalParams = new GlobalParams();
++#endif
++ }
+
+ globalParams->setPrintCommands(CPLTestBool(
+ CPLGetConfigOption("GDAL_PDF_PRINT_COMMANDS", "FALSE")));
diff --git a/sci-libs/gdal/files/gdal-2.4.1-poppler-0.83-2.patch b/sci-libs/gdal/files/gdal-2.4.1-poppler-0.83-2.patch
new file mode 100644
index 000000000000..74614e925f6d
--- /dev/null
+++ b/sci-libs/gdal/files/gdal-2.4.1-poppler-0.83-2.patch
@@ -0,0 +1,42 @@
+From 7318576fc7037412b755f038f8148f2d299587aa Mon Sep 17 00:00:00 2001
+From: Even Rouault <even.rouault@spatialys.com>
+Date: Tue, 26 Nov 2019 14:33:32 +0100
+Subject: [PATCH] PDF: fix to build against latest Poppler master (0.83dev)
+
+---
+ gdal/frmts/pdf/pdfio.cpp | 3 +++
+ gdal/frmts/pdf/pdfio.h | 7 ++++++-
+ 2 files changed, 9 insertions(+), 1 deletion(-)
+
+diff --git a/frmts/pdf/pdfio.cpp b/frmts/pdf/pdfio.cpp
+index 917e92330ae..c0b9dad93cb 100644
+--- a/frmts/pdf/pdfio.cpp
++++ b/frmts/pdf/pdfio.cpp
+@@ -170,6 +170,9 @@ getStart_ret_type VSIPDFFileStream::getStart()
+ /************************************************************************/
+
+ StreamKind VSIPDFFileStream::getKind()
++#if POPPLER_MAJOR_VERSION >= 1 || POPPLER_MINOR_VERSION >= 83
++ const
++#endif
+ {
+ return strFile;
+ }
+diff --git a/frmts/pdf/pdfio.h b/frmts/pdf/pdfio.h
+index aa34ab7210d..23344d33f77 100644
+--- a/frmts/pdf/pdfio.h
++++ b/frmts/pdf/pdfio.h
+@@ -81,7 +81,12 @@ class VSIPDFFileStream final: public BaseStream
+ virtual void setPos(setPos_offset_type pos, int dir = 0) override;
+ virtual void moveStart(moveStart_delta_type delta) override;
+
+- virtual StreamKind getKind() override;
++ virtual StreamKind getKind()
++#if POPPLER_MAJOR_VERSION >= 1 || POPPLER_MINOR_VERSION >= 83
++ const
++#endif
++ override;
++
+ virtual GooString *getFileName() override;
+
+ virtual int getChar() override;
diff --git a/sci-libs/gdal/gdal-2.4.1-r2.ebuild b/sci-libs/gdal/gdal-2.4.1-r2.ebuild
index fa26cc48e938..897a9cf41ae5 100644
--- a/sci-libs/gdal/gdal-2.4.1-r2.ebuild
+++ b/sci-libs/gdal/gdal-2.4.1-r2.ebuild
@@ -85,6 +85,7 @@ PATCHES=(
"${FILESDIR}/${P}-poppler-0.76.patch"
"${FILESDIR}/${P}-swig-4.patch" # bug 689110
"${FILESDIR}/${P}-poppler-0.82.patch"
+ "${FILESDIR}"/${P}-poppler-0.83-{1,2}.patch # bug 703790
)
src_prepare() {