summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2018-11-10 09:29:42 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2018-11-10 09:30:03 -0500
commitbf164e4fb624fd44f3b07ddc1a827bbe227a1c13 (patch)
tree06c1c663178e49a749a044e57e172ea6f7949d1f /sci-libs/geos/geos-3.6.2.ebuild
parentdev-ada/aunit: stabilize and remove old (diff)
downloadgentoo-bf164e4fb624fd44f3b07ddc1a827bbe227a1c13.tar.gz
gentoo-bf164e4fb624fd44f3b07ddc1a827bbe227a1c13.tar.bz2
gentoo-bf164e4fb624fd44f3b07ddc1a827bbe227a1c13.zip
sci-libs/geos: Remove 3.6.2
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Aaron Swenson <titanofold@gentoo.org>
Diffstat (limited to 'sci-libs/geos/geos-3.6.2.ebuild')
-rw-r--r--sci-libs/geos/geos-3.6.2.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/sci-libs/geos/geos-3.6.2.ebuild b/sci-libs/geos/geos-3.6.2.ebuild
deleted file mode 100644
index a53255ec4230..000000000000
--- a/sci-libs/geos/geos-3.6.2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-single-r1
-
-DESCRIPTION="Geometry engine library for Geographic Information Systems"
-HOMEPAGE="http://trac.osgeo.org/geos/"
-SRC_URI="http://download.osgeo.org/geos/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 ia64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
-IUSE="doc python ruby static-libs"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- python? ( ${PYTHON_DEPS} )
- ruby? ( dev-lang/ruby:* )
-"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
- python? ( dev-lang/swig:0 )
- ruby? ( dev-lang/swig:0 )
-"
-
-PATCHES=( "${FILESDIR}"/3.4.2-solaris-isnan.patch )
-
-RESTRICT="test"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
- echo "#!${EPREFIX}/bin/bash" > py-compile
-}
-
-src_configure() {
- econf \
- $(use_enable python) \
- $(use_enable ruby) \
- $(use_enable static-libs static)
-}
-
-src_compile() {
- default
- use doc && emake -C "${S}/doc" doxygen-html
-}
-
-src_install() {
- use doc && HTML_DOCS=( doc/doxygen_docs/html/. )
- default
- use python && python_optimize "${D}$(python_get_sitedir)"/geos/
-
- find "${D}" -name '*.la' -delete || die
-}