summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2019-07-05 07:35:10 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2019-07-05 07:35:14 -0400
commit56f04b6061aeabed1d0459b74e474a00752b6172 (patch)
treedd971c839360777a8aeeee54c3322cdbf21f9c61 /sci-libs/geos
parentmedia-gfx/imagemagick: Version bump to 7.0.8.51 (diff)
downloadgentoo-56f04b6061aeabed1d0459b74e474a00752b6172.tar.gz
gentoo-56f04b6061aeabed1d0459b74e474a00752b6172.tar.bz2
gentoo-56f04b6061aeabed1d0459b74e474a00752b6172.zip
sci-libs/geos: Bump to 3.7.2
Package-Manager: Portage-2.3.66, Repoman-2.3.11 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'sci-libs/geos')
-rw-r--r--sci-libs/geos/Manifest1
-rw-r--r--sci-libs/geos/geos-3.7.2.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sci-libs/geos/Manifest b/sci-libs/geos/Manifest
index d10e26879ca2..30e3b5649631 100644
--- a/sci-libs/geos/Manifest
+++ b/sci-libs/geos/Manifest
@@ -1 +1,2 @@
DIST geos-3.7.0.tar.bz2 2028814 BLAKE2B 17385d9be831d4812391a30627e13989d3ca099ca9b0a719a92cdb2503dadff3693d4b3d320652764185db05782b33760ca14d155365d87167bb4ef6d6c2463c SHA512 fcca5e503efa32bb388376b2a06b9ca5c74fbcddba750cce6b3b4109eb2eb122058aead12b9462cdd881f425cd75d7241645ab344f25ce022bc0659954560742
+DIST geos-3.7.2.tar.bz2 2071465 BLAKE2B ba968488aa5d845e582d3771d8d2b1f67b0f301e73fad5834a0805a912c8f3b1200bba93d8758f43539ce269758de348d999db3db9738e7abf5c1a443f388d8c SHA512 ff0fde2e21ed9d2770c139aa50c6efd22d9cff3c6bfd8f1ef86b064efd1ad318b08dec66e34661bc1c7a341b0837978853494f27d63988be865a8ee4f7611d38
diff --git a/sci-libs/geos/geos-3.7.2.ebuild b/sci-libs/geos/geos-3.7.2.ebuild
new file mode 100644
index 000000000000..1acbe1537bf3
--- /dev/null
+++ b/sci-libs/geos/geos-3.7.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Geometry engine library for Geographic Information Systems"
+HOMEPAGE="http://trac.osgeo.org/geos/"
+SRC_URI="http://download.osgeo.org/geos/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="doc python ruby static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ python? ( ${PYTHON_DEPS} )
+ ruby? ( dev-lang/ruby:* )
+"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ python? ( dev-lang/swig:0 )
+ ruby? ( dev-lang/swig:0 )
+"
+
+PATCHES=( "${FILESDIR}"/3.4.2-solaris-isnan.patch )
+
+RESTRICT="test"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ echo "#!${EPREFIX}/bin/bash" > py-compile
+}
+
+src_configure() {
+ econf \
+ $(use_enable python) \
+ $(use_enable ruby) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+ use doc && emake -C "${S}/doc" doxygen-html
+}
+
+src_install() {
+ use doc && HTML_DOCS=( doc/doxygen_docs/html/. )
+ default
+ use python && python_optimize "${D}$(python_get_sitedir)"/geos/
+
+ find "${D}" -name '*.la' -delete || die
+}