summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-03-26 11:45:23 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-26 13:38:32 +0100
commitae405b66699378c4e527337ba4a78bf793d67cf3 (patch)
treef9792d6051652d8aba0be35e47152a817899283f /sci-libs/geos
parentdev-util/clazy: 1.6 version bump (diff)
downloadgentoo-ae405b66699378c4e527337ba4a78bf793d67cf3.tar.gz
gentoo-ae405b66699378c4e527337ba4a78bf793d67cf3.tar.bz2
gentoo-ae405b66699378c4e527337ba4a78bf793d67cf3.zip
sci-libs/geos: 3.8.1 version bump
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-libs/geos')
-rw-r--r--sci-libs/geos/Manifest1
-rw-r--r--sci-libs/geos/geos-3.8.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sci-libs/geos/Manifest b/sci-libs/geos/Manifest
index 7a85d86d687f..2b565318d514 100644
--- a/sci-libs/geos/Manifest
+++ b/sci-libs/geos/Manifest
@@ -1,2 +1,3 @@
DIST geos-3.7.2.tar.bz2 2071465 BLAKE2B ba968488aa5d845e582d3771d8d2b1f67b0f301e73fad5834a0805a912c8f3b1200bba93d8758f43539ce269758de348d999db3db9738e7abf5c1a443f388d8c SHA512 ff0fde2e21ed9d2770c139aa50c6efd22d9cff3c6bfd8f1ef86b064efd1ad318b08dec66e34661bc1c7a341b0837978853494f27d63988be865a8ee4f7611d38
DIST geos-3.8.0.tar.bz2 2399403 BLAKE2B 0f9b6d7f9a4052b9b84e77d534be6e2909e5dc4995287f34e3b7e7c1537c9a73088d4a49f96f43034723eb37c88674aae469e26d7db3eb40efbcdf5551553a1a SHA512 c89b25b42092152ef261090f25ff64b229f30f67d42fdf44c2871e78b66bb2c42e23b9ae21f9aea0e48823bdb0267d609ab2ee77d310abcb76fa672c6614d8f1
+DIST geos-3.8.1.tar.bz2 2505407 BLAKE2B 43053ea9e29d190f41c37d5d382b689ef477e0256cfd5705f4f2f316cac21a1674660bcf0900c51db72909c41d46be7a41d297958de48e108ae6d6bd1ca9d247 SHA512 1d8d8b3ece70eb388ea128f4135c7455899f01828223b23890ad3a2401e27104efce03987676794273a9b9d4907c0add2be381ff14b8420aaa9a858cc5941056
diff --git a/sci-libs/geos/geos-3.8.1.ebuild b/sci-libs/geos/geos-3.8.1.ebuild
new file mode 100644
index 000000000000..ad70d2dd21ca
--- /dev/null
+++ b/sci-libs/geos/geos-3.8.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Geometry engine library for Geographic Information Systems"
+HOMEPAGE="http://trac.osgeo.org/geos/"
+SRC_URI="http://download.osgeo.org/geos/${PN}-${PV}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="doc ruby static-libs"
+
+BDEPEND="
+ doc? ( app-doc/doxygen )
+ ruby? ( dev-lang/swig:0 )
+"
+RDEPEND="
+ ruby? ( dev-lang/ruby:* )
+"
+DEPEND="${RDEPEND}"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ echo "#!${EPREFIX}/bin/bash" > py-compile
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-python
+ $(use_enable ruby)
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+ use doc && emake -C doc doxygen-html
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/doxygen_docs/html/. )
+ default
+
+ find "${D}" -name '*.la' -type f -delete || die
+}