summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-20 18:03:04 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-20 18:06:44 +0100
commit0e930a6532f6df3ce4b097e9e2d72d4dfb036fe4 (patch)
tree62f485f8425e09e7c0ddb77d21ff73cc647c96b6 /sci-libs/getdata/files
parentsci-libs/getdata: Build correctly for single python (diff)
downloadgentoo-0e930a6532f6df3ce4b097e9e2d72d4dfb036fe4.tar.gz
gentoo-0e930a6532f6df3ce4b097e9e2d72d4dfb036fe4.tar.bz2
gentoo-0e930a6532f6df3ce4b097e9e2d72d4dfb036fe4.zip
sci-libs/getdata: Version Bump
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-libs/getdata/files')
-rw-r--r--sci-libs/getdata/files/getdata-0.9.0-serial-test.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/sci-libs/getdata/files/getdata-0.9.0-serial-test.patch b/sci-libs/getdata/files/getdata-0.9.0-serial-test.patch
new file mode 100644
index 000000000000..ea17e548da2f
--- /dev/null
+++ b/sci-libs/getdata/files/getdata-0.9.0-serial-test.patch
@@ -0,0 +1,41 @@
+ bindings/Makefile.am | 6 +-----
+ bindings/python/test/Makefile.am | 2 +-
+ 2 files changed, 2 insertions(+), 6 deletions(-)
+
+diff --git a/bindings/Makefile.am b/bindings/Makefile.am
+index ad9f0d2..9e333a5 100644
+--- a/bindings/Makefile.am
++++ b/bindings/Makefile.am
+@@ -38,10 +38,6 @@ if MAKE_MATLABBINDINGS
+ MATLAB_SUBDIR=matlab
+ endif
+
+-if MAKE_PYBINDINGS
+-PY_SUBDIR=python
+-endif
+-
+ if MAKE_PERLBINDINGS
+ PERL_SUBDIR=perl
+ endif
+@@ -55,7 +51,7 @@ noinst_PROGRAMS=make_parameters
+ make_parameters_SOURCES = make_parameters.c
+ nodist_make_parameters_SOURCES = ../src/getdata.h ../src/gd_config.h
+
+-SUBDIRS = . ${F77_SUBDIR} ${CXX_SUBDIR} ${IDL_SUBDIR} ${PY_SUBDIR} \
++SUBDIRS = . ${F77_SUBDIR} ${CXX_SUBDIR} ${IDL_SUBDIR} \
+ ${PERL_SUBDIR} ${MATLAB_SUBDIR} ${PHP_SUBDIR}
+
+ make_parameters$(EXEEXT): $(make_parameters_SOURCES) \
+diff --git a/bindings/python/test/Makefile.am b/bindings/python/test/Makefile.am
+index 32d786f..f4be3de 100644
+--- a/bindings/python/test/Makefile.am
++++ b/bindings/python/test/Makefile.am
+@@ -18,7 +18,7 @@
+ # along with GetData; if not, write to the Free Software Foundation, Inc.,
+ # 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+ #
+-AUTOMAKE_OPTIONS = foreign serial-tests
++AUTOMAKE_OPTIONS = foreign
+
+ if TEST_PYTHON
+ TESTS_ENVIRONMENT=${DL_LIBRARY_PATH}=../../../src/.libs:${${DL_LIBRARY_PATH}} PYTHONPATH=..:${PYTHONPATH} ${PYTHON}