summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2019-10-07 01:24:00 +0200
committerDavid Seifert <soap@gentoo.org>2019-10-20 15:22:13 +0200
commitefd16ef7feee4548d53c8227a7b0f1b85ff2d58d (patch)
treeec8fdc3530f03f0469e3309f0757292a8ae165f0 /sci-libs/hdf5
parentsci-libs/tamu_anova: various fixes (diff)
downloadgentoo-efd16ef7feee4548d53c8227a7b0f1b85ff2d58d.tar.gz
gentoo-efd16ef7feee4548d53c8227a7b0f1b85ff2d58d.tar.bz2
gentoo-efd16ef7feee4548d53c8227a7b0f1b85ff2d58d.zip
sci-libs/hdf5: disable static libraries
Closes: https://bugs.gentoo.org/694128 Closes: https://github.com/gentoo/gentoo/pull/13061 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/hdf5')
-rw-r--r--sci-libs/hdf5/hdf5-1.10.5.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/sci-libs/hdf5/hdf5-1.10.5.ebuild b/sci-libs/hdf5/hdf5-1.10.5.ebuild
index a3c248db158e..deaec088dd13 100644
--- a/sci-libs/hdf5/hdf5-1.10.5.ebuild
+++ b/sci-libs/hdf5/hdf5-1.10.5.ebuild
@@ -17,7 +17,7 @@ SRC_URI="http://www.hdfgroup.org/ftp/HDF5/releases/${MAJOR_P}/${MY_P}/src/${MY_P
LICENSE="NCSA-HDF"
SLOT="0/${PV%%_p*}"
KEYWORDS="alpha amd64 ~arm arm64 ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="cxx debug examples fortran +hl mpi static-libs szip threads zlib"
+IUSE="cxx debug examples fortran +hl mpi szip threads zlib"
REQUIRED_USE="
cxx? ( !mpi ) mpi? ( !cxx )
@@ -79,10 +79,11 @@ src_prepare() {
src_configure() {
econf \
+ --disable-static \
--enable-deprecated-symbols \
- $(use debug && echo --enable-build-mode=debug || echo --enable-build-mode=production) \
- $(use_enable debug codestack) \
+ --enable-build-mode=$(usex debug debug production) \
$(use_enable cxx) \
+ $(use_enable debug codestack) \
$(use_enable fortran) \
$(use_enable hl) \
$(use_enable mpi parallel) \
@@ -91,3 +92,10 @@ src_configure() {
$(use_with threads pthread) \
$(use_with zlib)
}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}