summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-27 02:49:04 +0000
committerSam James <sam@gentoo.org>2021-03-27 02:57:41 +0000
commit82d812386cd653b498ce02733f38d7deea991f95 (patch)
tree301ebae2b097f049aee659e7a2c5de1c9695fcb0 /sci-libs/hypre
parentsci-libs/hypre: fix github remote-id (diff)
downloadgentoo-82d812386cd653b498ce02733f38d7deea991f95.tar.gz
gentoo-82d812386cd653b498ce02733f38d7deea991f95.tar.bz2
gentoo-82d812386cd653b498ce02733f38d7deea991f95.zip
sci-libs/hypre: drop useless cmake.eclass inherit in 2.18.2
Closes: https://bugs.gentoo.org/681580 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/hypre')
-rw-r--r--sci-libs/hypre/hypre-2.18.2-r1.ebuild (renamed from sci-libs/hypre/hypre-2.18.2.ebuild)21
1 files changed, 11 insertions, 10 deletions
diff --git a/sci-libs/hypre/hypre-2.18.2.ebuild b/sci-libs/hypre/hypre-2.18.2-r1.ebuild
index 2b5614b59ac8..e47dfb45334e 100644
--- a/sci-libs/hypre/hypre-2.18.2.ebuild
+++ b/sci-libs/hypre/hypre-2.18.2-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
FORTRAN_NEEDED=fortran
-inherit cmake-utils fortran-2 toolchain-funcs flag-o-matic
+inherit fortran-2 toolchain-funcs flag-o-matic
DESCRIPTION="Parallel matrix preconditioners library"
HOMEPAGE="https://computation.llnl.gov/projects/hypre-scalable-linear-solvers-multigrid-methods"
@@ -16,24 +16,24 @@ SLOT="0/${PV}"
KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE="debug examples fortran int64 openmp mpi"
+BDEPEND="virtual/pkgconfig"
RDEPEND="
sci-libs/superlu:=
virtual/blas
virtual/lapack
mpi? ( virtual/mpi )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
DOCS=( CHANGELOG COPYRIGHT README )
pkg_pretend() {
[[ ${MERGE_TYPE} != binary ]] &&\
- use openmp && [[ $(tc-getCC)$ == *gcc* ]] && tc-check-openmp
+ use openmp && [[ $(tc-getCC) == *gcc* ]] && tc-check-openmp
}
pkg_setup() {
if [[ ${MERGE_TYPE} != binary ]] && \
- use openmp && [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp ; then
+ use openmp && [[ $(tc-getCC) == *gcc* ]] && ! tc-has-openmp ; then
ewarn "You are using a non capable gcc compiler ( < 4.2 ? )"
die "Need an OpenMP capable compiler"
fi
@@ -56,11 +56,11 @@ src_prepare() {
src_configure() {
tc-export CC CXX
append-flags -Dhypre_dgesvd=dgesvd_
- use openmp && [[ $(tc-getCC)$ == *gcc* ]] && \
+ use openmp && [[ $(tc-getCC) == *gcc* ]] && \
append-flags -fopenmp && append-ldflags -fopenmp
use mpi && CC=mpicc FC=mpif77 CXX=mpicxx
- cd src
+ cd src || die
# without-superlu: means do not use bundled one
econf \
@@ -93,7 +93,8 @@ src_install() {
emake -C src install \
HYPRE_INSTALL_DIR="${ED}" \
HYPRE_LIB_INSTALL="${ED}/usr/$(get_libdir)" \
- HYPRE_INC_INSTALL="${ED}$/usr/include/hypre"
+ HYPRE_INC_INSTALL="${ED}/usr/include/hypre"
+
if use examples; then
dodoc -r src/examples
fi