summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2020-09-25 19:47:30 +0800
committerBenda Xu <heroxbd@gentoo.org>2020-09-25 19:47:30 +0800
commitf664ab78a1c118ee174d3980d03a9eee63494a11 (patch)
tree1ebaae9803b734b90eae767f34a92116f8324b27 /sci-libs/keras-preprocessing/keras-preprocessing-1.1.0-r1.ebuild
parentsci-libs/keras-applications: tested on Python 3.8. (diff)
downloadgentoo-f664ab78a1c118ee174d3980d03a9eee63494a11.tar.gz
gentoo-f664ab78a1c118ee174d3980d03a9eee63494a11.tar.bz2
gentoo-f664ab78a1c118ee174d3980d03a9eee63494a11.zip
sci-libs/keras-preprocessing: tested on Python 3.8.
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sci-libs/keras-preprocessing/keras-preprocessing-1.1.0-r1.ebuild')
-rw-r--r--sci-libs/keras-preprocessing/keras-preprocessing-1.1.0-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/sci-libs/keras-preprocessing/keras-preprocessing-1.1.0-r1.ebuild b/sci-libs/keras-preprocessing/keras-preprocessing-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..3a96094ba07c
--- /dev/null
+++ b/sci-libs/keras-preprocessing/keras-preprocessing-1.1.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Easy data preprocessing and data augmentation for deep learning models"
+HOMEPAGE="https://keras.io/"
+SRC_URI="https://github.com/keras-team/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"