summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2021-03-12 05:46:28 +0100
committerDennis Lamm <expeditioneer@gentoo.org>2021-03-12 08:05:48 +0100
commitc5235789538de64ad424d19d722c04088dffec50 (patch)
tree609667fe99e0848e5c745c5a06d393c8881fb418 /sci-libs/levmar/levmar-2.6.ebuild
parentsci-libs/levmar: EAPI-7 bump (diff)
downloadgentoo-c5235789538de64ad424d19d722c04088dffec50.tar.gz
gentoo-c5235789538de64ad424d19d722c04088dffec50.tar.bz2
gentoo-c5235789538de64ad424d19d722c04088dffec50.zip
sci-libs/levmar: drop old
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Package-Manager: Portage-3.0.13, Repoman-3.0.2 Closes: https://github.com/gentoo/gentoo/pull/19887 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'sci-libs/levmar/levmar-2.6.ebuild')
-rw-r--r--sci-libs/levmar/levmar-2.6.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/sci-libs/levmar/levmar-2.6.ebuild b/sci-libs/levmar/levmar-2.6.ebuild
deleted file mode 100644
index e2729c65c384..000000000000
--- a/sci-libs/levmar/levmar-2.6.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit cmake-utils eutils toolchain-funcs
-
-DESCRIPTION="Levenberg-Marquardt nonlinear least squares C library"
-HOMEPAGE="https://www.ics.forth.gr/~lourakis/levmar/"
-SRC_URI="https://www.ics.forth.gr/~lourakis/levmar/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- virtual/blas
- virtual/lapack"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${P}-shared.patch
- "${FILESDIR}"/${P}-demo-underlinking.patch
-)
-
-src_configure() {
- local mycmakeargs+=(
- -DNEED_F2C=OFF
- -DHAVE_LAPACK=ON
- -DLAPACKBLAS_LIB_NAMES="$($(tc-getPKG_CONFIG) --libs blas lapack)"
- $(cmake-utils_use test BUILD_DEMO)
- )
- cmake-utils_src_configure
-}
-
-src_test() {
- cd ${CMAKE_BUILD_DIR}
- ./lmdemo || die
-}
-
-src_install() {
- dolib.so ${CMAKE_BUILD_DIR}/liblevmar.so
- insinto /usr/include
- doins levmar.h
-}