summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-20 21:37:27 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-20 23:06:07 +0200
commitc44d450a927693cd4d0ebb694cbebd0afcfef47a (patch)
treee85d0072f3b05c4e2531c90439115e954f7f7e31 /sci-libs/libgenome/libgenome-1.3-r1.ebuild
parentsci-biology/prank: Remove old ebuilds (diff)
downloadgentoo-c44d450a927693cd4d0ebb694cbebd0afcfef47a.tar.gz
gentoo-c44d450a927693cd4d0ebb694cbebd0afcfef47a.tar.bz2
gentoo-c44d450a927693cd4d0ebb694cbebd0afcfef47a.zip
sci-libs/libgenome: Allow for compiling with GCC 6
Gentoo-bug: 594372 * EAPI=6 Package-Manager: portage-2.3.1
Diffstat (limited to 'sci-libs/libgenome/libgenome-1.3-r1.ebuild')
-rw-r--r--sci-libs/libgenome/libgenome-1.3-r1.ebuild26
1 files changed, 17 insertions, 9 deletions
diff --git a/sci-libs/libgenome/libgenome-1.3-r1.ebuild b/sci-libs/libgenome/libgenome-1.3-r1.ebuild
index 77c6ca7ec1d5..a52575cbf169 100644
--- a/sci-libs/libgenome/libgenome-1.3-r1.ebuild
+++ b/sci-libs/libgenome/libgenome-1.3-r1.ebuild
@@ -1,32 +1,40 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="2"
+EAPI=6
-MY_TAG="mauve-2-3-0-release"
-#ESVN_REPO_URI="https://mauve.svn.sourceforge.net/svnroot/mauve/libGenome/tags/${MY_TAG}"
-
-#inherit subversion autotools
inherit autotools
DESCRIPTION="Library for sci-biology/mauve"
HOMEPAGE="http://gel.ahabs.wisc.edu/mauve/"
-#SRC_URI=""
SRC_URI="mirror://gentoo/${PF}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-IUSE="doc"
+IUSE="doc static-libs"
KEYWORDS="~amd64 ~x86"
DEPEND="doc? ( app-doc/doxygen )"
RDEPEND=""
+PATCHES=( "${FILESDIR}/${PN}-1.3-fix-c++14.patch" )
+
src_prepare() {
+ default
+ rm libGenome/gnDefs.cpp || die
eautoreconf
}
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
src_install() {
- emake install DESTDIR="${D}" || die
+ default
+
+ # package provides .pc files
+ find "${D}" -name '*.la' -delete || die
}