summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-05-16 21:56:11 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-16 23:49:24 +0200
commit3297c990c507035e989a30c03a499851f05b385d (patch)
tree1232f0e0ad41e4ee0c592df797e6b25c976f116b /sci-libs/libh2oxx
parentsci-libs/libh2oxx: Migrate to GitHub (diff)
downloadgentoo-3297c990c507035e989a30c03a499851f05b385d.tar.gz
gentoo-3297c990c507035e989a30c03a499851f05b385d.tar.bz2
gentoo-3297c990c507035e989a30c03a499851f05b385d.zip
sci-libs/libh2oxx: Bump to EAPI 7
Diffstat (limited to 'sci-libs/libh2oxx')
-rw-r--r--sci-libs/libh2oxx/libh2oxx-0.2-r1.ebuild30
-rw-r--r--sci-libs/libh2oxx/libh2oxx-9999.ebuild21
2 files changed, 45 insertions, 6 deletions
diff --git a/sci-libs/libh2oxx/libh2oxx-0.2-r1.ebuild b/sci-libs/libh2oxx/libh2oxx-0.2-r1.ebuild
new file mode 100644
index 000000000000..7dcb50db90ff
--- /dev/null
+++ b/sci-libs/libh2oxx/libh2oxx-0.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="C++ bindings for libh2o"
+HOMEPAGE="https://github.com/mgorny/libh2oxx/"
+SRC_URI="https://github.com/mgorny/libh2oxx/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug static-libs"
+
+RDEPEND=">=sci-libs/libh2o-0.2:0="
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local myconf=(
+ $(use_enable debug)
+ $(use_enable static-libs static)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/sci-libs/libh2oxx/libh2oxx-9999.ebuild b/sci-libs/libh2oxx/libh2oxx-9999.ebuild
index 8932ae68d340..a9e3eef7129e 100644
--- a/sci-libs/libh2oxx/libh2oxx-9999.ebuild
+++ b/sci-libs/libh2oxx/libh2oxx-9999.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_AUTORECONF=yes
-
-inherit autotools-utils git-r3
+inherit autotools git-r3
DESCRIPTION="C++ bindings for libh2o"
HOMEPAGE="https://github.com/mgorny/libh2oxx/"
@@ -20,10 +18,21 @@ IUSE="debug static-libs"
RDEPEND=">=sci-libs/libh2o-0.2:0="
DEPEND="${RDEPEND}"
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
- local myeconfargs=(
+ local myconf=(
$(use_enable debug)
+ $(use_enable static-libs static)
)
- autotools-utils_src_configure
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
}