summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2020-09-19 15:00:29 -0600
committerChristoph Junghans <junghans@gentoo.org>2020-09-19 15:00:59 -0600
commite61ac24a1e6f7f7c22518017662e26e4f6651e70 (patch)
treedec2a2fcbf755dac8678946c8113f24175b22c46 /sci-libs/libint
parentapp-shells/bash-completion: remove unused patch(es) (diff)
downloadgentoo-e61ac24a1e6f7f7c22518017662e26e4f6651e70.tar.gz
gentoo-e61ac24a1e6f7f7c22518017662e26e4f6651e70.tar.bz2
gentoo-e61ac24a1e6f7f7c22518017662e26e4f6651e70.zip
sci-libs/libint: version bump
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
Diffstat (limited to 'sci-libs/libint')
-rw-r--r--sci-libs/libint/Manifest1
-rw-r--r--sci-libs/libint/libint-2.6.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/sci-libs/libint/Manifest b/sci-libs/libint/Manifest
index 072822675c1a..c5e881bc46e7 100644
--- a/sci-libs/libint/Manifest
+++ b/sci-libs/libint/Manifest
@@ -1,2 +1,3 @@
DIST libint-1.1.6.tar.gz 256404 BLAKE2B c754e25f0c3bc6c52eb434beafd2cb794a2e715003ee9409d76e8ae06e0ce19a42a9331ad4db9be2745d6820e7248210d10b4c004146e99192fd16fd2c31966d SHA512 cb39d73e89431c324e32d4a71593fe913c7ae2132677d4600e63ce1ed99e8e431758f0aa3d130991da841e98a1064fa931eb0e82dbe80af4c0ece10ee3a4f2d7
DIST libint-2.0.5.tar.gz 3209528 BLAKE2B 348dd7e2bf17504e19522f053e4dc25936702e7feea1342954af1fc3656711b38b70676c0ac574ee37bb74b37ca30b323d29d156c90711a127b7404b0ca8d5cd SHA512 d7717a6337b73645dcb77d3c0731df17884b4c662b0d52061b7b80ac0ebd9de344e6c301294f714db09e7b6e3dff5b4b6958ef06122303df52d0ebb6a011cf24
+DIST libint-2.6.0.tar.gz 24743255 BLAKE2B 3ab7baba012828485c6c8425bce100e1ab50d2a3c8443ea2ef5cf173d58d8aa211a07e837b10a7f89d7e57f2e15b9384060bbf7b9885f32e9426525e65e15960 SHA512 56343c64b0dfb829702f4bb2fe14a04ad063acd7cb8b5a21cd1a45a830944c1ee98c888c9a28d6746b1bc17459aefcfb0aafe6ef310bfe554056212ad19e43ef
diff --git a/sci-libs/libint/libint-2.6.0.ebuild b/sci-libs/libint/libint-2.6.0.ebuild
new file mode 100644
index 000000000000..a81caff037d7
--- /dev/null
+++ b/sci-libs/libint/libint-2.6.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools eutils fortran-2 toolchain-funcs
+
+DESCRIPTION="Matrix elements (integrals) evaluation over Cartesian Gaussian functions"
+HOMEPAGE="https://github.com/evaleev/libint"
+SRC_URI="https://github.com/evaleev/libint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs doc"
+
+DEPEND="
+ dev-libs/boost
+ dev-libs/gmp[cxx]
+ doc? (
+ dev-texlive/texlive-latex
+ dev-tex/latex2html
+ )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-cxx=$(tc-getCXX) \
+ --with-cxx-optflags="${CXXFLAGS}" \
+ --with-cxxgen-optflags="${CXXFLAGS}" \
+ --with-cxxdepend=$(tc-getCXX) \
+ --with-ranlib=$(tc-getRANLIB) \
+ --with-ar=$(tc-getAR) \
+ --with-ld=$(tc-getLD) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}"
+
+ use doc && emake html pdf
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ DOCS=( doc/progman/progman.pdf )
+ HTML_DOCS=( doc/progman/progman/*.{html,png,css} )
+ einstalldocs
+ fi
+}