summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/libmuscle
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/libmuscle')
-rw-r--r--sci-libs/libmuscle/Manifest1
-rw-r--r--sci-libs/libmuscle/files/3.7-bufferoverflow.patch22
-rw-r--r--sci-libs/libmuscle/libmuscle-3.7-r1.ebuild39
-rw-r--r--sci-libs/libmuscle/libmuscle-3.7-r2.ebuild40
-rw-r--r--sci-libs/libmuscle/libmuscle-9999.ebuild36
-rw-r--r--sci-libs/libmuscle/metadata.xml5
6 files changed, 143 insertions, 0 deletions
diff --git a/sci-libs/libmuscle/Manifest b/sci-libs/libmuscle/Manifest
new file mode 100644
index 000000000000..668a23bee9ee
--- /dev/null
+++ b/sci-libs/libmuscle/Manifest
@@ -0,0 +1 @@
+DIST libmuscle-3.7-r1.tar.bz2 458852 SHA256 3c0df6aeb8ea86bcd92e61f509486244176cee22c9bd7239ff16a51e1d046a14
diff --git a/sci-libs/libmuscle/files/3.7-bufferoverflow.patch b/sci-libs/libmuscle/files/3.7-bufferoverflow.patch
new file mode 100644
index 000000000000..c34b8ccacbda
--- /dev/null
+++ b/sci-libs/libmuscle/files/3.7-bufferoverflow.patch
@@ -0,0 +1,22 @@
+--- libMUSCLE/globalslinux.cpp.old 2010-03-14 19:03:14.000000000 +1300
++++ libMUSCLE/globalslinux.cpp 2010-03-14 19:11:09.000000000 +1300
+@@ -159,7 +159,7 @@
+ }
+ return DEFAULT_RAM;
+ }
+- int Bytes = atoi(pMem+9)*1000;
++ long Bytes = atol(pMem+9)*1000;
+ return ((double) Bytes)/1e6;
+ }
+
+--- libMUSCLE/progress.cpp.old 2010-03-14 19:50:27.000000000 +1300
++++ libMUSCLE/progress.cpp 2010-03-14 19:51:07.000000000 +1300
+@@ -48,7 +48,7 @@
+ if (MB < 0)
+ return "";
+
+- static char Str[9];
++ static char Str[11];
+ static double MaxMB = 0;
+ static double RAMMB = 0;
+
diff --git a/sci-libs/libmuscle/libmuscle-3.7-r1.ebuild b/sci-libs/libmuscle/libmuscle-3.7-r1.ebuild
new file mode 100644
index 000000000000..2a338dbb0694
--- /dev/null
+++ b/sci-libs/libmuscle/libmuscle-3.7-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+MY_TAG="mauve-2-3-0-release"
+#ESVN_REPO_URI="https://mauve.svn.sourceforge.net/svnroot/mauve/muscle/tags/${MY_TAG}"
+
+#inherit subversion autotools
+inherit autotools
+
+DESCRIPTION="Library for sci-biology/mauve"
+HOMEPAGE="http://gel.ahabs.wisc.edu/mauve/"
+#SRC_URI=""
+SRC_URI="mirror://gentoo/${P}-${PR}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+IUSE="doc"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="doc? ( app-doc/doxygen )
+ !sci-biology/muscle"
+RDEPEND=""
+
+#S="${WORKDIR}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_compile() {
+ emake -j1 || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+}
diff --git a/sci-libs/libmuscle/libmuscle-3.7-r2.ebuild b/sci-libs/libmuscle/libmuscle-3.7-r2.ebuild
new file mode 100644
index 000000000000..60ccf621f884
--- /dev/null
+++ b/sci-libs/libmuscle/libmuscle-3.7-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+MY_TAG="mauve-2-3-0-release"
+#ESVN_REPO_URI="https://mauve.svn.sourceforge.net/svnroot/mauve/muscle/tags/${MY_TAG}"
+
+#inherit subversion autotools
+inherit autotools eutils
+
+DESCRIPTION="Library for sci-biology/mauve"
+HOMEPAGE="http://gel.ahabs.wisc.edu/mauve/"
+#SRC_URI=""
+SRC_URI="mirror://gentoo/${P}-r1.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+IUSE="doc"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="doc? ( app-doc/doxygen )
+ !sci-biology/muscle"
+RDEPEND=""
+
+#S="${WORKDIR}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-bufferoverflow.patch
+ eautoreconf
+}
+
+src_compile() {
+ emake -j1 || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+}
diff --git a/sci-libs/libmuscle/libmuscle-9999.ebuild b/sci-libs/libmuscle/libmuscle-9999.ebuild
new file mode 100644
index 000000000000..7d5c5f035295
--- /dev/null
+++ b/sci-libs/libmuscle/libmuscle-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+ESVN_REPO_URI="https://mauve.svn.sourceforge.net/svnroot/mauve/muscle/trunk"
+
+inherit subversion autotools
+
+DESCRIPTION="Library for sci-biology/mauve"
+HOMEPAGE="http://gel.ahabs.wisc.edu/mauve/"
+SRC_URI=""
+
+LICENSE="public-domain"
+SLOT="0"
+IUSE="doc"
+KEYWORDS=""
+
+DEPEND="doc? ( app-doc/doxygen )
+ !sci-biology/muscle"
+RDEPEND=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_compile() {
+ emake -j1 || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+}
diff --git a/sci-libs/libmuscle/metadata.xml b/sci-libs/libmuscle/metadata.xml
new file mode 100644
index 000000000000..d4648212cbad
--- /dev/null
+++ b/sci-libs/libmuscle/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>