summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/libsigrok/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/libsigrok/files')
-rw-r--r--sci-libs/libsigrok/files/libsigrok-0.3.0-configure-flags.patch169
-rw-r--r--sci-libs/libsigrok/files/libsigrok-0.3.0-no-check-linkage.patch30
2 files changed, 199 insertions, 0 deletions
diff --git a/sci-libs/libsigrok/files/libsigrok-0.3.0-configure-flags.patch b/sci-libs/libsigrok/files/libsigrok-0.3.0-configure-flags.patch
new file mode 100644
index 000000000000..16e13349360c
--- /dev/null
+++ b/sci-libs/libsigrok/files/libsigrok-0.3.0-configure-flags.patch
@@ -0,0 +1,169 @@
+https://sourceforge.net/p/sigrok/mailman/message/32459490/
+
+From de8690fe8aad81f963f14cf1bd7d6e7013d9d747 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Fri, 13 Jun 2014 19:09:35 -0400
+Subject: [PATCH] add explicit configure flags for ftdi/serial/usb libraries
+
+This makes it a lot easier for distros to control this functionality.
+---
+ configure.ac | 118 +++++++++++++++++++++++++++++++++++++++--------------------
+ 1 file changed, 79 insertions(+), 39 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 496bc7a..f23e630 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -261,6 +261,18 @@ AC_ARG_ENABLE(zeroplus-logic-cube,
+ [HW_ZEROPLUS_LOGIC_CUBE="$enableval"],
+ [HW_ZEROPLUS_LOGIC_CUBE=$HW_ENABLED_DEFAULT])
+
++AC_ARG_ENABLE(libserialport,
++ AC_HELP_STRING([--disable-libserialport],
++ [disable libserialport support [default=detect]]))
++
++AC_ARG_ENABLE(libftdi,
++ AC_HELP_STRING([--disable-libftdi],
++ [disable libftdi support [default=detect]]))
++
++AC_ARG_ENABLE(libusb,
++ AC_HELP_STRING([--disable-libusb],
++ [disable libusb support [default=detect]]))
++
+ # Checks for libraries.
+
+ case "$host" in
+@@ -302,19 +314,28 @@ PKG_CHECK_MODULES([libzip], [libzip >= 0.10],
+
+ # libserialport is only needed for some hardware drivers. Disable the
+ # respective drivers if it is not found.
+-PKG_CHECK_MODULES([libserialport], [libserialport >= 0.1.0],
+- [have_libserialport="yes"; LIB_CFLAGS="$LIB_CFLAGS $libserialport_CFLAGS";
+- LIBS="$LIBS $libserialport_LIBS";
+- SR_PKGLIBS="$SR_PKGLIBS libserialport"],
+- [have_libserialport="no"; HW_AGILENT_DMM="no"; HW_APPA_55II="no";
++if test "x$enable_libserialport" != "xno"; then
++ PKG_CHECK_MODULES([libserialport], [libserialport >= 0.1.0],
++ [have_libserialport="yes"; LIB_CFLAGS="$LIB_CFLAGS $libserialport_CFLAGS";
++ LIBS="$LIBS $libserialport_LIBS";
++ SR_PKGLIBS="$SR_PKGLIBS libserialport"],
++ [have_libserialport="no"])
++ if test "x$enable_libserialport$have_libserialport" = "xyesno"; then
++ AC_MSG_ERROR([libserialport support requested, but it was not found])
++ fi
++else
++ have_libserialport="no"
++fi
++
++# Define HAVE_LIBSERIALPORT in config.h if we found libserialport.
++if test "x$have_libserialport" = "xno"; then
++ HW_AGILENT_DMM="no"; HW_APPA_55II="no";
+ HW_ATTEN_PPS3XXX="no"; HW_BRYMEN_DMM="no"; HW_CEM_DT_885X="no";
+ HW_CENTER_3XX="no"; HW_COLEAD_SLM="no"; HW_CONRAD_DIGI_35_CPU="no";
+ HW_FLUKE_DMM="no"; HW_GMC_MH_1X_2X="no"; HW_HAMEG_HMO="no";
+ HW_MIC_985XX="no"; HW_NORMA_DMM="no"; HW_OLS="no";
+- HW_SERIAL_DMM="no"; HW_TELEINFO="no"; HW_TONDAJ_SL_814="no"])
+-
+-# Define HAVE_LIBSERIALPORT in config.h if we found libserialport.
+-if test "x$have_libserialport" != "xno"; then
++ HW_SERIAL_DMM="no"; HW_TELEINFO="no"; HW_TONDAJ_SL_814="no";
++else
+ AC_DEFINE_UNQUOTED(HAVE_LIBSERIALPORT, [1],
+ [Specifies whether we have libserialport.])
+ fi
+@@ -340,43 +361,62 @@ fi
+
+ # libusb-1.0 is only needed for some hardware drivers. Disable the respective
+ # drivers if it is not found.
+-case "$host" in
+-*freebsd*)
+- # FreeBSD comes with an "integrated" libusb-1.0-style USB API.
+- # This means libusb-1.0 is always available, no need to check for it,
+- # and no need to (potentially) disable any drivers if it's not found.
++if test "x$enable_libusb" != "xno"; then
++ case "$host" in
++ *freebsd*)
++ # FreeBSD comes with an "integrated" libusb-1.0-style USB API.
++ # This means libusb-1.0 is always available, no need to check for it,
++ # and no need to (potentially) disable any drivers if it's not found.
++ have_libusb1_0="yes"
++ ;;
++ *)
++ PKG_CHECK_MODULES([libusb], [libusb-1.0 >= 1.0.16],
++ [have_libusb1_0="yes"; LIB_CFLAGS="$LIB_CFLAGS $libusb_CFLAGS";
++ LIBS="$LIBS $libusb_LIBS";
++ SR_PKGLIBS="$SR_PKGLIBS libusb-1.0"],
++ [have_libusb1_0="no"])
++ if test "x$enable_libusb$have_libusb1_0" = "xyesno"; then
++ AC_MSG_ERROR([libusb support requested, but it was not found])
++ fi
++ ;;
++ esac
++else
++ have_libusb1_0="no"
++fi
++
++# Define HAVE_LIBUSB_1_0 in config.h if we found libusb-1.0.
++if test "x$have_libusb1_0" = "xno"; then
++ HW_BRYMEN_BM86X="no"; HW_FX2LAFW="no";
++ HW_HANTEK_DSO="no"; HW_IKALOGIC_SCANALOGIC2="no";
++ HW_KECHENG_KC_330B="no"; HW_LASCAR_EL_USB="no";
++ HW_SYSCLK_LWLA="no"; HW_UNI_T_DMM="no";
++ HW_UNI_T_UT32X="no"; HW_VICTOR_DMM="no";
++ HW_ZEROPLUS_LOGIC_CUBE="no"; HW_SALEAE_LOGIC16="no";
++else
+ AC_DEFINE_UNQUOTED(HAVE_LIBUSB_1_0, [1],
+ [Specifies whether we have a libusb.h header.])
+- ;;
+-*)
+- PKG_CHECK_MODULES([libusb], [libusb-1.0 >= 1.0.16],
+- [have_libusb1_0="yes"; LIB_CFLAGS="$LIB_CFLAGS $libusb_CFLAGS";
+- LIBS="$LIBS $libusb_LIBS";
+- SR_PKGLIBS="$SR_PKGLIBS libusb-1.0"],
+- [have_libusb1_0="no"; HW_BRYMEN_BM86X="no"; HW_FX2LAFW="no";
+- HW_HANTEK_DSO="no"; HW_IKALOGIC_SCANALOGIC2="no";
+- HW_KECHENG_KC_330B="no"; HW_LASCAR_EL_USB="no";
+- HW_SYSCLK_LWLA="no"; HW_UNI_T_DMM="no";
+- HW_UNI_T_UT32X="no"; HW_VICTOR_DMM="no";
+- HW_ZEROPLUS_LOGIC_CUBE="no"; HW_SALEAE_LOGIC16="no"])
+-
+- # Define HAVE_LIBUSB_1_0 in config.h if we found libusb-1.0.
+- if test "x$have_libusb1_0" != "xno"; then
+- AC_DEFINE_UNQUOTED(HAVE_LIBUSB_1_0, [1],
+- [Specifies whether we have a libusb.h header.])
+- fi
+- ;;
+-esac
++fi
+
+ # USB + FX2 firmware helper code is only compiled in if libusb-1.0 was found.
+ AM_CONDITIONAL(NEED_USB, test "x$have_libusb1_0" != xno)
+
+ # libftdi is only needed for some hardware drivers. Disable them if not found.
+-PKG_CHECK_MODULES([libftdi], [libftdi >= 0.16],
+- [LIB_CFLAGS="$LIB_CFLAGS $libftdi_CFLAGS";
+- LIBS="$LIBS $libftdi_LIBS";
+- SR_PKGLIBS="$SR_PKGLIBS libftdi"],
+- [HW_ASIX_SIGMA="no"; HW_CHRONOVU_LA="no"; HW_IKALOGIC_SCANAPLUS="no"])
++if test "x$enable_libftdi" != "xno"; then
++ PKG_CHECK_MODULES([libftdi], [libftdi >= 0.16],
++ [have_libftdi="yes"; LIB_CFLAGS="$LIB_CFLAGS $libftdi_CFLAGS";
++ LIBS="$LIBS $libftdi_LIBS";
++ SR_PKGLIBS="$SR_PKGLIBS libftdi"],
++ [have_libftdi="no"])
++ if test "x$enable_libftdi$have_libftdi" = "xyesno"; then
++ AC_MSG_ERROR([libftdi support requested, but it was not found])
++ fi
++else
++ have_libftdi="no"
++fi
++
++if test "x$have_libftdi" = "xno"; then
++ HW_ASIX_SIGMA="no"; HW_CHRONOVU_LA="no"; HW_IKALOGIC_SCANAPLUS="no";
++fi
+
+ # The Check unit testing framework is optional. Disable if not found.
+ PKG_CHECK_MODULES([check], [check >= 0.9.4],
+--
+2.0.0
+
diff --git a/sci-libs/libsigrok/files/libsigrok-0.3.0-no-check-linkage.patch b/sci-libs/libsigrok/files/libsigrok-0.3.0-no-check-linkage.patch
new file mode 100644
index 000000000000..f638c47b196e
--- /dev/null
+++ b/sci-libs/libsigrok/files/libsigrok-0.3.0-no-check-linkage.patch
@@ -0,0 +1,30 @@
+https://sourceforge.net/p/sigrok/mailman/message/32459488/
+
+From 5326833697a73826babb6a43c74112da7368d2d6 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Fri, 13 Jun 2014 21:17:23 -0400
+Subject: [PATCH] do not add check to common cflags/libs
+
+Only the unittests use these flags, so don't go linking them in for
+the main library too.
+---
+ configure.ac | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index f23e630..d0654f1 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -420,8 +420,7 @@ fi
+
+ # The Check unit testing framework is optional. Disable if not found.
+ PKG_CHECK_MODULES([check], [check >= 0.9.4],
+- [have_check="yes"; LIB_CFLAGS="$LIB_CFLAGS $check_CFLAGS";
+- LIBS="$LIBS $check_LIBS"], [have_check="no"])
++ [have_check="yes"], [have_check="no"])
+ AM_CONDITIONAL(HAVE_CHECK, test x"$have_check" = "xyes")
+
+ # The OLS driver uses serial port file descriptors directly, and therefore
+--
+2.0.0
+