summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2016-08-03 11:31:02 +0000
committerSven Wegener <swegener@gentoo.org>2016-08-03 11:35:21 +0000
commit0b3387c386eb267aa7d9344dc0dc0389fbca503c (patch)
tree06ee497bd3c7f3a5a3d35bbf56dd20471729bfc7 /sci-libs/libsigrokdecode/libsigrokdecode-0.4.0.ebuild
parentsci-libs/libsigrokdecode: Bump to EAPI 6 (diff)
downloadgentoo-0b3387c386eb267aa7d9344dc0dc0389fbca503c.tar.gz
gentoo-0b3387c386eb267aa7d9344dc0dc0389fbca503c.tar.bz2
gentoo-0b3387c386eb267aa7d9344dc0dc0389fbca503c.zip
sci-libs/libsigrokdecode: Version bump, bug #579898
Package-Manager: portage-2.2.28 Signed-off-by: Sven Wegener <swegener@gentoo.org>
Diffstat (limited to 'sci-libs/libsigrokdecode/libsigrokdecode-0.4.0.ebuild')
-rw-r--r--sci-libs/libsigrokdecode/libsigrokdecode-0.4.0.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sci-libs/libsigrokdecode/libsigrokdecode-0.4.0.ebuild b/sci-libs/libsigrokdecode/libsigrokdecode-0.4.0.ebuild
new file mode 100644
index 000000000000..10946b61463b
--- /dev/null
+++ b/sci-libs/libsigrokdecode/libsigrokdecode-0.4.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{3,4} )
+
+inherit eutils python-single-r1
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://sigrok.org/${PN}"
+ inherit git-r3 autotools
+else
+ SRC_URI="http://sigrok.org/download/source/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="provide (streaming) protocol decoding functionality"
+HOMEPAGE="http://sigrok.org/wiki/Libsigrokdecode"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="static-libs"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND=">=dev-libs/glib-2.24.0
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ [[ ${PV} == "9999" ]] && eautoreconf
+
+ # Only a test program (not installed, and not used by src_test)
+ # is used by libsigrok, so disable it to avoid the compile.
+ sed -i \
+ -e '/build_runtc=/s:yes:no:' \
+ configure || die
+
+ eapply_user
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}