summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-07-03 01:35:35 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-06 20:15:25 +0200
commit1eca0ab57d32d3956301844e88a5d9c55485373a (patch)
tree355a0898284751dc0d8d56c339029b62ccf237a6 /sci-libs/libsigrokdecode
parentsci-libs/libsigrok: Fix build with IUSE=ruby (diff)
downloadgentoo-1eca0ab57d32d3956301844e88a5d9c55485373a.tar.gz
gentoo-1eca0ab57d32d3956301844e88a5d9c55485373a.tar.bz2
gentoo-1eca0ab57d32d3956301844e88a5d9c55485373a.zip
sci-libs/libsigrokdecode: EAPI-7 bump, drop eutils, ltprune
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-libs/libsigrokdecode')
-rw-r--r--sci-libs/libsigrokdecode/libsigrokdecode-0.5.3.ebuild26
-rw-r--r--sci-libs/libsigrokdecode/libsigrokdecode-9999.ebuild26
2 files changed, 28 insertions, 24 deletions
diff --git a/sci-libs/libsigrokdecode/libsigrokdecode-0.5.3.ebuild b/sci-libs/libsigrokdecode/libsigrokdecode-0.5.3.ebuild
index 1b1d6710e99f..987d7b1a7489 100644
--- a/sci-libs/libsigrokdecode/libsigrokdecode-0.5.3.ebuild
+++ b/sci-libs/libsigrokdecode/libsigrokdecode-0.5.3.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
+inherit python-single-r1
-inherit eutils ltprune python-single-r1
-
-if [[ ${PV} == "9999" ]]; then
+if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="git://sigrok.org/${PN}"
inherit git-r3 autotools
else
@@ -15,7 +14,7 @@ else
KEYWORDS="~amd64 ~x86"
fi
-DESCRIPTION="provide (streaming) protocol decoding functionality"
+DESCRIPTION="Provide (streaming) protocol decoding functionality"
HOMEPAGE="https://sigrok.org/wiki/Libsigrokdecode"
LICENSE="GPL-3"
@@ -23,13 +22,16 @@ SLOT="0/4"
IUSE="static-libs"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND=">=dev-libs/glib-2.34.0
- ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.34.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
src_prepare() {
- [[ ${PV} == "9999" ]] && eautoreconf
+ default
# Only a test program (not installed, and not used by src_test)
# is used by libsigrok, so disable it to avoid the compile.
@@ -37,7 +39,7 @@ src_prepare() {
-e '/build_runtc=/s:yes:no:' \
configure || die
- eapply_user
+ [[ ${PV} == *9999* ]] && eautoreconf
}
src_configure() {
@@ -50,5 +52,5 @@ src_test() {
src_install() {
default
- prune_libtool_files
+ find "${D}" -name '*.la' -type f -delete || die
}
diff --git a/sci-libs/libsigrokdecode/libsigrokdecode-9999.ebuild b/sci-libs/libsigrokdecode/libsigrokdecode-9999.ebuild
index d4b8425482e3..aa68dd79a092 100644
--- a/sci-libs/libsigrokdecode/libsigrokdecode-9999.ebuild
+++ b/sci-libs/libsigrokdecode/libsigrokdecode-9999.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
+inherit python-single-r1
-inherit eutils ltprune python-single-r1
-
-if [[ ${PV} == "9999" ]]; then
+if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="git://sigrok.org/${PN}"
inherit git-r3 autotools
else
@@ -15,7 +14,7 @@ else
KEYWORDS="~amd64 ~x86"
fi
-DESCRIPTION="provide (streaming) protocol decoding functionality"
+DESCRIPTION="Provide (streaming) protocol decoding functionality"
HOMEPAGE="https://sigrok.org/wiki/Libsigrokdecode"
LICENSE="GPL-3"
@@ -23,13 +22,16 @@ SLOT="0/9999"
IUSE="static-libs"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND=">=dev-libs/glib-2.34.0
- ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.34.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
src_prepare() {
- [[ ${PV} == "9999" ]] && eautoreconf
+ default
# Only a test program (not installed, and not used by src_test)
# is used by libsigrok, so disable it to avoid the compile.
@@ -37,7 +39,7 @@ src_prepare() {
-e '/build_runtc=/s:yes:no:' \
configure || die
- eapply_user
+ [[ ${PV} == *9999* ]] && eautoreconf
}
src_configure() {
@@ -50,5 +52,5 @@ src_test() {
src_install() {
default
- prune_libtool_files
+ find "${D}" -name '*.la' -type f -delete || die
}