summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-10-06 09:58:23 +0200
committerJakov Smolić <jsmolic@gentoo.org>2021-10-06 10:31:37 +0200
commitbc2a5196f4222c275e065db300d9674983fee402 (patch)
tree20218210e3664425eade3711866804dc9f74df0b /sci-libs/libsvm
parentsci-libs/openblas: drop 0.3.12-r1, 0.3.13, 0.3.14 (diff)
downloadgentoo-bc2a5196f4222c275e065db300d9674983fee402.tar.gz
gentoo-bc2a5196f4222c275e065db300d9674983fee402.tar.bz2
gentoo-bc2a5196f4222c275e065db300d9674983fee402.zip
sci-libs/libsvm: drop 3.24
Closes: https://bugs.gentoo.org/794625 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'sci-libs/libsvm')
-rw-r--r--sci-libs/libsvm/Manifest1
-rw-r--r--sci-libs/libsvm/libsvm-3.24.ebuild118
2 files changed, 0 insertions, 119 deletions
diff --git a/sci-libs/libsvm/Manifest b/sci-libs/libsvm/Manifest
index e1e9144dd425..0dbb0b08cf6f 100644
--- a/sci-libs/libsvm/Manifest
+++ b/sci-libs/libsvm/Manifest
@@ -1,2 +1 @@
-DIST libsvm-3.24.tar.gz 876441 BLAKE2B 6781804ba9706de5ad363bcbda20f2ec181cc4ee9613c9e7429f03872f7a03b04859df2ec00692d9de3ea237d1e478435a4d4db3ce7e5292689a2eab26a1fe46 SHA512 ff3c39bc84291bfb707151d7b8b6fb2eece937afa769cb8ee579d00ee4c30e943d476cd7bb18851d482c9bed89cf94fb3fd8abca4d47253360e12e9406f2f24b
DIST libsvm-3.25.tar.gz 892471 BLAKE2B a80b7192981811f57446a966c911a07a2de17042e67faa26451c23129dafeac642596a619731b57a27d9845f904e2e4c5c11ae8aa3006fa49e2f62d7cec4cca2 SHA512 91afbcfd204f5fc9c367df446550cecaf01d5e34770fa10fc6bb02277d79b756393f7d057290df0f72fc941faaf0f4c84a863a3bf9d8628eeff1f99b6bc57a98
diff --git a/sci-libs/libsvm/libsvm-3.24.ebuild b/sci-libs/libsvm/libsvm-3.24.ebuild
deleted file mode 100644
index 64467f9355ad..000000000000
--- a/sci-libs/libsvm/libsvm-3.24.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit flag-o-matic java-pkg-opt-2 python-r1 toolchain-funcs
-
-DESCRIPTION="Library for Support Vector Machines"
-HOMEPAGE="https://www.csie.ntu.edu.tw/~cjlin/libsvm/"
-SRC_URI="https://www.csie.ntu.edu.tw/~cjlin/libsvm/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/2"
-KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="java openmp python tools"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-DEPEND="
- java? ( >=virtual/jdk-1.4 )
- python? ( ${PYTHON_DEPS} )
-"
-RDEPEND="
- java? ( >=virtual/jre-1.4 )
- python? ( ${PYTHON_DEPS} )
- tools? ( sci-visualization/gnuplot )
-"
-
-PATCHES=(
- "${FILESDIR}/3.11-openmp.patch"
- "${FILESDIR}/3.14-makefile.patch"
-)
-
-pkg_setup() {
- if use openmp; then
- if ! tc-has-openmp; then
- ewarn "OpenMP is not supported by your currently selected compiler"
-
- if tc-is-clang; then
- ewarn "OpenMP support in sys-devel/clang is provided by sys-libs/libomp,"
- ewarn "which you will need to build ${CATEGORY}/${PN} for USE=\"openmp\""
- fi
-
- die "need openmp capable compiler"
- fi
-
- append-cflags -fopenmp
- append-cxxflags -fopenmp
- append-cppflags -DOPENMP
- fi
-}
-
-src_prepare() {
- default
-
- sed -i -e "s@\.\./@${EPREFIX}/usr/bin/@g" tools/*.py \
- || die "Failed to fix paths in python files"
- sed -i -e "s|./grid.py|${EPREFIX}/usr/bin/svm-grid|g" tools/*.py \
- || die "Failed to fix paths for svm-grid"
- sed -i -e 's/grid.py/svm-grid/g' tools/grid.py \
- || die "Failed to rename grid.py to svm-grid"
-
- if use java; then
- local JAVAC_FLAGS="$(java-pkg_javac-args)"
- sed -i \
- -e "s/JAVAC_FLAGS =/JAVAC_FLAGS=${JAVAC_FLAGS}/g" \
- java/Makefile || die "Failed to fix java makefile"
- fi
- tc-export CXX CC
-}
-
-src_compile() {
- default
- use java && emake -C java
-}
-
-src_install() {
- dobin svm-train svm-predict svm-scale
- dolib.so *.so*
- doheader svm.h
-
- DOCS=( README )
-
- if use tools; then
- local t
- for t in tools/*.py; do
- python_foreach_impl python_newscript ${t} svm-$(basename ${t} .py)
- done
-
- mv tools/README{,.tools} || die
- DOCS+=( tools/README.tools )
-
- insinto /usr/share/doc/${PF}/examples
- docompress -x /usr/share/doc/${PF}/examples
- doins heart_scale
- doins -r svm-toy
- fi
-
- if use python ; then
- installation() {
- touch python/__init__.py || die
- python_moduleinto libsvm
- python_domodule python/*.py
- }
- python_foreach_impl installation
-
- mv python/README{,.python} || die
- DOCS+=( python/README.python )
- fi
-
- HTML_DOCS=( FAQ.html )
- if use java; then
- java-pkg_dojar java/libsvm.jar
- HTML_DOCS+=( java/test_applet.html )
- fi
-
- einstalldocs
-}