summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2016-12-12 23:58:31 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-12-12 23:58:31 +0100
commitca095aac3343b459c291010a31101dd06d22d14c (patch)
treee42c2bb4d76ac0c5491bc94011d87f1557f18f89 /sci-libs/linux-gpib
parentsci-visualization/spyview: Version bump without keywords (doesnt build yet) (diff)
downloadgentoo-ca095aac3343b459c291010a31101dd06d22d14c.tar.gz
gentoo-ca095aac3343b459c291010a31101dd06d22d14c.tar.bz2
gentoo-ca095aac3343b459c291010a31101dd06d22d14c.zip
sci-libs/linux-gpib: correctly use REPLACING_VERSIONS, bug 589512
Package-Manager: portage-2.3.3
Diffstat (limited to 'sci-libs/linux-gpib')
-rw-r--r--sci-libs/linux-gpib/linux-gpib-3.2.21-r1.ebuild20
-rw-r--r--sci-libs/linux-gpib/linux-gpib-4.0.2.ebuild20
2 files changed, 24 insertions, 16 deletions
diff --git a/sci-libs/linux-gpib/linux-gpib-3.2.21-r1.ebuild b/sci-libs/linux-gpib/linux-gpib-3.2.21-r1.ebuild
index f5904e397b97..8a70950b9d19 100644
--- a/sci-libs/linux-gpib/linux-gpib-3.2.21-r1.ebuild
+++ b/sci-libs/linux-gpib/linux-gpib-3.2.21-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -8,7 +8,7 @@ PERL_EXPORT_PHASE_FUNCTIONS=no
GENTOO_DEPEND_ON_PERL=no
PYTHON_COMPAT=( python2_7 )
-inherit eutils linux-mod autotools perl-module python-single-r1 toolchain-funcs udev user
+inherit versionator eutils linux-mod autotools perl-module python-single-r1 toolchain-funcs udev user
DESCRIPTION="Kernel module and driver library for GPIB (IEEE 488.2) hardware"
HOMEPAGE="http://linux-gpib.sourceforge.net/"
@@ -184,10 +184,14 @@ pkg_postinst () {
einfo ""
fi
- if [[ $REPLACING_VERSIONS < "3.2.21-r1" ]]; then
- ewarn "sci-libs/linux-gpib-3.2.21-r1 introduces incompatible changes to the kernel"
- ewarn "interface. You may need to reboot to make sure the newly built driver modules"
- ewarn "are used (some of the driver modules cannot be unloaded)."
- ewarn "If you do not do this, every gpib call will just result in an error message."
- fi
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 3.2.21-r1 ${v}; then
+ ewarn "sci-libs/linux-gpib-3.2.21-r1 introduces incompatible changes to the kernel"
+ ewarn "interface. You may need to reboot to make sure the newly built driver modules"
+ ewarn "are used (some of the driver modules cannot be unloaded)."
+ ewarn "If you do not do this, every gpib call will just result in an error message."
+ break
+ fi
+ done
}
diff --git a/sci-libs/linux-gpib/linux-gpib-4.0.2.ebuild b/sci-libs/linux-gpib/linux-gpib-4.0.2.ebuild
index 72a254f65583..e23cd3761b84 100644
--- a/sci-libs/linux-gpib/linux-gpib-4.0.2.ebuild
+++ b/sci-libs/linux-gpib/linux-gpib-4.0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -8,7 +8,7 @@ PERL_EXPORT_PHASE_FUNCTIONS=no
GENTOO_DEPEND_ON_PERL=no
PYTHON_COMPAT=( python2_7 )
-inherit eutils linux-mod autotools perl-module python-single-r1 toolchain-funcs udev user
+inherit versionator eutils linux-mod autotools perl-module python-single-r1 toolchain-funcs udev user
DESCRIPTION="Kernel module and driver library for GPIB (IEEE 488.2) hardware"
HOMEPAGE="http://linux-gpib.sourceforge.net/"
@@ -183,10 +183,14 @@ pkg_postinst () {
einfo ""
fi
- if [[ $REPLACING_VERSIONS < "3.2.21-r1" ]]; then
- ewarn "sci-libs/linux-gpib-3.2.21-r1 introduces incompatible changes to the kernel"
- ewarn "interface. You may need to reboot to make sure the newly built driver modules"
- ewarn "are used (some of the driver modules cannot be unloaded)."
- ewarn "If you do not do this, every gpib call will just result in an error message."
- fi
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 3.2.21-r1 ${v}; then
+ ewarn "sci-libs/linux-gpib-3.2.21-r1 introduces incompatible changes to the kernel"
+ ewarn "interface. You may need to reboot to make sure the newly built driver modules"
+ ewarn "are used (some of the driver modules cannot be unloaded)."
+ ewarn "If you do not do this, every gpib call will just result in an error message."
+ break
+ fi
+ done
}