summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-06 11:00:06 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-06 12:09:46 +0100
commitf23a22634619c746bbf13c001cca329b6132dd56 (patch)
treec2f411fbb9bf191438559532af872deca1d58e11 /sci-libs/lmfit
parentapp-mobilephone/gammu: Drop 1.38.5, 1.39.0-r1 and 1.40.0 (diff)
downloadgentoo-f23a22634619c746bbf13c001cca329b6132dd56.tar.gz
gentoo-f23a22634619c746bbf13c001cca329b6132dd56.tar.bz2
gentoo-f23a22634619c746bbf13c001cca329b6132dd56.zip
sci-libs/lmfit: Use cmake.eclass/EAPI-7, fix patch, fix HOMEPAGE
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-libs/lmfit')
-rw-r--r--sci-libs/lmfit/files/lmfit-8.2.2-cmake.patch4
-rw-r--r--sci-libs/lmfit/lmfit-8.2.2.ebuild11
2 files changed, 7 insertions, 8 deletions
diff --git a/sci-libs/lmfit/files/lmfit-8.2.2-cmake.patch b/sci-libs/lmfit/files/lmfit-8.2.2-cmake.patch
index 258f70a533d4..482ecebe8294 100644
--- a/sci-libs/lmfit/files/lmfit-8.2.2-cmake.patch
+++ b/sci-libs/lmfit/files/lmfit-8.2.2-cmake.patch
@@ -42,7 +42,7 @@ index dbb571e..279f06a 100644
configure_file("lmfit.pc.in" "lmfit.pc" @ONLY)
install(FILES "${CMAKE_CURRENT_BINARY_DIR}/lmfit.pc"
- DESTINATION "${destination}/lib/pkgconfig/")
-+ DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig/")
++ DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig/")
add_subdirectory(lib)
add_subdirectory(demo)
@@ -76,7 +76,7 @@ index d4595fd..5505713 100644
install(
FILES ${CMAKE_CURRENT_BINARY_DIR}/${pname}.html
- DESTINATION "${CMAKE_INSTALL_PREFIX}/share/doc/lmfit/html"
-+ DESTINATION "${CMAKE_INSTALL_DOCDIR}-${CMAKE_PROJECT_VERSION}/html"
++ DESTINATION "${CMAKE_INSTALL_DOCDIR}/html"
)
endfunction()
diff --git a/sci-libs/lmfit/lmfit-8.2.2.ebuild b/sci-libs/lmfit/lmfit-8.2.2.ebuild
index 5a79ce239e5d..954e91ac7e70 100644
--- a/sci-libs/lmfit/lmfit-8.2.2.ebuild
+++ b/sci-libs/lmfit/lmfit-8.2.2.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="library for Levenberg-Marquardt least-squares minimization and curve fitting"
-HOMEPAGE="http://apps.jcns.fz-juelich.de/doku/sc/lmfit"
+HOMEPAGE="https://jugit.fz-juelich.de/mlz/lmfit"
SRC_URI="http://apps.jcns.fz-juelich.de/src/lmfit/${P}.tgz"
LICENSE="BSD-2"
@@ -20,6 +20,5 @@ src_configure() {
local mycmakeargs=(
-DINJECT_C_FLAGS=OFF
)
-
- cmake-utils_src_configure
+ cmake_src_configure
}