summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2021-11-05 20:56:27 -0400
committerMichael Orlitzky <mjo@gentoo.org>2021-11-05 21:00:10 -0400
commitebbc960f2696ed482e68f1839192af91bba65d22 (patch)
treeaa602fa321d07b427b9abf3c710a36ef77fe048d /sci-libs/lrslib
parentvirtual/libcrypt: Stabilize 2 hppa, #809410 (diff)
downloadgentoo-ebbc960f2696ed482e68f1839192af91bba65d22.tar.gz
gentoo-ebbc960f2696ed482e68f1839192af91bba65d22.tar.bz2
gentoo-ebbc960f2696ed482e68f1839192af91bba65d22.zip
sci-libs/lrslib: drop to ~x86 and remove old lrslib-062.ebuild.
The current "stable" version of lrslib on x86, v062, doesn't actually build because it's incompatible with newer GCCs. But its replacement has some issues (bug 771675) on some 32-bit systems. This commit removes the existing x86 stable version 062 (usually a no-no), and closes the x86 stabilization request for v071. The end result is that this package is now ~x86 only, but we've replaced a version that will never build on x86 with one that might build sometimes. Running a `git grep lrslib` shows that this should not affect any consumers. Bug: https://bugs.gentoo.org/771675 Closes: https://bugs.gentoo.org/819555 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/lrslib')
-rw-r--r--sci-libs/lrslib/Manifest1
-rw-r--r--sci-libs/lrslib/lrslib-062.ebuild50
2 files changed, 0 insertions, 51 deletions
diff --git a/sci-libs/lrslib/Manifest b/sci-libs/lrslib/Manifest
index 187a96f0c720..65ee490c9030 100644
--- a/sci-libs/lrslib/Manifest
+++ b/sci-libs/lrslib/Manifest
@@ -1,2 +1 @@
-DIST lrslib-062.tar.gz 292745 BLAKE2B 1a2c0e264d590c38d83ee35616b1ec36d8a093b5c7f08179019261d8b321d5b95d8889ca6555ae69853f919d6d66358a865a8a2002516dfd560bec6658f3913d SHA512 1d644a7798580457ff266730f42f6fac317ec8cdf2509ad6028e7a838e5c4c948bd0f9499b840c227bad4269f7144ff72b87fe3a19bdb9ad0925ebe4a7bc4f9f
DIST lrslib-071b.tar.gz 466789 BLAKE2B 57a8abd9d203b1cdc62d6848afa77aa6912d9d720a0dedfbe72ca602ad8ba36d13160f7da7d719e3fa140ba2cb6432d20590ae9ea9b1f66bc2e24c393d9fe1bd SHA512 feafc5726e66c977e917f0b59ae950cdb98dbd84639885b487930aab2a89a7f067a3f39c381acc3eae7206b91255e1befa5551488d8816afc0f8054d801eb539
diff --git a/sci-libs/lrslib/lrslib-062.ebuild b/sci-libs/lrslib/lrslib-062.ebuild
deleted file mode 100644
index d3ae098fd119..000000000000
--- a/sci-libs/lrslib/lrslib-062.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-DESCRIPTION="Self-contained C implementation of the reverse search algorithm"
-HOMEPAGE="http://cgm.cs.mcgill.ca/~avis/C/lrs.html"
-SRC_URI="http://cgm.cs.mcgill.ca/~avis/C/lrslib/archive/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
-IUSE="gmp mpi"
-
-RDEPEND="gmp? ( dev-libs/gmp:0=
- mpi? ( virtual/mpi ) )"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- default
- tc-export CC
- sed -e "s/gcc/$(tc-getCC)/g" \
- -e "s/g++/$(tc-getCXX)/g" \
- -e "s/-O3/${CFLAGS}/g" \
- -e 's/$(CC) -shared/$(CC) $(LDFLAGS) -shared/' \
- -e "s,/usr/local,${EPREFIX}/usr,g" \
- -e "s,/lib,/$(get_libdir),g" \
- -i makefile || die
-}
-
-src_compile() {
- if use gmp ; then
- emake
- emake all-shared
- use mpi && emake mplrs
- else
- emake allmp
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" prefix="${EPREFIX}/usr" install-common
- if use gmp; then
- emake DESTDIR="${D}" install-shared prefix="${EPREFIX}/usr"
- use mpi && dobin mplrs
- fi
- dodoc README
-}