summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-03-13 20:18:38 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-13 20:18:38 +0100
commit6dc9d5d0c6f56ee701a1836d6aa872f9e9372dcd (patch)
tree3359f6b60575371fe97822e8d83d4ac7b995447e /sci-libs/mc
parentReverts: efc78ff95f89db0e7c2400c72a4d819976c3df0d (diff)
downloadgentoo-6dc9d5d0c6f56ee701a1836d6aa872f9e9372dcd.tar.gz
gentoo-6dc9d5d0c6f56ee701a1836d6aa872f9e9372dcd.tar.bz2
gentoo-6dc9d5d0c6f56ee701a1836d6aa872f9e9372dcd.zip
sci-libs/mc: Port to EAPI 7
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/mc')
-rw-r--r--sci-libs/mc/mc-1.5.ebuild76
1 files changed, 37 insertions, 39 deletions
diff --git a/sci-libs/mc/mc-1.5.ebuild b/sci-libs/mc/mc-1.5.ebuild
index 788d5bfc75d4..faecf71d6cfb 100644
--- a/sci-libs/mc/mc-1.5.ebuild
+++ b/sci-libs/mc/mc-1.5.ebuild
@@ -1,20 +1,19 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_AUTORECONF=true
-
-inherit autotools-utils fortran-2 multilib
+inherit autotools fortran-2
DESCRIPTION="2D/3D AFEM code for nonlinear geometric PDE"
HOMEPAGE="http://fetk.org/codes/mc/index.html"
SRC_URI="http://www.fetk.org/codes/download/${P}.tar.gz"
+S="${WORKDIR}"/${PN}
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-LICENSE="GPL-2"
-IUSE="debug doc static-libs"
+IUSE="debug doc"
RDEPEND="
dev-libs/maloc
@@ -26,14 +25,12 @@ RDEPEND="
sci-libs/umfpack
virtual/blas
virtual/lapack"
-DEPEND="
- ${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
doc? (
media-gfx/graphviz
app-doc/doxygen
- )"
-
-S="${WORKDIR}"/${PN}
+ )"
PATCHES=(
"${FILESDIR}"/1.4-superlu.patch
@@ -41,7 +38,7 @@ PATCHES=(
"${FILESDIR}"/1.4-multilib.patch
"${FILESDIR}"/1.4-doc.patch
"${FILESDIR}"/${P}-unbundle.patch
- )
+)
src_prepare() {
sed \
@@ -49,36 +46,37 @@ src_prepare() {
-e 's:UMFPACK_numeric:umfpack_di_numeric:g' \
-e 's:buildg_:matvec_:g' \
-i configure.ac || die
- autotools-utils_src_prepare
+
+ default
+ eautoreconf
}
src_configure() {
- local fetk_include
- local fetk_lib
- local myeconfargs
-
- use doc || myeconfargs+=( --with-doxygen= --with-dot= )
+ export FETK_INCLUDE="${ESYSROOT}"/usr/include
+ export FETK_LIBRARY="${ESYSROOT}"/usr/$(get_libdir)
- fetk_include="${EPREFIX}"/usr/include
- fetk_lib="${EPREFIX}"/usr/$(get_libdir)
- export FETK_INCLUDE="${fetk_include}"
- export FETK_LIBRARY="${fetk_lib}"
- export FETK_MPI_LIBRARY="${fetk_lib}"
- export FETK_VF2C_LIBRARY="${fetk_lib}"
- export FETK_BLAS_LIBRARY="${fetk_lib}"
- export FETK_LAPACK_LIBRARY="${fetk_lib}"
- export FETK_AMD_LIBRARY="${fetk_lib}"
- export FETK_UMFPACK_LIBRARY="${fetk_lib}"
- export FETK_SUPERLU_LIBRARY="${fetk_lib}"
- export FETK_ARPACK_LIBRARY="${fetk_lib}"
- export FETK_CGCODE_LIBRARY="${fetk_lib}"
- export FETK_PMG_LIBRARY="${fetk_lib}"
+ export FETK_MPI_LIBRARY="${FETK_LIBRARY}"
+ export FETK_VF2C_LIBRARY="${FETK_LIBRARY}"
+ export FETK_BLAS_LIBRARY="${FETK_LIBRARY}"
+ export FETK_LAPACK_LIBRARY="${FETK_LIBRARY}"
+ export FETK_AMD_LIBRARY="${FETK_LIBRARY}"
+ export FETK_UMFPACK_LIBRARY="${FETK_LIBRARY}"
+ export FETK_SUPERLU_LIBRARY="${FETK_LIBRARY}"
+ export FETK_ARPACK_LIBRARY="${FETK_LIBRARY}"
+ export FETK_CGCODE_LIBRARY="${FETK_LIBRARY}"
+ export FETK_PMG_LIBRARY="${FETK_LIBRARY}"
- myeconfargs+=(
- --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ econf \
+ --disable-static \
+ --disable-triplet \
+ --with-doxygen=$(usex doc "${BROOT}"/usr/bin/doxygen '') \
+ --with-dot=$(usex doc "${BROOT}"/usr/bin/dot '') \
$(use_enable debug vdebug)
- --disable-triplet
- --enable-shared
- )
- autotools-utils_src_configure
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
}