summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/minuit/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/minuit/files')
-rw-r--r--sci-libs/minuit/files/minuit-5.27.02-asneeded.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-libs/minuit/files/minuit-5.27.02-asneeded.patch b/sci-libs/minuit/files/minuit-5.27.02-asneeded.patch
new file mode 100644
index 000000000000..b9b8b4b5bb5d
--- /dev/null
+++ b/sci-libs/minuit/files/minuit-5.27.02-asneeded.patch
@@ -0,0 +1,38 @@
+This OpenMP library finding code is from ImageMagick's configure.ac
+
+http://bugs.gentoo.org/314095
+
+--- configure.in
++++ configure.in
+@@ -44,6 +44,20 @@
+ CFLAGS="$CFLAGS $OPENMP_CFLAGS"
+ CXXFLAGS="$CXXFLAGS $OPENMP_CXXFLAGS"
+
++dnl Find OpenMP library
++GOMP_LIBS=''
++if test "$enable_openmp" != 'no'; then
++ if test "${GCC}" = "yes"; then
++ AC_CHECK_LIB(gomp,GOMP_parallel_start,GOMP_LIBS="-lgomp",,) # gcc
++ else
++ AC_CHECK_LIB(mtsk,sunw_mp_register_warn,GOMP_LIBS="-lmtsk",,) # solaris cc
++ AC_CHECK_LIB(xlsmp,_xlsmpFlush,GOMP_LIBS="-lxlsmp",,) # AIX xlc
++ AC_CHECK_LIB(mp,mp_destroy,GOMP_LIBS="-lmp",,) # SGI IRIX 6.5 MIPSpro C/C++
++ fi
++ LIBS="$GOMP_LIBS $LIBS"
++fi
++AC_SUBST(GOMP_LIBS)
++
+ dnl files to be generated
+ AC_OUTPUT(Makefile inc/Makefile inc/Minuit2/Makefile inc/Math/Makefile src/Makefile
+ doc/Doxyfile doc/Makefile test/Makefile test/MnSim/Makefile
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -9,6 +9,8 @@
+ # The convenience library to be built.
+ lib_LTLIBRARIES = libMinuit2.la
+
++libMinuit2_la_LIBADD = $(GOMP_LIBS)
++
+ libMinuit2_la_SOURCES = \
+ AnalyticalGradientCalculator.cxx \
+ BasicMinimumError.cxx \