summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2017-08-14 10:57:59 -0500
committerMatthias Maier <tamiko@gentoo.org>2017-08-14 11:01:03 -0500
commit9475103e8faf002aef0a0e4e877b9d28936391e2 (patch)
tree4b4e2eaf9eaf8396e06d921a64b2fb510510a3a4 /sci-libs/nanoflann/nanoflann-1.2.3.ebuild
parentkde-frameworks: Drop KDE Frameworks 5.36.0 (diff)
downloadgentoo-9475103e8faf002aef0a0e4e877b9d28936391e2.tar.gz
gentoo-9475103e8faf002aef0a0e4e877b9d28936391e2.tar.bz2
gentoo-9475103e8faf002aef0a0e4e877b9d28936391e2.zip
sci-libs/nanoflann: initial commit; add version 1.2.3 to the tree
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'sci-libs/nanoflann/nanoflann-1.2.3.ebuild')
-rw-r--r--sci-libs/nanoflann/nanoflann-1.2.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-libs/nanoflann/nanoflann-1.2.3.ebuild b/sci-libs/nanoflann/nanoflann-1.2.3.ebuild
new file mode 100644
index 000000000000..e82a84965d8b
--- /dev/null
+++ b/sci-libs/nanoflann/nanoflann-1.2.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="C++ header-only library for Nearest Neighbor (NN) search wih KD-trees"
+HOMEPAGE="https://github.com/jlblancoc/nanoflann"
+SRC_URI="https://github.com/jlblancoc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-cpp/eigen:*"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eapply_user
+
+ # do not compile examples
+ sed -ie 's/add_subdirectory(examples)//g' CMakeLists.txt || die "sed failed"
+}
+
+src_test() {
+ cd "${BUILD_DIR}" && emake -j1 test
+}
+
+src_compile() {
+ :
+}