summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2018-04-24 10:36:32 -0500
committerMatthias Maier <tamiko@gentoo.org>2018-04-24 10:57:49 -0500
commit27d91842b56c3c40aa61ea6c5c06231434e70580 (patch)
treed2226702ae583d129453856d799e5e96e76c3e03 /sci-libs/netcdf/netcdf-4.6.1.ebuild
parentnet-wireless/kismet: add mostly required python support (diff)
downloadgentoo-27d91842b56c3c40aa61ea6c5c06231434e70580.tar.gz
gentoo-27d91842b56c3c40aa61ea6c5c06231434e70580.tar.bz2
gentoo-27d91842b56c3c40aa61ea6c5c06231434e70580.zip
sci-libs/netcdf: version bump to 4.6.1
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'sci-libs/netcdf/netcdf-4.6.1.ebuild')
-rw-r--r--sci-libs/netcdf/netcdf-4.6.1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sci-libs/netcdf/netcdf-4.6.1.ebuild b/sci-libs/netcdf/netcdf-4.6.1.ebuild
new file mode 100644
index 000000000000..69b0804fd8bd
--- /dev/null
+++ b/sci-libs/netcdf/netcdf-4.6.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="Scientific library and interface for array oriented data access"
+HOMEPAGE="http://www.unidata.ucar.edu/software/netcdf/"
+SRC_URI="https://github.com/Unidata/netcdf-c/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="UCAR-Unidata"
+SLOT="0/11"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+dap examples hdf +hdf5 mpi static-libs szip test tools"
+
+RDEPEND="
+ dap? ( net-misc/curl:0= )
+ hdf? ( sci-libs/hdf:0= sci-libs/hdf5:0= )
+ hdf5? ( sci-libs/hdf5:0=[hl(+),mpi=,szip=,zlib] )"
+DEPEND="${RDEPEND}"
+# doc generation is missing many doxygen files in tar ball
+# doc? ( app-doc/doxygen[dot] )"
+
+REQUIRED_USE="test? ( tools ) szip? ( hdf5 ) mpi? ( hdf5 )"
+
+S="${WORKDIR}/${PN}-c-${PV}"
+
+src_configure() {
+ local myconf
+ if use mpi; then
+ export CC=mpicc
+ myconf="--enable-parallel"
+ use test && myconf+=" --enable-parallel-tests"
+ fi
+ econf "${myconf}" \
+ --disable-examples \
+ --disable-dap-remote-tests \
+ $(use_enable dap) \
+ $(use_enable hdf hdf4) \
+ $(use_enable hdf5 netcdf-4) \
+ $(use_enable static-libs static) \
+ $(use_enable tools utilities)
+}
+
+src_test() {
+ # fails parallel tests: bug #621486
+ emake check -j1
+}
+
+src_install() {
+ default
+ use examples && dodoc -r examples
+ prune_libtool_files
+}