summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-22 04:32:07 +0100
committerSam James <sam@gentoo.org>2021-07-22 04:32:07 +0100
commit34508854fcdf0f22e27969254fc15d6cd5bfe438 (patch)
treedbf065b93fe02fc53115edaddfeeb641cf6ca9ec /sci-libs/openblas
parentsci-libs/openblas: add 0.3.17 (diff)
downloadgentoo-34508854fcdf0f22e27969254fc15d6cd5bfe438.tar.gz
gentoo-34508854fcdf0f22e27969254fc15d6cd5bfe438.tar.bz2
gentoo-34508854fcdf0f22e27969254fc15d6cd5bfe438.zip
sci-libs/openblas: drop 0.3.16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/openblas')
-rw-r--r--sci-libs/openblas/Manifest1
-rw-r--r--sci-libs/openblas/openblas-0.3.16.ebuild198
2 files changed, 0 insertions, 199 deletions
diff --git a/sci-libs/openblas/Manifest b/sci-libs/openblas/Manifest
index 0d1b36ab96c8..282547b8ee46 100644
--- a/sci-libs/openblas/Manifest
+++ b/sci-libs/openblas/Manifest
@@ -2,5 +2,4 @@ DIST openblas-0.3.12.tar.gz 12325103 BLAKE2B 3d6706e59e83f87dd58b287753bf697de99
DIST openblas-0.3.13.tar.gz 12437434 BLAKE2B d8f9d3296506c6148cd506278f0b6a2a4fe50975a7fd3f54108e98e88a13002b1035f5697322ba73df7c6397faee6d0772c1d4d46b66db8e862f17b980dbdf97 SHA512 86e7f496587cc35d7feede99cbe3cf627ef690dd7489bb03b95f7d15ed758e32baf17d79f17b1de187184394233f60a8249a64dd53c3d59a9540db92269b7ee4
DIST openblas-0.3.14.tar.gz 12460465 BLAKE2B 9505ff6e132581ecc86159fb84192c6bbce0f2974293eaf1b4aca6b96b5da85823bfc1bced65a96930674fd4781ea3e375aed09cbdc9930cef26694c9f8e1c80 SHA512 c7d5947ada525a32bc6e97ff94272df9730fa5fb06102e06e80472baedc1a9119d82050cdaede192db15f816ae7143784d7801b61b64fab5b5cf97cdbd5e625e
DIST openblas-0.3.15.tar.gz 12498434 BLAKE2B acf3d15e002686bcd84323616387dcf540b58d57392a4862cb556da58d873a8c40783fc4fdae45170aeb204ede3451843c44e3f5e264f76c9a7486b30b3f4cc7 SHA512 c07964ead5ffe9cf088364697bfe5cb409170663e420bdcd08a6366a028625d2a3c23ee4ddbaf0e625860a9fd08cbbb39f97eb985c366c052696d6f8598a844f
-DIST openblas-0.3.16.tar.gz 12511373 BLAKE2B 7856ffa249f6a18102188b32f40327682c9e5f5fd5430e6bd628fd9b00a852a106a9053fe3116cd349ac35f30126bfa19c2dd9dcdfe79f7748a327bf6e53cf7d SHA512 cf5592fca7ff88ad6dc70fc0d87f6f63d3c76c923ebe9a7f62732739151b460a9b2e0d3a34ca541d7f0fb61e80b30d495020bd2c556fcaa408b9a4155f1b2d1a
DIST openblas-0.3.17.tar.gz 12513037 BLAKE2B bb3a89500f242613a6bed73519702995cf1e82dcfec49f9469ecfd6647121260a4364582dbc257a75212320b5690ba93e75a0f2762dce7f398ef6443b169b4e4 SHA512 a97745c1f050ea44fce5f1722810de469612d374a29796a874d12673d6ad189872160cc2b5d0885790e6562d9d7ade629144c86f2649e668b0d4def36aa74495
diff --git a/sci-libs/openblas/openblas-0.3.16.ebuild b/sci-libs/openblas/openblas-0.3.16.ebuild
deleted file mode 100644
index 4566f928af81..000000000000
--- a/sci-libs/openblas/openblas-0.3.16.ebuild
+++ /dev/null
@@ -1,198 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic fortran-2 toolchain-funcs
-
-DESCRIPTION="Optimized BLAS library based on GotoBLAS2"
-HOMEPAGE="http://xianyi.github.com/OpenBLAS/"
-SRC_URI="https://github.com/xianyi/OpenBLAS/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}"/OpenBLAS-${PV}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="dynamic eselect-ldso index-64bit openmp pthread relapack test"
-REQUIRED_USE="?? ( openmp pthread )"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- eselect-ldso? (
- >=app-eselect/eselect-blas-0.2
- >=app-eselect/eselect-lapack-0.2
- )
-"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.3.12-shared-blas-lapack.patch"
- "${FILESDIR}/${PN}-0.3.10-dont-clobber-fflags.patch"
-)
-
-pkg_pretend() {
- elog "This software has a massive number of options that"
- elog "are configurable and it is *impossible* for all of"
- elog "those to fit inside any manageable ebuild."
- elog "The Gentoo provided package has enough to build"
- elog "a fully optimized library for your targeted CPU."
- elog "You can set the CPU target using the environment"
- elog "variable - OPENBLAS_TARGET or it will be detected"
- elog "automatically from the target toolchain (supports"
- elog "cross compilation toolchains)."
- elog "You can control the maximum number of threads"
- elog "using OPENBLAS_NTHREAD, default=64 and number of "
- elog "parallel calls to allow before further calls wait"
- elog "using OPENBLAS_NPARALLEL, default=8."
-}
-
-pkg_setup() {
- fortran-2_pkg_setup
-
- # List of most configurable options - Makefile.rule
-
- # https://github.com/xianyi/OpenBLAS/pull/2663
- tc-export CC FC LD AR AS RANLIB
-
- # HOSTCC is used for scripting
- export HOSTCC=$(tc-getBUILD_CC)
-
- # threading options
- use openmp && tc-check-openmp
- USE_THREAD=0
- if use openmp; then
- USE_THREAD=1; USE_OPENMP=1;
- elif use pthread; then
- USE_THREAD=1; USE_OPENMP=0;
- fi
- export USE_THREAD USE_OPENMP
-
- # We need to filter these while building the library, and not just
- # while building the test suite. Will hopefully get fixed upstream:
- # https://github.com/xianyi/OpenBLAS/issues/2657
- use test && filter-flags "-fbounds-check" "-fcheck=bounds" "-fcheck=all"
-
- # disable submake with -j and default optimization flags
- # in Makefile.system
- # Makefile.rule says to not modify COMMON_OPT/FCOMMON_OPT...
- export MAKE_NB_JOBS=-1 \
- COMMON_OPT=" " \
- FCOMMON_OPT=" "
-
- # Target CPU ARCH options
- # generally detected automatically from cross toolchain
- use dynamic && \
- export DYNAMIC_ARCH=1 \
- NO_AFFINITY=1 \
- TARGET=GENERIC
-
- export NUM_PARALLEL=${OPENBLAS_NPARALLEL:-8} \
- NUM_THREADS=${OPENBLAS_NTHREAD:-64}
-
- # setting OPENBLAS_TARGET to override auto detection
- # in case the toolchain is not enough to detect
- # https://github.com/xianyi/OpenBLAS/blob/develop/TargetList.txt
- if ! use dynamic && [[ ! -z "${OPENBLAS_TARGET}" ]] ; then
- export TARGET="${OPENBLAS_TARGET}"
- fi
-
- export NO_STATIC=1
-
- BUILD_RELAPACK=1
- if ! use relapack; then
- BUILD_RELAPACK=0
- fi
-
- export PREFIX="${EPREFIX}/usr" BUILD_RELAPACK
-}
-
-src_prepare() {
- default
-
- # Disable tests by default
- sed -e "/^all ::/s/tests //" -i Makefile || die
-
- # if 64bit-index is needed, create second library
- # with LIBPREFIX=libopenblas64
- if use index-64bit; then
- cp -aL "${S}" "${S}-index-64bit" || die
- fi
-}
-
-src_compile() {
- default
- cd interface || die
- emake shared-blas-lapack
-
- if use index-64bit; then
- emake -C"${S}-index-64bit" \
- INTERFACE64=1 \
- LIBPREFIX=libopenblas64
- fi
-}
-
-src_test() {
- emake tests
-}
-
-src_install() {
- emake install DESTDIR="${D}" \
- OPENBLAS_INCLUDE_DIR='$(PREFIX)'/include/${PN} \
- OPENBLAS_LIBRARY_DIR='$(PREFIX)'/$(get_libdir)
-
- dodoc GotoBLAS_*.txt *.md Changelog.txt
-
- if use index-64bit; then
- dolib.so "${S}-index-64bit"/libopenblas64*.so*
- fi
-
- if use eselect-ldso; then
- insinto /usr/$(get_libdir)/blas/openblas/
- doins interface/libblas.so.3
- dosym libblas.so.3 usr/$(get_libdir)/blas/openblas/libblas.so
- doins interface/libcblas.so.3
- dosym libcblas.so.3 usr/$(get_libdir)/blas/openblas/libcblas.so
-
- insinto /usr/$(get_libdir)/lapack/openblas/
- doins interface/liblapack.so.3
- dosym liblapack.so.3 usr/$(get_libdir)/lapack/openblas/liblapack.so
- doins interface/liblapacke.so.3
- dosym liblapacke.so.3 usr/$(get_libdir)/lapack/openblas/liblapacke.so
- fi
-}
-
-pkg_postinst() {
- use eselect-ldso || return
- local libdir=$(get_libdir) me="openblas"
-
- # check blas
- eselect blas add ${libdir} "${EROOT}"/usr/${libdir}/blas/${me} ${me}
- local current_blas=$(eselect blas show ${libdir} | cut -d' ' -f2)
- if [[ ${current_blas} == "${me}" || -z ${current_blas} ]]; then
- eselect blas set ${libdir} ${me}
- elog "Current eselect: BLAS/CBLAS ($libdir) -> [${current_blas}]."
- else
- elog "Current eselect: BLAS/CBLAS ($libdir) -> [${current_blas}]."
- elog "To use blas [${me}] implementation, you have to issue (as root):"
- elog "\t eselect blas set ${libdir} ${me}"
- fi
-
- # check lapack
- eselect lapack add ${libdir} "${EROOT}"/usr/${libdir}/lapack/${me} ${me}
- local current_lapack=$(eselect lapack show ${libdir} | cut -d' ' -f2)
- if [[ ${current_lapack} == "${me}" || -z ${current_lapack} ]]; then
- eselect lapack set ${libdir} ${me}
- elog "Current eselect: LAPACK ($libdir) -> [${current_lapack}]."
- else
- elog "Current eselect: LAPACK ($libdir) -> [${current_lapack}]."
- elog "To use lapack [${me}] implementation, you have to issue (as root):"
- elog "\t eselect lapack set ${libdir} ${me}"
- fi
-}
-
-pkg_postrm() {
- if use eselect-ldso; then
- eselect blas validate
- eselect lapack validate
- fi
-}