summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorswitch87 <gert@pellin.be>2018-03-15 22:05:46 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-05 14:24:22 +0200
commit34251046e57f6eefc3576839fb1c333c8420a604 (patch)
tree7388b8a75b001203bb1d367c8e0bbd794d9091a4 /sci-libs/opencascade
parentdev-util/spec-cleaner: Add myself as maintainer (diff)
downloadgentoo-34251046e57f6eefc3576839fb1c333c8420a604.tar.gz
gentoo-34251046e57f6eefc3576839fb1c333c8420a604.tar.bz2
gentoo-34251046e57f6eefc3576839fb1c333c8420a604.zip
sci-libs/opencascade: Fix build with >=vtk-8.1.0
Closes: https://bugs.gentoo.org/650596 Closes: https://github.com/gentoo/gentoo/pull/7470
Diffstat (limited to 'sci-libs/opencascade')
-rw-r--r--sci-libs/opencascade/files/opencascade-6.9.1-vtk-8.1.patch48
-rw-r--r--sci-libs/opencascade/opencascade-6.9.1-r2.ebuild4
2 files changed, 50 insertions, 2 deletions
diff --git a/sci-libs/opencascade/files/opencascade-6.9.1-vtk-8.1.patch b/sci-libs/opencascade/files/opencascade-6.9.1-vtk-8.1.patch
new file mode 100644
index 000000000000..d1f560320c6c
--- /dev/null
+++ b/sci-libs/opencascade/files/opencascade-6.9.1-vtk-8.1.patch
@@ -0,0 +1,48 @@
+--- a/src/IVtkVTK/IVtkVTK_ShapeData.cxx
++++ b/src/IVtkVTK/IVtkVTK_ShapeData.cxx
+@@ -80,9 +80,9 @@ void IVtkVTK_ShapeData::InsertVertex (const IVtk_IdType theShapeID,
+ vtkIdType aPointIdVTK = thePointId;
+ myPolyData->InsertNextCell (VTK_VERTEX, 1, &aPointIdVTK);
+ const vtkIdType aShapeIDVTK = theShapeID;
+- mySubShapeIDs->InsertNextTupleValue (&aShapeIDVTK);
++ mySubShapeIDs->InsertNextTypedTuple (&aShapeIDVTK);
+ const vtkIdType aType = theMeshType;
+- myMeshTypes->InsertNextTupleValue (&aType);
++ myMeshTypes->InsertNextTypedTuple (&aType);
+ }
+
+ //================================================================
+@@ -97,9 +97,9 @@ void IVtkVTK_ShapeData::InsertLine (const IVtk_IdType theShapeID,
+ vtkIdType aPoints[2] = { thePointId1, thePointId2 };
+ myPolyData->InsertNextCell (VTK_LINE, 2, aPoints);
+ const vtkIdType aShapeIDVTK = theShapeID;
+- mySubShapeIDs->InsertNextTupleValue (&aShapeIDVTK);
++ mySubShapeIDs->InsertNextTypedTuple (&aShapeIDVTK);
+ const vtkIdType aType = theMeshType;
+- myMeshTypes->InsertNextTupleValue (&aType);
++ myMeshTypes->InsertNextTypedTuple (&aType);
+ }
+
+ //================================================================
+@@ -124,9 +124,9 @@ void IVtkVTK_ShapeData::InsertLine (const IVtk_IdType theShapeID,
+
+ myPolyData->InsertNextCell (VTK_POLY_LINE, anIdList);
+ const vtkIdType aShapeIDVTK = theShapeID;
+- mySubShapeIDs->InsertNextTupleValue (&aShapeIDVTK);
++ mySubShapeIDs->InsertNextTypedTuple (&aShapeIDVTK);
+ const vtkIdType aType = theMeshType;
+- myMeshTypes->InsertNextTupleValue (&aType);
++ myMeshTypes->InsertNextTypedTuple (&aType);
+ anIdList->Delete();
+ }
+ }
+@@ -144,7 +144,7 @@ void IVtkVTK_ShapeData::InsertTriangle (const IVtk_IdType theShapeID,
+ vtkIdType aPoints[3] = { thePointId1, thePointId2, thePointId3 };
+ myPolyData->InsertNextCell (VTK_TRIANGLE, 3, aPoints);
+ const vtkIdType aShapeIDVTK = theShapeID;
+- mySubShapeIDs->InsertNextTupleValue (&aShapeIDVTK);
++ mySubShapeIDs->InsertNextTypedTuple (&aShapeIDVTK);
+ const vtkIdType aType = theMeshType;
+- myMeshTypes->InsertNextTupleValue (&aType);
++ myMeshTypes->InsertNextTypedTuple (&aType);
+ }
diff --git a/sci-libs/opencascade/opencascade-6.9.1-r2.ebuild b/sci-libs/opencascade/opencascade-6.9.1-r2.ebuild
index 8eff7a5ab1a6..bf868ce0ef5a 100644
--- a/sci-libs/opencascade/opencascade-6.9.1-r2.ebuild
+++ b/sci-libs/opencascade/opencascade-6.9.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -31,13 +31,13 @@ DEPEND="
tbb? ( dev-cpp/tbb )
vtk? ( || ( sci-libs/vtk[imaging] sci-libs/vtk[rendering] sci-libs/vtk[views] sci-libs/vtk[all-modules] ) )"
RDEPEND="${DEPEND}"
-
CHECKREQS_MEMORY="256M"
CHECKREQS_DISK_BUILD="3584M"
PATCHES=(
"${FILESDIR}"/${PN}-6.8.0-fixed-DESTDIR.patch
"${FILESDIR}"/${PN}-6.9.1-vtk-configure.patch
+ "${FILESDIR}"/${PN}-6.9.1-vtk-8.1.patch
)
pkg_setup() {