summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-23 09:53:04 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-23 10:05:17 +0100
commitf1afa13d5bac109cfd22d2084bc58c4894c3632b (patch)
tree3f6af31e968b9d01aafe8b9938b4cc8515483208 /sci-libs/pastix
parentdev-python/oauth2client: Fix name of S (diff)
downloadgentoo-f1afa13d5bac109cfd22d2084bc58c4894c3632b.tar.gz
gentoo-f1afa13d5bac109cfd22d2084bc58c4894c3632b.tar.bz2
gentoo-f1afa13d5bac109cfd22d2084bc58c4894c3632b.zip
sci-libs/pastix: Version Bump
* drop SMP support for now Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=575392 Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-libs/pastix')
-rw-r--r--sci-libs/pastix/Manifest2
-rw-r--r--sci-libs/pastix/pastix-5.2.2.22.ebuild (renamed from sci-libs/pastix/pastix-5.2.2_p9.ebuild)28
2 files changed, 16 insertions, 14 deletions
diff --git a/sci-libs/pastix/Manifest b/sci-libs/pastix/Manifest
index 882d92409f61..2d3e4d75aa7f 100644
--- a/sci-libs/pastix/Manifest
+++ b/sci-libs/pastix/Manifest
@@ -1 +1 @@
-DIST pastix_release_bugfix9_351ef60.tar.bz2 2526795 SHA256 58f8cc3aa0fdd9029114b48cc8923ea111919ade94a8c43c9fc5cd016110a90d SHA512 2cc25f5861fd7cd1235a7deea8fbdd5a56b6b7812aefb74d6cf4804c1e954fa86b616602f6db91b9abb430be9ee3e2fcd8a91f7c06cebf1edd4bac132d04b2a5 WHIRLPOOL 5e96b630a1d8e4b34cbcc1ed40538019d24b1fe79231996dbc38c1aedc0d9d62545676c47beb87a617bc1ad891fc70ae388733ffae7f03fd90ef4b6b47430654
+DIST pastix_5.2.2.22.tar.bz2 2664470 SHA256 30f771a666719e6b116f549a6e4da451beabab99c2ecabc0745247c3654acbed SHA512 15ecdb10b5229e40f744c1ad54be7cac6560cb92e90df1937c90ca7da290df6bdb6f24a1e1c54197731b9df3e0dcc0b9fa39750479fcf03a0c08c304c5b9df70 WHIRLPOOL 7031f822d3c2f89bd520175a124200303adc2dda56cbae4eb9e011b90d5119c5b96958d648c7e18d034e2845a32ad80385714bfb424260aa62c9f6484a18ce6b
diff --git a/sci-libs/pastix/pastix-5.2.2_p9.ebuild b/sci-libs/pastix/pastix-5.2.2.22.ebuild
index e51bebec2adc..19e3f2487f39 100644
--- a/sci-libs/pastix/pastix-5.2.2_p9.ebuild
+++ b/sci-libs/pastix/pastix-5.2.2.22.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit eutils fortran-2 toolchain-funcs multilib
@@ -15,21 +15,22 @@ inherit eutils fortran-2 toolchain-funcs multilib
# metis?
# commit id: change every version
-CID=351ef60
+CID=
# package id: change every version, see the link on inriaforge
-PID=33558
+PID=35070
# leave empty if this is not a post release bug fix
-PPV=bugfix9_
+PPV=bugfix10_
MYPN=pastix_release
DESCRIPTION="Parallel solver for very large sparse linear systems"
HOMEPAGE="http://pastix.gforge.inria.fr"
-SRC_URI="https://gforge.inria.fr/frs/download.php/${PID}/${MYPN}_${PPV}${CID}.tar.bz2"
+SRC_URI="https://gforge.inria.fr/frs/download.php/${PID}/${PN}_${PV}.tar.bz2"
LICENSE="CeCILL-C"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc int64 mpi smp starpu static-libs"
+#IUSE="doc int64 mpi smp starpu static-libs"
+IUSE="doc int64 mpi starpu static-libs"
RDEPEND="
sci-libs/scotch:0=[int64?,mpi?]
@@ -40,7 +41,7 @@ RDEPEND="
DEPEND="${RDEPEND}
virtual/pkgconfig"
-S="${WORKDIR}/${MYPN}_${CID}/src"
+S="${WORKDIR}/${PN}_${PV}/src"
src_prepare() {
sed -e 's/^\(HOSTARCH\s*=\).*/\1 ${HOST}/' \
@@ -72,6 +73,7 @@ src_prepare() {
-e "s:^\s*\(SCOTCH_LIB\s*?=.*\)lib:\1$(get_libdir):" \
config/LINUX-GNU.in > config.in || die
sed -i -e 's/__SO_NAME__,$@/__SO_NAME__,$(notdir $@)/g' Makefile || die
+ default
}
src_configure() {
@@ -97,12 +99,12 @@ src_configure() {
config.in || die
fi
- if ! use smp; then
- sed \
- -e '/VERSIONSMP.*_nosmp/s/#//' \
- -e '/CCTYPES.*NOSMP/s/#//' \
- -i config.in || die
- fi
+# if ! use smp; then
+# sed \
+# -e '/VERSIONSMP.*_nosmp/s/#//' \
+# -e '/CCTYPES.*NOSMP/s/#//' \
+# -i config.in || die
+# fi
if use starpu; then
sed -i -e '/libstarpu/s/#//g' config.in || die