summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-13 18:40:32 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-13 18:40:32 +0100
commitd0c7e8f4fe367cb344ddf2a9e05626dfac65be40 (patch)
tree84c87eeed607b38727333b7218e5548e24ff0634 /sci-libs/qfits
parentsci-libs/ta-lib: Port to EAPI 7 (diff)
downloadgentoo-d0c7e8f4fe367cb344ddf2a9e05626dfac65be40.tar.gz
gentoo-d0c7e8f4fe367cb344ddf2a9e05626dfac65be40.tar.bz2
gentoo-d0c7e8f4fe367cb344ddf2a9e05626dfac65be40.zip
sci-libs/qfits: Port to EAPI 7
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/qfits')
-rw-r--r--sci-libs/qfits/files/qfits-6.2.0-open.patch5
-rw-r--r--sci-libs/qfits/files/qfits-6.2.0-ttest.patch4
-rw-r--r--sci-libs/qfits/qfits-6.2.0.ebuild22
3 files changed, 17 insertions, 14 deletions
diff --git a/sci-libs/qfits/files/qfits-6.2.0-open.patch b/sci-libs/qfits/files/qfits-6.2.0-open.patch
index 71d2df1a692a..951970da6dc4 100644
--- a/sci-libs/qfits/files/qfits-6.2.0-open.patch
+++ b/sci-libs/qfits/files/qfits-6.2.0-open.patch
@@ -1,6 +1,5 @@
-diff -ur qfits-6.2.0/src/qfits_memory.c qfits-6.2.0.new/src/qfits_memory.c
---- qfits-6.2.0/src/qfits_memory.c 2006-08-24 17:01:56.000000000 +0200
-+++ qfits-6.2.0.new/src/qfits_memory.c 2007-09-21 13:43:19.000000000 +0200
+--- a/src/qfits_memory.c
++++ b/src/qfits_memory.c
@@ -308,7 +308,7 @@
/* Create swap file with rights: rw-rw-rw- */
swapfileid = ++ qfits_memory_table.file_reg ;
diff --git a/sci-libs/qfits/files/qfits-6.2.0-ttest.patch b/sci-libs/qfits/files/qfits-6.2.0-ttest.patch
index ee87bfc702ca..a333a32e0a68 100644
--- a/sci-libs/qfits/files/qfits-6.2.0-ttest.patch
+++ b/sci-libs/qfits/files/qfits-6.2.0-ttest.patch
@@ -1,5 +1,5 @@
---- test/test_tfits.c 2006-04-27 14:08:43.000000000 +0100
-+++ test/test_tfits.c.new 2007-02-23 00:29:41.000000000 +0000
+--- a/test/test_tfits.c
++++ b/test/test_tfits.c
@@ -322,7 +322,7 @@
* Test on BINARY tables
*/
diff --git a/sci-libs/qfits/qfits-6.2.0.ebuild b/sci-libs/qfits/qfits-6.2.0.ebuild
index e98cd4afcfa2..181c4777ba8a 100644
--- a/sci-libs/qfits/qfits-6.2.0.ebuild
+++ b/sci-libs/qfits/qfits-6.2.0.ebuild
@@ -1,23 +1,27 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-
-inherit autotools-utils
+EAPI=7
DESCRIPTION="ESO stand-alone C library offering easy access to FITS files"
HOMEPAGE="http://www.eso.org/projects/aot/qfits/"
SRC_URI="ftp://ftp.hq.eso.org/pub/${PN}/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc static-libs"
-DEPEND=""
-RDEPEND=""
+IUSE="doc"
PATCHES=( "${FILESDIR}"/${P}-{ttest,open}.patch )
+src_configure() {
+ econf --disable-static
+}
+
src_install() {
- autotools-utils_src_install
- use doc && dohtml html/*
+ use doc && HTML_DOCS=( html/. )
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}