summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2021-01-21 19:36:45 +0800
committerBenda Xu <heroxbd@gentoo.org>2021-01-24 15:45:41 +0800
commit21458c9061094f1fa0a47c93c1416c31bc6dc7de (patch)
tree49f630a59daa15e0a656cda0b0d27f3c66143bb9 /sci-libs/rocThrust
parentsci-libs/rocPRIM: HIP parallel primitives for ROCm GPU. (diff)
downloadgentoo-21458c9061094f1fa0a47c93c1416c31bc6dc7de.tar.gz
gentoo-21458c9061094f1fa0a47c93c1416c31bc6dc7de.tar.bz2
gentoo-21458c9061094f1fa0a47c93c1416c31bc6dc7de.zip
sci-libs/rocThrust: ROCm backend for Thrust.
Bug: https://bugs.gentoo.org/650804 Bug: https://github.com/gentoo/gentoo/pull/10724 Suggested-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Suggested-by: Wilfried Holzke <gentoo@holzke.net> Package-Manager: Portage-3.0.12, Repoman-3.0.1 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sci-libs/rocThrust')
-rw-r--r--sci-libs/rocThrust/Manifest1
-rw-r--r--sci-libs/rocThrust/files/rocThrust-4.0-operator_new.patch29
-rw-r--r--sci-libs/rocThrust/metadata.xml18
-rw-r--r--sci-libs/rocThrust/rocThrust-4.0.0-r1.ebuild49
4 files changed, 97 insertions, 0 deletions
diff --git a/sci-libs/rocThrust/Manifest b/sci-libs/rocThrust/Manifest
new file mode 100644
index 000000000000..282c08da9b97
--- /dev/null
+++ b/sci-libs/rocThrust/Manifest
@@ -0,0 +1 @@
+DIST rocThrust-4.0.0.tar.gz 1166346 BLAKE2B 02c89e0c4ab2c888a20b7c956a73012157f2735e6ec76369a1f75fbc17bb3f995d1914106ec58562f28243fbe5f019ac230ac3313b6aacb4d8b868f3ac1f091e SHA512 476aa5706487c5801cc91908806a1a1fcb550171f63e0b2debd9b59b18c7435c484578ec456ccfabc140dd7bca7d9bb432a7ba223946b1fca22e72e7d053af2d
diff --git a/sci-libs/rocThrust/files/rocThrust-4.0-operator_new.patch b/sci-libs/rocThrust/files/rocThrust-4.0-operator_new.patch
new file mode 100644
index 000000000000..2b78fd0053ed
--- /dev/null
+++ b/sci-libs/rocThrust/files/rocThrust-4.0-operator_new.patch
@@ -0,0 +1,29 @@
+# Use copy assignment instead of copy constructor to avoid unavailability of placement new operator.
+# But more likely there is another hidden bug, since this syntax is actually correct.
+# There are still similar syntax remain in other headers, which may cause identical compilation error.
+
+# Suggested by Yuyi Wang <strawberry_str@hotmail.com>
+diff --color -uprN rocThrust-rocm-4.0.0.orig/thrust/system/hip/detail/uninitialized_copy.h rocThrust-rocm-4.0.0/thrust/system/hip/detail/uninitialized_copy.h
+--- rocThrust-rocm-4.0.0.orig/thrust/system/hip/detail/uninitialized_copy.h 2021-01-21 20:42:44.439246148 +0800
++++ rocThrust-rocm-4.0.0/thrust/system/hip/detail/uninitialized_copy.h 2021-01-21 21:13:20.926840762 +0800
+@@ -62,7 +62,7 @@ namespace __uninitialized_copy
+ InputType const& in = raw_reference_cast(input[idx]);
+ OutputType& out = raw_reference_cast(output[idx]);
+
+- ::new(static_cast<void*>(&out)) OutputType(in);
++ out = in;
+ }
+ }; // struct functor
+
+diff --color -uprN rocThrust-rocm-4.0.0.orig/thrust/system/hip/detail/uninitialized_fill.h rocThrust-rocm-4.0.0/thrust/system/hip/detail/uninitialized_fill.h
+--- rocThrust-rocm-4.0.0.orig/thrust/system/hip/detail/uninitialized_fill.h 2021-01-21 20:42:44.439246148 +0800
++++ rocThrust-rocm-4.0.0/thrust/system/hip/detail/uninitialized_fill.h 2021-01-21 21:13:07.022489406 +0800
+@@ -59,7 +59,7 @@ namespace __uninitialized_fill
+ {
+ value_type& out = raw_reference_cast(items[idx]);
+
+- ::new(static_cast<void*>(&out)) value_type(value);
++ out = value;
+ }
+ }; // struct functor
+ } // namespace __uninitialized_copy
diff --git a/sci-libs/rocThrust/metadata.xml b/sci-libs/rocThrust/metadata.xml
new file mode 100644
index 000000000000..b0a23ffc1e09
--- /dev/null
+++ b/sci-libs/rocThrust/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>candrews@gentoo.org</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>gentoo@holzke.net</email>
+ <name>Wilfried Holzke</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ROCm-Developer-Tools/rocThrust</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/rocThrust/rocThrust-4.0.0-r1.ebuild b/sci-libs/rocThrust/rocThrust-4.0.0-r1.ebuild
new file mode 100644
index 000000000000..4ca8a58bad69
--- /dev/null
+++ b/sci-libs/rocThrust/rocThrust-4.0.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Thrust dependent software on AMD GPUs"
+HOMEPAGE="https://github.com/ROCmSoftwarePlatform/rocThrust"
+SRC_URI="https://github.com/ROCmSoftwarePlatform/rocThrust/archive/rocm-${PV}.tar.gz -> rocThrust-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND=">=dev-util/hip-${PV}
+ =sci-libs/rocPRIM-${PV}*"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/rocThrust-rocm-${PV}"
+
+PATCHES="${FILESDIR}/rocThrust-4.0-operator_new.patch"
+
+src_prepare() {
+ sed -e "/PREFIX rocthrust/d" \
+ -e "/DESTINATION/s:rocthrust/include/thrust:include/rocthrust/thrust:" \
+ -e "/rocm_install_symlink_subdir(rocthrust)/d" \
+ -e "/<INSTALL_INTERFACE/s:rocthrust/include/:include/rocthrust/:" -i thrust/CMakeLists.txt || die
+ sed -e "s:\${CMAKE_INSTALL_INCLUDEDIR}:&/rocthrust:" \
+ -e "s:\${ROCM_INSTALL_LIBDIR}:\${CMAKE_INSTALL_LIBDIR}:" -i cmake/ROCMExportTargetsHeaderOnly.cmake || die
+
+ eapply_user
+ cmake_src_prepare
+}
+
+src_configure() {
+ # Grant access to the device
+ addwrite /dev/kfd
+ addpredict /dev/dri/
+
+ # Compiler to use
+ export CXX=hipcc
+
+ local mycmakeargs=(
+ -DBUILD_TEST=OFF
+ )
+
+ cmake_src_configure
+}