summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2020-10-11 15:15:18 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2020-10-11 15:50:37 +0200
commitead3dbad2e9beb6bc3ecde96730c931beb79ebb5 (patch)
tree3bedf084b10e0e58e5e9a647534fbc039578f12c /sci-libs/rtree
parentdev-lang/spidermonkey: security cleanup (diff)
downloadgentoo-ead3dbad2e9beb6bc3ecde96730c931beb79ebb5.tar.gz
gentoo-ead3dbad2e9beb6bc3ecde96730c931beb79ebb5.tar.bz2
gentoo-ead3dbad2e9beb6bc3ecde96730c931beb79ebb5.zip
sci-libs/rtree: renamed from Rtree to rtree
removed old Closes: https://bugs.gentoo.org/738596 Signed-off-by: Dennis Lamm <expeditoneer@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/17885 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'sci-libs/rtree')
-rw-r--r--sci-libs/rtree/Manifest1
-rw-r--r--sci-libs/rtree/metadata.xml17
-rw-r--r--sci-libs/rtree/rtree-0.9.4.ebuild27
3 files changed, 45 insertions, 0 deletions
diff --git a/sci-libs/rtree/Manifest b/sci-libs/rtree/Manifest
new file mode 100644
index 000000000000..405a862ae51a
--- /dev/null
+++ b/sci-libs/rtree/Manifest
@@ -0,0 +1 @@
+DIST Rtree-0.9.4.tar.gz 62017 BLAKE2B 72a979a3b9b9e9e1d18ea8646bbf860413c18420ce40946108c4f2f0e59fcb5bb64971a57936a92714e02e13419f7dc594b2371e4b44a4fd6a3e3986c19f7d85 SHA512 59981ffefedac1162faaa86ea10d7d5503da46c7ae9588a57e1a49214043de5f41bd4836965651d4cd22e7959c37cc6d586d9912568a2aaf693a0afb7895b429
diff --git a/sci-libs/rtree/metadata.xml b/sci-libs/rtree/metadata.xml
new file mode 100644
index 000000000000..d03728e20d7e
--- /dev/null
+++ b/sci-libs/rtree/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>3dprint@gentoo.org</email>
+ <name>Gentoo 3D Printer Project</name>
+ </maintainer>
+ <longdescription>
+ Rtree is a ctypes Python wrapper of libspatialindex that provides a number of advanced spatial indexing
+ features for the spatially curious Python user.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/Toblerity/rtree/issues</bugs-to>
+ <remote-id type="github">Toblerity/rtree</remote-id>
+ <remote-id type="pypi">Rtree</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/rtree/rtree-0.9.4.ebuild b/sci-libs/rtree/rtree-0.9.4.ebuild
new file mode 100644
index 000000000000..a7ec92220226
--- /dev/null
+++ b/sci-libs/rtree/rtree-0.9.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..8} )
+
+inherit distutils-r1
+
+MY_PN="Rtree"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="R-Tree spatial index for Python GIS"
+HOMEPAGE="https://rtree.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+S=${WORKDIR}/${MY_P}
+
+RDEPEND="sci-libs/libspatialindex"
+
+distutils_enable_sphinx docs/source
+
+distutils_enable_tests pytest